Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card


M

miso_media

Hi all,
can anyone tell me the good driver for RIS (dell Optiplex 755 with
intel 82566DM-2) and the procedure to make it work with RIS
(winxpSP3).

I've just used pro2Kxp and did the following instructions but still no
joy:


Microsoft Windows XP and Microsoft* Windows Server* 2003 (32-bit)
==================================================================

1. Create an [IMAGE_ROOT]\$oem$\$1\Drivers\NIC directory if one does
not already exist.

2. Copy all files from the PRO1000\Win32 directory to the [IMAGE_ROOT]\
$oem$\$1\Drivers\NIC directory.

3. Make the following changes to the .SIF file that is used for this
image installation (located in the [IMAGE_ROOT]\I386\Templates
directory):

[Unattended]
OemPreinstall = yes
OemPnpDriversPath = \Drivers\Nic

4. Copy all .SYS files from PRO1000\Win32 directory to the [IMAGE_ROOT]
\i386 directory. Do NOT copy the INF files to this directory.

5. Delete E1000325.PNF, E1E5132.PNF, E1Q5132.PNF, and E1Y5132.PNF (if
present) from the [IMAGE_ROOT]\i386 directory.

6. Extract the .INF files from PRO1000\Win32\RIS_INF\E1000325.ZIP,
E1E5132.zip, E1Q5132.ZIP, and E1Y5132.ZIP to the [IMAGE_ROOT]\i386
directory.

7. Restart the Remote Installation Service.

8. Follow the rest of the Microsoft instructions for adding a new
network driver to the RIS installation.

I usually get the message:
"The operating system image you selected does not contain the
necessary drivers for your network adapter. Try selecting a different
operating system image. If the problem persists, contact your
administrator. Setup cannot continue. Press any key to exit."

I don't know what am i missing.
Please help help
 
Ad

Advertisements

Joined
Sep 2, 2008
Messages
1
Reaction score
0
Intel Driver unpack

To those that need to unpack the Intel drivers from the .exe, go to http://downloadmirror.intel.com/4275/eng/readme.htm and follow the instructions, You can "unpack" the drivers without installing them by using the appropriate switches.

As far as the RISing goes, I have not found an answer to this yet either. If someone has successfully RISed a Dell Optiplex 755 with the Intel 82566DM-2 onboard NIC, let us know please. There are several of us that could really use the info
 
A

Adam Winter

BronzeDodge - If you're still on here. Is there any way you can provide those drivers or maybe have them someplace? We're having trouble imaging Optiplex 755's through SCCM.

THANK YOU!!!!
-Adam



BronzeDodge wrote:

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
19-Jan-08

On Jan 18, 4:51 pm, (e-mail address removed) wrote:

Update: Got a new driver from DELL (support spoke with the engineers).

Apparently the problem is due to the updated drivers containing
multiple languages AND settings for Win2k and WinXP in one file - this
make RIS go boom.

Looks like they've just cut the file down to English only + WinXP
only. And like magic, I'm past the error.

Now I'm onto a BSOD, but hopefully that is more easily solved.

Previous Posts In This Thread:

Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
Been through about 6 different step-by-step guides to try and get this
combo to work but I still get stopped on the "The operating system
image you selected does not contain the necessary drivers for your
network adapter" message.

Anyone found a combination of drivers to make this work with RIS?

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Jan 18, 4:51 pm, (e-mail address removed) wrote:

Update: Got a new driver from DELL (support spoke with the engineers).

Apparently the problem is due to the updated drivers containing
multiple languages AND settings for Win2k and WinXP in one file - this
make RIS go boom.

Looks like they've just cut the file down to English only + WinXP
only. And like magic, I'm past the error.

Now I'm onto a BSOD, but hopefully that is more easily solved.

Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card in Windows XP
Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card in Windows XP
Deployment

Hi BronzeDoger,I am having the same problem and Dell are unable to provide the
Hi BronzeDoger,

I am having the same problem and Dell are unable to provide the drivers for
me. I have given them the link to the this post but still no joy.

Could you please post the driver somewhere/email it to me in a zip so I can
also have a go?

Thanks in advance.

:

Hi It seems I'm in the same state as you.
Hi
It seems I'm in the same state as you. I can install the english version of
XP no matter what I do, but no amount of testing has brought me further than
a BSOD on the Danish version: STOP: 0x0000007E pci.sys
When leaving inf-files as is, the NIC isn't recognized, and no matter what
editing I do in the same inffiles, I end up with a BSOD.
Did you solve youd BSOD problem? How?


:

Get the latest nic driver from the Intel site. This worked for me.
Get the latest nic driver from the Intel site. This worked for me.
Just got to get the storage driver working now...

:

Setting the sata type tp "legacy" avoids the blue screen error when using RIS.
Setting the sata type tp "legacy" avoids the blue screen error when using RIS.
It comes up with "cannot find a hard drive in your machine" otherwise.

:

Alas!
Alas! Already tried that, to no avail.
What localized version of XP did you succeed with? Not by any chance the
Danish?

As for the SATA controller, I assume that the standard way of integrating
disk-controller drivers (txtsetup.oem an so on) will work. I personally use a
piece of software (which my company delivers as a part of its IT specialist
service) that is able to integrate a limitless number of drivers.

:

Make sure the nic drivers are in the base xp image and that they're in the
Make sure the nic drivers are in the base xp image and that they're in the
right places as per the ris structure.
Mine didn't work until I used the driver from the Intel site.
This happened on another Dell Optiplex 520 that had the broadcom chip in it.
It wouldn't play with the driver from the Dell site.

Storage driver - I didn't get chance to try it but if you have just one sata
drive then disable the raid to "legacy" mode and boot from the ris server. I
set the oemsetup.txt and the other .sif lines with the appropriate settings
but I'm not sure if it's this or just disabling the raid that makes it work.
Re-enabling the raid in the bios after the image had been pulled down
doesn't cause problems (I was expecting a blue screen or can't find hard
drive at boot!)
Device manager simply updates and it works.
I didn't get chance to try the storage driver from the Intel site but the
driver on the UK Dell site is "imaging" specific. I got there in the end.



:

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
(e-mail address removed) wrote :

Usually drivers with an installation program unpacks themselves in a
subfolder to %TEMP%, so you might be able to pick them up from there.
Clean the folder before running the installation so the subfolder is
easier to spot.
I've also seen Intel unpacking files in C:\Intel, so check that
location as well.

As an alternative, check the driver in the device manager under the tab
"Driver", and the "Driver Details" button. This lists the files used by
the driver, except for the .inf-file that is renamed to oem??.inf and
placed in c:\windows\inf.


/klaus

I've read all these posts, I downloaded the driver from the Intelsite, but it
I've read all these posts, I downloaded the driver from the Intel
site, but it was a .exe that ran the setup to install the drivers.
Where can I get the .inf and .sys files that are extracted? I've got
a whole lab of these that needs to go in quickly and we can't get past
the NIC driver part.

Any help is appreciated.

Guys,I'm still having trouble with this.
Guys,

I'm still having trouble with this. We downloaded the driver from
Intel, the only one we could find is the multilanguage. I tried those
after extraction, I've tried Dell support, and a couple other
scenarios. We eleveated with Dell but I don't have much confidence we
have two labs full of these that have to be RIS'd. Any help out there
please?

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Feb 11, 9:42=A0am, (e-mail address removed) wrote:

Still no luck on my end. If anyone has it working, could you post this
info:

a) driver used in base Windows XP RIS image (and the source)
b) driver used in the $oem$\$1\Drivers\Nic folder (and the source)

The cut-down driver from DELL gets me past the "operating system
image you selected does not contain the necessary drivers for your
network adapter" message, but I'm still stuck on this BSOD:

"An initialization failure occurred while attempting to boot from the
network"

*** STOP: 0x000000BB (0x00000003, 0xc00000c0, 0x00000000, 0x00000000)

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Feb 12, 4:38=A0pm, (e-mail address removed) wrote:



Intel released a new driver package in February 2008. Included in the
package are RIS specific .inf files in a subfolder AND INSTRUCTIONS -
sweet.

They work like a charm. Now, moving on to the "Setup did not find any
hard disk drives" error - but at least it's progress.

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=3DY&ProductID=3D871&Dwn=
ldID=3D4275&strOSs=3DAll&OSFullName=3DAll%20Operating%20Systems&lang=3Deng

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
(e-mail address removed) wrote :

My Dell D830 in AHCI mode installs fine from my RIS server. IIRC all it
takes is to copy the SATA driver files to i386 and add driver info to
the txtsetup.sif file.

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Feb 14, 2:17 pm, (e-mail address removed) wrote:

Thanks for this discussion, I was able to solve my network card
problem.

And now I have the same problem as you... the hard drive -_-

BUT, I changed something in the BIOS ;

Drives
- SATA Operation
From AHCI to ATA

with this modification, I don't have the message "hard drive not found
bla bla bla..." with my RIS installation

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
I also understand from a NIC standpoint that Dell has acknowledged
issues pertaining to dropouts and is recommended a BIOS update

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
All sorted now? Have we finally cracked it?


:

I had the dropouts.
I had the dropouts. The Intel NIC driver update (link posted
previously) totally solved the problem.

No need for a BIOS update in my case.

- I had a similar HD missing error on an HP.....
- I had a similar HD missing error on an HP..... and disabling USB in the bios
solved it so you may want to give that a try-
Annoying but it worked.

Hi all,can anyone tell me the good driver for RIS (dell Optiplex 755 withintel
Hi all,
can anyone tell me the good driver for RIS (dell Optiplex 755 with
intel 82566DM-2) and the procedure to make it work with RIS
(winxpSP3).

I've just used pro2Kxp and did the following instructions but still no
joy:


Microsoft Windows XP and Microsoft* Windows Server* 2003 (32-bit)
==================================================================

1. Create an [IMAGE_ROOT]\$oem$\$1\Drivers\NIC directory if one does
not already exist.

2. Copy all files from the PRO1000\Win32 directory to the [IMAGE_ROOT]\
$oem$\$1\Drivers\NIC directory.

3. Make the following changes to the .SIF file that is used for this
image installation (located in the [IMAGE_ROOT]\I386\Templates
directory):

[Unattended]
OemPreinstall = yes
OemPnpDriversPath = \Drivers\Nic

4. Copy all .SYS files from PRO1000\Win32 directory to the [IMAGE_ROOT]
\i386 directory. Do NOT copy the INF files to this directory.

5. Delete E1000325.PNF, E1E5132.PNF, E1Q5132.PNF, and E1Y5132.PNF (if
present) from the [IMAGE_ROOT]\i386 directory.

6. Extract the .INF files from PRO1000\Win32\RIS_INF\E1000325.ZIP,
E1E5132.zip, E1Q5132.ZIP, and E1Y5132.ZIP to the [IMAGE_ROOT]\i386
directory.

7. Restart the Remote Installation Service.

8. Follow the rest of the Microsoft instructions for adding a new
network driver to the RIS installation.

I usually get the message:
"The operating system image you selected does not contain the
necessary drivers for your network adapter. Try selecting a different
operating system image. If the problem persists, contact your
administrator. Setup cannot continue. Press any key to exit."

I don't know what am i missing.
Please help help

Remote Unuttented installation
You are required to be a member to post replies. After logging in or becoming a member, you will be redirected back to this page.


Submitted via EggHeadCafe - Software Developer Portal of Choice
Using VSTO Add-In To Automate Frequent Excel 2007 Tasks
http://www.eggheadcafe.com/tutorial...60-39a86ccab5d6/using-vsto-addin-to-auto.aspx
 
Ad

Advertisements

P

Peter Foldes

BronzeDodge passed away over a year ago. You are a deadhead from egghead trying to
join to a 2 yr old post and thread which also passed away 2 years ago

--
Peter

Please Reply to Newsgroup for the benefit of others
Requests for assistance by email can not and will not be acknowledged.
http://www.microsoft.com/protect

BronzeDodge - If you're still on here. Is there any way you can provide those
drivers or maybe have them someplace? We're having trouble imaging Optiplex 755's
through SCCM.

THANK YOU!!!!
-Adam



BronzeDodge wrote:

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
19-Jan-08

On Jan 18, 4:51 pm, (e-mail address removed) wrote:

Update: Got a new driver from DELL (support spoke with the engineers).

Apparently the problem is due to the updated drivers containing
multiple languages AND settings for Win2k and WinXP in one file - this
make RIS go boom.

Looks like they've just cut the file down to English only + WinXP
only. And like magic, I'm past the error.

Now I'm onto a BSOD, but hopefully that is more easily solved.

Previous Posts In This Thread:

Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
Been through about 6 different step-by-step guides to try and get this
combo to work but I still get stopped on the "The operating system
image you selected does not contain the necessary drivers for your
network adapter" message.

Anyone found a combination of drivers to make this work with RIS?

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Jan 18, 4:51 pm, (e-mail address removed) wrote:

Update: Got a new driver from DELL (support spoke with the engineers).

Apparently the problem is due to the updated drivers containing
multiple languages AND settings for Win2k and WinXP in one file - this
make RIS go boom.

Looks like they've just cut the file down to English only + WinXP
only. And like magic, I'm past the error.

Now I'm onto a BSOD, but hopefully that is more easily solved.

Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card in Windows XP
Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card in Windows XP
Deployment

Hi BronzeDoger,I am having the same problem and Dell are unable to provide the
Hi BronzeDoger,

I am having the same problem and Dell are unable to provide the drivers for
me. I have given them the link to the this post but still no joy.

Could you please post the driver somewhere/email it to me in a zip so I can
also have a go?

Thanks in advance.

:

Hi It seems I'm in the same state as you.
Hi
It seems I'm in the same state as you. I can install the english version of
XP no matter what I do, but no amount of testing has brought me further than
a BSOD on the Danish version: STOP: 0x0000007E pci.sys
When leaving inf-files as is, the NIC isn't recognized, and no matter what
editing I do in the same inffiles, I end up with a BSOD.
Did you solve youd BSOD problem? How?


:

Get the latest nic driver from the Intel site. This worked for me.
Get the latest nic driver from the Intel site. This worked for me.
Just got to get the storage driver working now...

:

Setting the sata type tp "legacy" avoids the blue screen error when using RIS.
Setting the sata type tp "legacy" avoids the blue screen error when using RIS.
It comes up with "cannot find a hard drive in your machine" otherwise.

:

Alas!
Alas! Already tried that, to no avail.
What localized version of XP did you succeed with? Not by any chance the
Danish?

As for the SATA controller, I assume that the standard way of integrating
disk-controller drivers (txtsetup.oem an so on) will work. I personally use a
piece of software (which my company delivers as a part of its IT specialist
service) that is able to integrate a limitless number of drivers.

:

Make sure the nic drivers are in the base xp image and that they're in the
Make sure the nic drivers are in the base xp image and that they're in the
right places as per the ris structure.
Mine didn't work until I used the driver from the Intel site.
This happened on another Dell Optiplex 520 that had the broadcom chip in it.
It wouldn't play with the driver from the Dell site.

Storage driver - I didn't get chance to try it but if you have just one sata
drive then disable the raid to "legacy" mode and boot from the ris server. I
set the oemsetup.txt and the other .sif lines with the appropriate settings
but I'm not sure if it's this or just disabling the raid that makes it work.
Re-enabling the raid in the bios after the image had been pulled down
doesn't cause problems (I was expecting a blue screen or can't find hard
drive at boot!)
Device manager simply updates and it works.
I didn't get chance to try the storage driver from the Intel site but the
driver on the UK Dell site is "imaging" specific. I got there in the end.



:

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
(e-mail address removed) wrote :

Usually drivers with an installation program unpacks themselves in a
subfolder to %TEMP%, so you might be able to pick them up from there.
Clean the folder before running the installation so the subfolder is
easier to spot.
I've also seen Intel unpacking files in C:\Intel, so check that
location as well.

As an alternative, check the driver in the device manager under the tab
"Driver", and the "Driver Details" button. This lists the files used by
the driver, except for the .inf-file that is renamed to oem??.inf and
placed in c:\windows\inf.


/klaus

I've read all these posts, I downloaded the driver from the Intelsite, but it
I've read all these posts, I downloaded the driver from the Intel
site, but it was a .exe that ran the setup to install the drivers.
Where can I get the .inf and .sys files that are extracted? I've got
a whole lab of these that needs to go in quickly and we can't get past
the NIC driver part.

Any help is appreciated.

Guys,I'm still having trouble with this.
Guys,

I'm still having trouble with this. We downloaded the driver from
Intel, the only one we could find is the multilanguage. I tried those
after extraction, I've tried Dell support, and a couple other
scenarios. We eleveated with Dell but I don't have much confidence we
have two labs full of these that have to be RIS'd. Any help out there
please?

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Feb 11, 9:42=A0am, (e-mail address removed) wrote:

Still no luck on my end. If anyone has it working, could you post this
info:

a) driver used in base Windows XP RIS image (and the source)
b) driver used in the $oem$\$1\Drivers\Nic folder (and the source)

The cut-down driver from DELL gets me past the "operating system
image you selected does not contain the necessary drivers for your
network adapter" message, but I'm still stuck on this BSOD:

"An initialization failure occurred while attempting to boot from the
network"

*** STOP: 0x000000BB (0x00000003, 0xc00000c0, 0x00000000, 0x00000000)

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Feb 12, 4:38=A0pm, (e-mail address removed) wrote:



Intel released a new driver package in February 2008. Included in the
package are RIS specific .inf files in a subfolder AND INSTRUCTIONS -
sweet.

They work like a charm. Now, moving on to the "Setup did not find any
hard disk drives" error - but at least it's progress.

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=3DY&ProductID=3D871&Dwn=
ldID=3D4275&strOSs=3DAll&OSFullName=3DAll%20Operating%20Systems&lang=3Deng

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
(e-mail address removed) wrote :

My Dell D830 in AHCI mode installs fine from my RIS server. IIRC all it
takes is to copy the SATA driver files to i386 and add driver info to
the txtsetup.sif file.

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
On Feb 14, 2:17 pm, (e-mail address removed) wrote:

Thanks for this discussion, I was able to solve my network card
problem.

And now I have the same problem as you... the hard drive -_-

BUT, I changed something in the BIOS ;

Drives
- SATA Operation
From AHCI to ATA

with this modification, I don't have the message "hard drive not found
bla bla bla..." with my RIS installation

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
I also understand from a NIC standpoint that Dell has acknowledged
issues pertaining to dropouts and is recommended a BIOS update

Re: Window 2003 RIS Server w/ Optiplex 755 & Intel 82566DM-2 card
All sorted now? Have we finally cracked it?


:

I had the dropouts.
I had the dropouts. The Intel NIC driver update (link posted
previously) totally solved the problem.

No need for a BIOS update in my case.

- I had a similar HD missing error on an HP.....
- I had a similar HD missing error on an HP..... and disabling USB in the bios
solved it so you may want to give that a try-
Annoying but it worked.

Hi all,can anyone tell me the good driver for RIS (dell Optiplex 755 withintel
Hi all,
can anyone tell me the good driver for RIS (dell Optiplex 755 with
intel 82566DM-2) and the procedure to make it work with RIS
(winxpSP3).

I've just used pro2Kxp and did the following instructions but still no
joy:


Microsoft Windows XP and Microsoft* Windows Server* 2003 (32-bit)
==================================================================

1. Create an [IMAGE_ROOT]\$oem$\$1\Drivers\NIC directory if one does
not already exist.

2. Copy all files from the PRO1000\Win32 directory to the [IMAGE_ROOT]\
$oem$\$1\Drivers\NIC directory.

3. Make the following changes to the .SIF file that is used for this
image installation (located in the [IMAGE_ROOT]\I386\Templates
directory):

[Unattended]
OemPreinstall = yes
OemPnpDriversPath = \Drivers\Nic

4. Copy all .SYS files from PRO1000\Win32 directory to the [IMAGE_ROOT]
\i386 directory. Do NOT copy the INF files to this directory.

5. Delete E1000325.PNF, E1E5132.PNF, E1Q5132.PNF, and E1Y5132.PNF (if
present) from the [IMAGE_ROOT]\i386 directory.

6. Extract the .INF files from PRO1000\Win32\RIS_INF\E1000325.ZIP,
E1E5132.zip, E1Q5132.ZIP, and E1Y5132.ZIP to the [IMAGE_ROOT]\i386
directory.

7. Restart the Remote Installation Service.

8. Follow the rest of the Microsoft instructions for adding a new
network driver to the RIS installation.

I usually get the message:
"The operating system image you selected does not contain the
necessary drivers for your network adapter. Try selecting a different
operating system image. If the problem persists, contact your
administrator. Setup cannot continue. Press any key to exit."

I don't know what am i missing.
Please help help

Remote Unuttented installation
You are required to be a member to post replies. After logging in or becoming a
member, you will be redirected back to this page.


Submitted via EggHeadCafe - Software Developer Portal of Choice
Using VSTO Add-In To Automate Frequent Excel 2007 Tasks
http://www.eggheadcafe.com/tutorial...60-39a86ccab5d6/using-vsto-addin-to-auto.aspx
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top