USB pnp Printer




I am having a little issue installing a USB printer.
I have created the printer driver components and they seemed to be available
to the build but then when I connect the USB Printer to the device I always
get the "Add hardware Wizard"
1 - Is there a way to disable this and let the install happens automatically?
I have tried changing "driver signing" to ignore but it always get back to
"Prompt". Why is that?

2 - Is there a way to force the install using a commandline tool?

ps; I can install manualy the printer followinf=d the prompts from Add
Printer wizard. Add Hardware wizard seems not able to get thing around


the printer component should be ok since the Add printer Wizard installs
without error.
Keep the printer connected during FBA so that is recognized and set.


Hi Raffaele,
No, it does not like.
I have left the prt on and hw wizard pops up somehow.
I have even added a "runonce" to install the printer using rundll32.
As soon as the build process ends I can verify on control panel/rpinter that
the printer is there and am able to print a test page OK.
Then I thought, ok the printer is installed, lets do another reboot and that
should clear hw wizard, BUT NOT :(

any other thoughts?


Hi LoboMax,
you means that Hdw wizard pops up every time you reboot even if on
preceeding one it was installed and running?
When you reboot before setting it again, the printer is shown in "printer
and fax" folder or reboot makes it disappear?
If it's so this means that settings are not recorded as if your disk is
write protected.
Check if you are using EWF or FBWF keeping your disk read only, symptoms say
regards Raffaele



I do have ewf.
Let me refresh our conversation. I have said at the begining that I can
install the printer driver manually aswering the prompts. if I reboot the
printer will still be there.
What I had done is to get rid of the (man now I can't remember) . here is an
article to rename a .dll that does the discovery, later I found the component
and took it out.
All worked fine. no popups.
then I add the printer with rundll32 printui command.

i went cleaning up the wizards and this component that does the discovery
and now it propmpts that the software (driver) you are installing is not
"Windows Logo blah, blah" Continue, etc
The actual printer driver is definately signed as if I use addprt wizard it
shows a green tick on it.
So what is the matter with XPe? Do you know the dll i am talking about?
Can't find on my cached pages dev***.dll maybe?
thank again


ok, got it

its still to do with "driver signing".
I disabled it from the reg key.
no prompts, all installing automatic.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads