USB Printer installed but not printing


Eli Iser

Hello all,

I'm developing a minimal XPe installation, with my own application as
the shell. My application requires a printer, which is connected via
To install the printer I simply call "RUNDLL32.exe
PrintUI.dll,PrintUIEntry /il" at the first run of the application.
Currently I'm experimenting with a Lexmark T644 printer, connected to
the USB port of the target computer.
Now, the installation goes well (I install with the 'have disk'
option, with the drivers supplied with the printer, to support any
printer), and at the end I even manage to print a test page. I choose
the USB001 port for the printer.
However, when trying to print from my application, or even from
notepad (after putting notepad.exe as the shell), nothing gets
printed. The "Printing page x..." popup shows up, but the printer does
I tried making a demo program for printing in C# (the application is
in .NET as well), using the System.Drawing.Printing. The printer I
installed is enumerated okay with PrinterSettings.InstalledPrinters,
and the PrinterSettings.IsValid with the printer in the PrinterName
returns true. Printing, however, returns the same result as the
application and notepad - "Printing page x..." is shows, but nothing
gets printed.

I've added practically all the USB components (despite my wishes to
exclude any USB support aside from a printer), and everything that
looks even remotely related to printing.

Anyone might help me with this problem? I've searched through the
entire archive of the group, but nothing helped.

Kind regards,
Eli Iser

Sean Liming \(MVP\)

With HP printers, I have to enable the help system in the image for the
driver to work.

In Target Design, go to the configuration settings page, selest other
settings, and uncheck "Do not copy help files for this configuration"


Sean Liming /
Book Author - XP Embedded Advanced, XP Embedded Supplemental Toolkit

Eli Iser

Thank you for the suggestion, but I found the problem.
Apparently, I was missing the "USB NT Hardware Detect" component. I
found this after a tedious manual diff with a previous version that
did have printing, but also a lot of junk.
At the end I was able to disable all USB aside from the printer (HID
and storage devices).

Hopefully someone else will find this helpful.

Eli Iser

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question