Windows 2003 RIS ERROR


C

Cody

Hello friends:

I have setup a Windows 2003 RIS server, and it has few images on it. But I
have no luck importing those images to the client machines. I get error
message "The operating system image you selected does not contain the
necessary drivers for your network adapter. Try selecting a different
operating system image. If the problem persists, contact your administrator.
Setup cannot continue. Press any key to exit" . I even got the hot fix from
Microsoft for this problem, still no luck. I have installed service pack 1
for windows server 2003 still no luck.

Your help in this matter would be greatly appreciated.

Regrads.
 
Ad

Advertisements

K

Kevin McNiel [MSFT]

This issue is often caused by not having the correct driver for the adapter.
If you have a system that has the driver installed correctly, check Msinfo32
for the PNP ID and compare it to the INF file that you are using for the
adapter to confirm that it is listed. If it is, try copying the driver files
to the i386 folder in addition to the driver folder.

You may have seen both of these articles, but if not, look at:

823658 "The operating system image you selected does not contain the
necessary
http://support.microsoft.com/?id=823658

315074 Error Message: The Operating System Image You Selected Does Not
Contain
http://support.microsoft.com/?id=315074

Kevin McNiel, MCSE/MCSA
Platform Server Setup Group

This posting is provided "AS IS" with no warranties, and confers no rights.
Please reply to the Group only, This address cannot receive incoming
messages.
 
G

Guest

Hi

I agree with Kevin this issue occurs due to incorrect drivers but there is a
work around for this issue.

Try to copy NIC drivers in CD Base Image under i386 directory. Then Refresh
the following services:
Remote Installation
BITS
Trival FTP

After which you can try to deploy the image. Hope fully you will be able to
deploy if the we have copied the drivers in the CD Base Image.

This is know issue with Intel Pro 100/1000 and Boadcom Network Adapters.
Intel is also knows about this issue and they have modified there files which
you can download from there site.


Shitiz Vohra
 
Joined
Jun 11, 2005
Messages
88
Reaction score
0
Hi

I can confirm that the broadcom nic 44xx work perfectly with ris but you do need sp1 - check the version of your binlsvc.dll againt the one in the previuos posters MSKB articles

Also there is a specific file structure yo must create under the i386 and a couple of lines you need to put in the [unattended] section of the .sif answer file

once you have done that reboot the srver or restart the above mentioned services and your good to go

Regards

S
 
Joined
Feb 20, 2008
Messages
1
Reaction score
0
I had the same problem as Cody

mine was the Intel 825xx Gigabit Platform LAN Network card

I copied the drivers to the i386 directory and restarted the server - worked like a charm !
 
Ad

Advertisements

Joined
Apr 24, 2008
Messages
1
Reaction score
0
**

Hi i'm having same problem as Cody also. Like venum i have a Intel 825xx gigabit lan card. But i've tried to put the drivers in the i386 dir but didn't work shall i do something to the drivers or put them in some other folders or anything? or shall i follow this guide http://support.microsoft.com/kb/246184/?
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

RIS in Windows 2003 0
Windows 2003 RIS 11
Server 2003 RIS error 1
RIS on Windows Server 2003 2
Windows 2003 RIS Server 0
2003 RIS Login Error 1
Windows 2003 RIS Question, 0
RIS and Windows 2003 Server 0

Top