Windows 2000 Terminal Server printing


K

Krish

There is a need to access a DOS program residing in Windows 2000 Terminal
server. The Terminal server creates a port (TSxxx) for the printer remotely
connected to the remote computer. Running a test page was successful.
However I am unable to use net command to map the remote printer as LPT1. Is
there a simpler way to connect the printer so that using DOS program a
report can be printed to the remote printer?

Thanks

Krish
 
Ad

Advertisements

G

Guest

I have a similar question.

I got an answer from another forum entirely, but haven't
had time to try it yet. Here it is, since neither of us
has gotten an answer here:

"you may want to not capture the port until AFTER you log
onto term serve... you can actually utilize a network
printer or any other port type with terminal services by
adding this key to your registry (on the client machine)
under
LOCAL_MACHINE/SOFTWARE/MICROSOFT/TERMINAL_SERVICES_CLIENT
add a key called FilterQueueType .. then right click that
new key and go to New dword value... give it a value of
ffffffff and then close out of the registry... you may
have to reboot but it might work right out of the box...
you will then have access to any printer regardless of
port type... then term serve over and find the printer
and THEN capture the port... printing from dos should
then work... can you tell ive been thru this before? heh"

It doesn't sound quite right to me, because the capture
is still going to be of TSXXX something, which seems to
be the confusing part for both you and I. I'm also
considering trying \\machinename\TSXXX, and then I'm
going to try actually sharing the printer on the server.
I dunno whether that will work with the way things get
disconnected when one logs off ...
 
Ad

Advertisements

K

Krish

Even though I did not get an answer, I browsed the Newsgroup for similar
postings and I got the answer and it works. The key is when the client is
connected to TS, the client printer that is added, has to be shared in TS.
Then you can use the net use command for the desired lpt ports and it will
work perfectly.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top