User cannot open custom Organizational Form


T

teenzbutler

I am running terminal server with Windows Server 2003 SP2/Office 2003 SP3. I
installed Office SP3 a few days ago. As a result, all my custom forms were
non-functional. I had to republish the forms in the Organizational Forms
Library. Eveything has been working fine. For some reason, one user is
unable to open the organizational forms. I cleared their form cache but that
did not work. When you open the form (Tools>Forms>Choose Forms...), the user
receives the following error:

"The form you selected could not be displayed. The form required to view
this message cannot be displayed. Contact your administrator."

I also saved these forms to a network folder. All other users are able to
open the forms from the folder. However, when this user does, they receive
the following error:

"The custom form could not be opened. Outlook will use an Outlook form
instead. The form required to view this message cannot be displayed.
Contact your administrator."

The permissions on this folder is set to Everyone. This user had no problem
accessing the forms yesterday. No updates were done on the system last
night. Does anyone have any information. Again, Thanks.
 
Ad

Advertisements

S

Sue Mosher [MVP-Outlook]

Custom forms generally will not work as expected if you save them as ..oft files to a network folder.

The message you're getting for the published form suggests a forms cache issue. When you cleared the cache, did you delete all the items in the user's Forms folder or just use the OUtlook command? (Try the former.) Also check to make sure the user has write permission on the Forms folder.
 
T

teenzbutler

Thanks for you reply. All my forms are saves as .msg. When I cleared the
cache, I used the Outlook Command. Can you tell me where the forms folder is
located. Does every user have their own specific forms folder?
 
S

Sue Mosher [MVP-Outlook]

Each user has their own cache. The location of the forms cache depends on the operating system, where %username% is the environment variable containing the user's login name:

Windows Vista - C:\Users\%username%\AppData\Local\Microsoft\FORMS
Windows XP - C:\Documents and Settings\%username\Local Settings\Application Data\Microsoft\FORMS

Delete the Frmcache.dat file and all the subfolders.

If that doesn't work, you might try creating a new Outlook profile for the user.

For the record, .msg files are not themselves forms -- certainly not in the sense of being reusable code/UI templates. They are items that may be linked to a published custom form. In that regard, they should show the same behavior as items opened from an Outlook folder.
--
Sue Mosher, Outlook MVP
Author of Microsoft Outlook 2007 Programming:
Jumpstart for Power Users and Administrators
http://www.outlookcode.com/article.aspx?id=54
 
T

teenzbutler

Thanks for your response Sue. I deleted the cache, however, that did not
work. I also created a new profile, and that did not work either. We use
the XPRINT Add-On. I tried disabling that but that didn't work either. Do
you have any other recommendations?
 
Ad

Advertisements

T

teenzbutler

THanks for your reply Sue. I was able to resolve the issue. It appears the
users "UsrClass" was locked on our terminal server. I had to reboot our
servers then delete their caches profile. After deleting the profile, I
logged on as them and was able to open the forms.

Thanks again for all you guys do :)
 
T

teenzbutler

Hi Sue. I have one more anomoly. Anytime a user tries to forward a form,
they receive "Operation failed". Forwarding is enabled on the form. I
discovered the buttons to edit the form are disabled (greyed out). Do you
think this may be the cause? If so, what do you think would cause those
buttons to be disabled? I am logged on as Administrator and have full rights
to the form.
 
S

Sue Mosher [MVP-Outlook]

On the Actions page of the form, in design mode, check to make sure that the form associated with the Forward action is the same as this published form. If not, change it, increment the version number, and republish.

As for the buttons, you didn't say how you're getting to those buttons (or even really which buttons you mean). You should be able to get into design mode using the Tools | Forms | Design a Form command.

--
Sue Mosher, Outlook MVP
Author of Microsoft Outlook 2007 Programming:
Jumpstart for Power Users and Administrators
http://www.outlookcode.com/article.aspx?id=54
 
T

teenzbutler

Thanks for your reply. Sorry for not elaborating. The buttons I am
referring to are when you go into Design this form, then you have Edit
Compose Page and Edit Read Page. Both of those options are disabled. Next,
the form associated with the Forward action is the same as the published
form. Unfortnatlely, that does not work either. I tried creating a new form
and copying the fields from the original over to the new one, but that didn't
work either.
 
Ad

Advertisements

S

Sue Mosher [MVP-Outlook]

If the Edit Read/Compose Page buttons are disabled, that indicates that the form is set up to have only one layout. You can change that if appropriate with the Form | Separate Read Layout command.

Is there any code in the Item_Forward event handler? Is the Forward action set to send immediately, display, or use user's default?

--
Sue Mosher, Outlook MVP
Author of Microsoft Outlook 2007 Programming:
Jumpstart for Power Users and Administrators
http://www.outlookcode.com/article.aspx?id=54
 
T

teenzbutler

I think I figured it out. It doesn't like my BCC field. We need to be able
to BCC a user every time someone sends this form. Then, some users will
forward the form to another user. Again, it needs to be BCCed.

As for your other questions, I do not see any code in the Item_Forward event
handler. The form is set to send the form immediately. I tried all
different settings. The only thing that works is to remove the BCC all
together. Do you know a work around for this?

, which has a checkmark next to "Set the initial value of this field to:".
I have the persons email address in that field. I also have the "Calculate
this formula automatically" enabled. is set to calculate automatically
 
S

Sue Mosher [MVP-Outlook]

So what is your form actually doing with the Bcc field? I presume you're using code to set the value. Are you also calling Recipients.Resolve? Outlook can't send a message that has unresolved recipients.

--
Sue Mosher, Outlook MVP
Author of Microsoft Outlook 2007 Programming:
Jumpstart for Power Users and Administrators
http://www.outlookcode.com/article.aspx?id=54
 
T

teenzbutler

I was able to resolve the issue with the BCC field. I am not sure what I
did, but it now works. My last issue is, the To: and From: fields will not
print. The setting "Include this field for Printing and Save As" is enabled
on these fields. What happens is, after a user sends the form, the recipient
opens the form and prints. Once printed, the Subject and all the information
within the form is printed. The From: and To: fields are blank, even though
you can see them on the screen. It is perplexing. I am using the XPrint
add-on. If I remove the add-on, the form won't print at all. Do you have
any recommendations on how we can get the To and From fields to print?
 
Ad

Advertisements

T

teenzbutler

I got it. I created a Label and tied the From and To control to the label
instead of a text box. It liked that better.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top