USB Printer Problem in XP - test page works, not much else



I have a strange problem with XP printing. Printer was working properly at
one time but now cannot print from Office, Notepad, Wordpad. I tried loading
a different word processor, also cannot print.

Printing is successful from "Print Test Page" AND from web browser, but
cannot print from Office et al. Paper/pages advance, but no text.
Cartridges have ink. USB printer (HP 812C), no network.

Any ideas?

Cari \(MS-MVP\)

Are you using File, Print from the toolbar or simply clicking on the printer
icon? Is this a blank document you started with, or a previously
edited/saved one? If it's a previous save, try creating a document from
scratch, then saving it and using File, Print, make sure you are chosing the
correcty printer to print to.

I would also suggest a complete uninstall and reinstall in case of corrupted
printer drivers, using:

Remember not to miss out Step 4, or all you will do is install the old, and
possibly corrupted drivers.


Thanks Carl for your response.

Have tried printing from a variety of positions. Ctl-P, File/Print,
Print Icon. All fail to actually print the text...saved and
created...but in all cases advances the paper in the printer. Print
Preview shows correctly.

Failure to print from Notepad, Wordpad, Word, and I even installed
Abiword...all same problem.

Going to Printers and Faxes...selecting properties for the particular
printer, and printing the Test Page works! So does printing from
Mozilla Firefox and Mozilla Thunderbird!

Will try the Article One suggestion...note that the printer driver is
local to Windows XP - the HP 812C printer. No new drivers available
from HP...they say just install the Windows XP version.




Tried your suggestions...uninstalled the printer and drivers per
Coribright Article One, restarted the computer, reinstalled the printer,
successfully printed the Printer Test Page, but still could not print
from any wordpad, etc. According to HP, the drivers in XP are current
and they don't offer any others.

Like before, printing did work from browser and Adobe Reader printing a
PDF file.



Thanks Cari. Problem resolved. Replacing the black printer cartridge,
re-enabled printing.

I don't know the original level of ink in the cartridges, but it is strange
that some programs - Adobe PDF reader, Firefox, Thunderbird - had no problems
printing, including the Windows Printer Test Page, but programs such as Word,
Abiword, etc. could not print.

p.s. posts to the web site are significantly delayed from the conventional
news several days!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question