USB Mass storage device shows up in device man but not in disk man


M

majestik

Ok,

I have a USB Mass storage device that I connect via a powered hub to
my laptop. It has worked in the past, but for some reason, it
recognizes it as a Mass Storage device, then a popup says found new
disk drive.

I go into Device Manager, and there it is. It is recognized correctly
and working fine. When I then go into Disk management I do not see it.
I have a c partition on my laptop hard drive, and also an e. I do not
see any other drives.

Why is my USB drive not assigning a drive letter to it, and why is it
no showing in disk management? I have another JUST like it, and it
works just fine, plug and "pray" works and assigns it a drive letter.

Any ideas? I have tried editing the registry, changing some drive
letters of devices taht have connected in the past. I have tried
uninstalling/reinstalling the device in Computer Management.

Thanks for any help you can give me!

JJ
 
Ad

Advertisements

R

R. McCarty

Add a System Environment Variable:
DevMgr_Show_NonPresent_Devices
and set it's value = 1

Open Device Manager, Click View - Tic/Check "Show Hidden Devices"
Expand the categories "Universal Serial Bus Controllers", Storage Volumes
and Disk Drives one at time and Right Click each entry shown in a
diminished tone (grayed out) and choose Uninstall.
*Do this with all Flash based devices unplugged.
Then re-insert your Flash drives and check Disk Mgmt for a proper
Drive letter assignment.

Bump.

Does anyone have any idea what I can do to get this working?

Thanks,
Jim
 
M

majestik

Yeah, that is the first thing tha came up in a search. It doesn't show
in Disk Management (that is the weird part for me).
 
Ad

Advertisements

M

majestik

This is definitely something I have NOT tried, thanks! I will give it
a go when I get home tonight.

Thanks again all for replying!!!

JJ
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top