TS Printer Configuration w/Epson Receipt Printer



Client runs VB6 application on thin client environment.
Roughly 30 remotely connected users.
Epson TM-88II Receipt Printers are attached to local printer ports on
numerous machines.

The initial installation was on Windows 2000 Server & Desktops. The Epson
receipt printers were attached locally & cofigured to LPT1. Upon connecting,
the printers were visible and accessible to the application. I'm not sure at
this point about the 'approved compatibility' with Windows 2000, but I don't
believe that the printer driver that was used was in compliance. However, it
worked without any visible issues (ie: the printer came available, print jobs
were sent, and the print jobs executed fine; no errors were reported in the

In the past year, the client PCs were upgraded to Windows XP Pro. The
migration went smoothly and no problems were observed with the receipt
printers. (As noted the installation occured numerous months ago so any
problems which would have appeared had plenty of time to manifest.)

Current Issue:
The server was upgraded to Windows Server 2003. Most print jobs work out
just fine, however, there are many which fail. In addition, users
occassionally get booted from their TS session for no apparent reason.
Nothing is logged in the event logs which appears to coorespond to these
spontaneous exits. The spontaneous exits do not affect all users when they
happen - only individual users are affected.

I figure that it is possible that these problems are related. I have
noticed events in which the print spooler is noted to have failed. So my
solution is to get the latest printer driver for the printer. From what I
have found, MS does not produce a printer driver for this printer, so I am
left with using the 3rd party driver - if any ideas can be floated in which I
can use a stock printer driver for this printer, I am all ears for that.

So where that leaves me is that when I install the latest Epson printer
driver on my machine, it creates its own Epson ECP port, which is not an LPT
port, although it seems to tell me that it related to LPT1 somehow. But when
I connect to a TS session, a redirect does not occur for the printer, and no
error is logged in the System log regarding a missing printer driver, or
other reason for not mapping the printer. My hunch is that this is because
the printer is not really on LPT1 and therefore is not being seen during the
redirection process. Can anyone validate this or tell me how to validate it?
Do I have any options on other means of connecting this printer using the
updated driver?

Here's what I tried:
1) I did the Epson setup on my machine - this gave me the printer on a port
named ESDPRT001 (described as LPT1). A printer test page showed that this
printer worked fine.
2) I fired up a session on the TS
3) In my TS session, I checked my printers - as suspected, the printer was
not there
4) Still in the TS session, I added a new printer and told it to use the
port named TS000 (MACHINENAME: LPT1) and set it to use the older Epson
printer driver. (Ooops - I didn't try a test page before...)
5) I logged off the TS session and fired up a new one
6) I checked my printers in the TS session - voila - the printer is now
mapped (ie: it appears as 'Epson TM-88II (from MACHINENAME) in session 3'
rather than 'Epson TM-88II' as it did when I installed it during the previous

Any thoughts? Should this be my solution? Does it make sense?

Unfortunately, I'm out of thermal receipt paper now so until I get to the
store, I can't tell if the test pages are coming up good or as a bundh of


How fancy are the receipt printouts? Any graphics,
special effects, fonts?

I ask because many of the Point of Sale programs I have
worked with will just send printer language commands
to the lpt port for receipts. If this is the case you could set
things up with the generic text driver for the mapping.

There may be other native Epson drivers on the server
that are similar enough to your printer for things to

Your hunch about the epson port name affecting the
autocreation process is correct. In order to use a port
that doesn't begin with com, usb, lpt, you need to:

Make this registry addition:



Use one of the newer Remote Desktop
Client versions:




Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question