Solution! Windows cannot initialize the device driver for this hardware. (Code 37)


E Brent Price

I was about to post here with my problem when I stumbled over a solution.

I have a recent upgrade from 2KPro to XPpro and I've been installing and
uninstalling right and left for days, so I don't know what caused it but
suddenly I couldn't see my CD/DVD.

The device properties said "Windows cannot initialize the device driver for
this hardware. (Code 37)"

I tried the uninstall/rescan trick, no luck. Then I came across this simple
registry fix in a forum:

"Run REGEDIT, open up the following folders:
{4D36E965-E325 -11CE-BFC1-08002BE10318}

After clicking on {4D36E965-E325 -11CE-BFC1-08002BE10318} you should see two
settings on the right-hand side:

Click on each of them, press DELETE and click YES.

Rescan h/w in Device Manager, it worked for me, my DVD writer is back.

The theory is that something you installed lately created this problem. In
my case I don't remember what, maybe RealPlayer, or GEnie Backup Manager
Pro. I still have to find the culprit.

Tell me if this work.


The only thing to add is to delete the CD from Device Manager before
scanning for changes and reboot after that.

You can see by the thread that this affects several brands including Sony,
Plextor and Pioneer (mine).

MicroSoft People: take note. MS KB was little help.


In E Brent Price had this to say:

My reply is at the bottom of your sent message:
MicroSoft People: take note. MS KB was little help.

It's there - you just have to find it, it's hidden.

Galen - MS MVP - Windows (Shell/User & IE)

"Chance has put in our way a most singular and whimsical problem, and
its solution is its own reward." - Sherlock Holmes

Yves Leclerc

This is a known problem for some time now. Usually happens when you have a
third party DVD/CD driver added, like Roxio's DirectCD (Drag to CD.)

E Brent Price

Bob I said:
Humm, what did you search for? It's been there for awhile.

I entered the entire error message verbatim:

"Windows cannot initialize the device driver for this hardware. (Code 37)"


Bob I

Ok, might I give a suggestion. Start simple and work up. Long strings
are generally counter productive in that you limiting it by complexity.

I searched "CD-rom is missing" (without the quotes).
Nov 9, 2014
Reaction score
Thanks a lot for the soluion it work for me :thumb: in my case I deleted the upper filter key; (It was only one I found my registry ,no lower filter ) then CD-rom was come back.:lol:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question