SLOW speed xp network problem


R

RedStar

scenario: 1 win2000 sp 4 platformed hardwired into a linksys wireless G
router and 1 XP 1.7 Ghz intel platformed connected to same router using a
linksys wireless g pci adapter cord (video cable prevents antenna from
going vertical). Both computers share internet (DSL rated at 1.5 Mbps/320
upload).

Problem: The win2000 tests out at the max 1.47 Mbps dwnload speed/300kbps
upload speed (using DSL reports web site). (YAY)

HOWEVER, the XP platform tests out at a dismal 166kbps download but still
maxing out the upload channel at 300kbps. (BOOO!)

The connection is more than 8x slower than it should be while strangely
having no trouble with the upload speed.
The problem includes just trying to file share between the 2
computers..dwnloading to the XP platform takes forever. But if i grab a file
from XP platform, it goes fast.

------------------------------------------------------
Strange behaviour: downloading 1 file may go at 33 KBytes or 50KBytes a
second (or some other low figure) on XP, yet the winXP platform IS still
capable of downloading multiple files at same time for a total approaching
the max speed of 1.5 Mbps.

(this is definately NOT a cap on any web server throughput as my win2000
platform was downloading each file tested at my full DSL speed limit ..near
the same time)


Remedies tried.
1) Disabled/uninstalled Zone alarm pro and a download accelerator ..result
was no diff (except the dwnloads were even slower without the accelerator)
2) tried several ajustments like mtu size/beacon time etc.. as indicated by
linksys support. result was that performance DROPPED another 10%.

3) moved computer 10 ft away from the router. Result was NO change.

4) Disabled the wireless connection and enabled the built in Intel 100 Ve
adapter and plugged the cable into the XP platform (using the same cable
that my win2000 platform was using). Result was NO difference in speed.

5) removed any unneeded protocals ..in this case it was just QoS.

6) Turned off win2000 platform so that just the winXP platform was running.

7) Triple-triple checked that there was no spyware or other extrtaneous
software running in background.

So i think i have ruled out the connection/ISP/router/adapter (adapter
serttings) as being the problem...

It seems to me there is something about XP that is limiting my connection
but i can't see any settings to fiddle with.

How can I get the max network speed out of XP like my win2000 platform is
enjoying???

this is driving me crazy now, so a big

TIA if ya can help end my suffering = )
 
Ad

Advertisements

R

RedStar

going to DSLREPORTS.com
i finally found that the RWIN seting was at fault.
I downloaded their little program that allowed me to change this setting in
XP (i think some modem optimization had set this rate even lower than
default to about 7900)

a setting of 39 000 for a 1.5 Mbit connection, now lets DSL connection gets
its full speed.

YAYA! :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top