Scheduled Tasks problem, affects security


G

Guest

Hello all.

I've noticed that my Scheduled Tasks (not sure about the english
translation) never run. The log file for Scheduled Tasks says that "Empty
passwords are not allowed", but i havent set up any password for my user
account. So i cant enter any password for the task, and when i do the log
file says "Invalid password". (obviously)

This is annoying of course, but also my antivirus and firewall program uses
a Scheduled Task to scan my hard disk for viruses, and that task hasnt ever
run, and i didnt know why until now. So this could be a security problem too,
a small one :).

Please fix this problem.

I'm using XP home Service pack 1A.

/Olle
 
Ad

Advertisements

Ad

Advertisements

D

Doug Knox MS-MVP

The security problem would be to allow Scheduled Tasks to run with out a password. By default, XP only allows the use of blank passwords for the local console logon session. There is a work around, but it is what creates the security hole, as all an attacker would need is your username, without the requirement for a password.

For XP Pro: Start, Control Panel, Administrative Tools, Local Security Policy, Local Policies, Security options.

In the right hand pane (third down). Accounts: Limit local account use of blank passwords to console logon only. This is enabled by default, disable it.

For XP Home: Click Start, Run and enter REGEDIT Go to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

In the right pane, locate the Value "limitblankpassworduse"

Data: 0 (disabled) 1 (enabled)

It is enabled by default. Disable it and scheduled tasks should run.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top