RRAS won't start (7024 & 20103)


Martyn Alner

I have a customer with an SBS 2000 Server which yesterday
had RRAS working perfectly. Today he does a Windows
update and reboots and RRAS refuses to start. The
following errors appear:

Event ID 7024
The Routing and Remote Access Service terminated with the
service-specific error 2

Event ID 20103
Unable to load d:\WINNT\system32\iprtrmgr.dll

Now there is a KB article 299013 which I have followed
and all reg entries and dlls are correct. It also says
about removing TCP/IP and reinstalling it, but I would
rather do that as a last resort.

Has anyone got any idea? Anything would be gratefully


Martyn Alner
Phoenix IT (UK)


Same exact problem and 299013 - just's toasts tcpip ---
but doesn't resolve...Better have a system state backup
before you remove tcpip - what a nightmare...

Any ideas...anyone...

Tried uninstalling sp4..and reinstalling sp3...doesn't
help...have removed and reinstalled
nic...repeatedly....have tried another brand nic....in
both sp3....tried reinstalling sp4.....Have seached for
and removed ghost adapters and duplicate addressing
entries in registry


This is a exchange 2000 server...which is already a
nightmare to install...I do not want to have to reinstall
all of this....

Any ideas???????????????PPPPPPPPPPLEEEEEZE

Alex Goudriaan

The hdd of an existing W2k Server with terminal services
and ras with vpn is too small. I made a full backup and
installed a new w2k on a new hdd. I restored the whole
system, following the correct procedure.
The system works fine, but RAS won't work. I also get the
event id: 20103
Source: router
description: unable to load c:\winnt\system32\iprtrmgr.dll

I followed the articles:
KB299013 routing and RAS does not start and event id
20103 message is logged
KB299451 how to: remove and reinstall tcp/ip on a windows
2000 domain controller
KB284955 event id 4191: ip could not open the registry
key for adapter tcpip\parameters\adapters\ndiswanip

Nothing helped and I had to put the small hdd back into
the system. I really hope someone knows the right
solution to solve this big problem. The only thing I can
do now is to install and configure a new system.

Best regards,


I phone MS and paid for a support incident, and they got
me to remove a modem that was still in the Modems part of
Control Panel even though there was no physical modem in
the Server. This cured it.

They also suggested installing MDAC 2.7 Refresh, and if
not then they have sent me a little exe which is supposed
to reinstall RAS



Alex Goudriaan

Thanks, Martyn,
My server has no modems installed, but I'll try the mdac
thing. I'll let you know at the end of the week if it
Best regards,

Ian Hadley

Sadly, one of my clients has same situation.

Did you ever manage to resolve the problem?

Border Technology

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question