Errors 20152 & 7024 on starting RRAS


Martyn Alner

I have recently migrated a win2k Server to new hardware
(compaq) which worked perfectly. However, I cannot start
Routing and Remote Access as it comes up with the

20152 - The currently configured authentication failed to
load and initialise successfully. The specified procedure
could not be found

7024 - Routing and Remote Acess service terminated with
service specific error 127

The RRAS snap-in also comes up with "an error occurred
while trying to make a connection to the datastore".

I have tried to do the regsvr32 fix as per Q329719 but I
then get "loadlibrary ("oledb32.dll") failed - the
specific procedure could not be found".

Server is win2k (sp4) with ISA (sp1) on it.Any help
gratefully received.


Martyn Alner

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question