Remote Desktop over VPN Not Working



I use my laptop at home to connect to my VPN at work and then use Remote
Desktop to administer my servers. I use the same technique for offering
support to my clients. Recently I began having problems getting RDP to work
over a VPN connection (around the time I installed WinXP SP2).

I can connect to the VPN.
I can ping the remote machine (by name AND by IP)
I can see network shares by browsing the machine in explorer
However, when I try to open Remote Desktop connection, it pauses and then
gives the following error:

1) Remote connections might not be enabled at the remote
2) Maximum number of connection was exceeded at the
remote computer
3) A network error occured while establishing the

I have two computers at home, both running WinXP SP2 and one connects just
fine using RDP over VPN, while the other doesn't. Also, at work my laptop
connect to RDP over VPN with no problems. I have checked all the network,
vpn and rdp settings to make sure they match between both of my computers at
home, but I still can't connect from my laptop to RDP over VPN from my home
network. Help!


Same exact problem here. Connect through VPN just fine,
but RDC will not establish - Error reads "Client could
not establish a connection to the remote computer". I've
had several IT execs look at it - it's set up on the
remote end correctly and our local IT administrator
looked my pc over and everything is set up correctly
there too. Hopefully somebody will be able to provide
both of us with a quick and simple fix.


And what is really strange is that my desktop on the same network with the
same OS and settings (as far as I can tell) seems to work fine.

Also, a quick update: as I've been trying to find a solution, I
impatiently opened my RDP connection twice to the same machine and was
actually able to get RDP to connect! I tried this again a couple of times
and it works intermittently (my favorite kind of technical
problem--inconsistent and non-repeatable).

PLEASE help!


yep same problem here. Except it will partly start the
application and stop with a black screen. If i Open the
RDC software again with teh black screen on then it works
fine. IT all worked fine with my dial up but not with
ADSL. port 3389 forwarded in router OK. Any help would be


I have experienced a similar/same problem.
I am using a pc with XPpro/SP2 and connecting to a pc with XPpro. I am
using the Xceedium web based product running on a server that connects to my
work intranet to create the secure tunnel to the second computer. Prior to
the installation of SP2, the connection went flawlessly. Now, when I connect
to the Xceedium server and sign on to my network, the the universal port is
available. When I start up RDC, the log in window presents itself, but after
the log on I am presented with:
"The client could not connect to remote computer. The remote connections
might not be enabled or the computer might be too busy to accept new
connections. It is also possible that network problems are preventing your
Please try connecting again later. If problem persists, contact your

While visiting with other staff members, I came up with another who updated
to SP2 and he has run into the same problem.
I have disabled the XP firewall and the problem persists.
I have rebooted both computers.

Does anyone know the quickest way to undo the SP2 install? I really don't
want to go into the weekend without access to work.......what am I
saying....? jez

Jeffrey Randow (MVP)

You can remove it via the Add/Remove Programs in the Control Panel...

Jeffrey Randow (Windows Networking & Smart Display MVP)
(e-mail address removed)

Please post all responses to the newsgroups for the benefit
of all USENET users. Messages sent via email may or may not
be answered depending on time availability....

Remote Networking Technology Support Site -
Windows XP Expert Zone -


This patch came out and it fixed the problem for me.
Download from MS: WindowsXP-KB884020-x86-enu.exe


After downloading a patch from microsoft
(WindowsXP-KB884020-x86-enu.exe) I am still not able to connect to
the remote computer. Same error

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question