Relative Hyperlinks not allowed in Word 2002


G

Guest

I have Word documents with many hyperlinks to other documents and web pages
within my site. The documents are converted to PDF format using the Adobe
MakePDF macro that runs in Word. In fact, I have two web sites: an external
one and an internal development site. I want to be able to move a PDF
document from one to the other and have the links point to the documents or
web pages on the appropriate site.

Under Word 2000, I was able to create links of the form:
http:/pdflib/document.pdf
(note there is only one slash character after the http:)
This worked fine once I used MakePDF to create the pdf version of the
document and posted it on either web site.

Under Word 2002, when I define that http address, Word insists on adding an
extra slash character after the http:, to give
http://pdflib/document.pdf
This looks like a valid URL, but of course it is not - it is missing the
actual web site address. But that web site address will be different
depending on which web site I put the document.

Is there a way to get Word 2002 to save the web address exactly as I enter
it, or will Word 2002 insist that I don't know what I am doing by
'correcting' the http address I type in?

By the way, if I edit a document in Word 2002 with links of this sort
created under Word 2000, but do not touch the links already there, the
MakePDF macro does not mess up the URL, and it works as I want in the PDF
format.
 
Ad

Advertisements

C

Cindy M -WordMVP-

Hi =?Utf-8?B?UGllcmNl?=,
Is there a way to get Word 2002 to save the web address exactly as I enter
it, or will Word 2002 insist that I don't know what I am doing by
'correcting' the http address I type in?
Have you tried turning off the AutoCorrect option that changes paths?
Tools/AutoCorrect/AutoFormat as you type, I believe is the path in Word 2002.

Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or
reply in the newsgroup and not by e-mail :)
 
G

Guest

Thanks, Cindy, for your reply, but I still don't see how changing Autocorrect
options could suppress this "correction" that Word makes. I've tried changing
a number of Autocorrect options that look vaguely like they could be related,
but no luck.

The problem is not a correction made "while I type". The text in the
document is not the address I want to link to. I have to mark the title of
the document (in the text) I want to link to as a hyperlink and then type in
the address I want to have stored, into the Insert Hyperlink window. As I
said, I don't type in the full address, since I want the link to be relative
to whichever web directory the eventual PDF document is stored in.

If I don't touch a hyperlink entered in Word 2000, the link address stays as
I originally typed it. If I have to edit the link address for any reason,
Word 2002 changes what I type so the link will no longer work in the PDF
document I create from Word. It insists on changing an address
"http:/pdflib/document.pdf" by adding a second "/" after the "http:".
 
C

Cindy M -WordMVP-

Hi Pierce,

I have to say, I find your problem description a bit confusing. It doesn't
really set out, step for step, the actions you're taking, where (which commands)
you're working, and the result it's giving you, vs. the result you expect.
However...

Based on what I read from this message, go to Tools/Options/General/Web
Options/Files and deactivate the checkbox about updating links on save.
Thanks, Cindy, for your reply, but I still don't see how changing Autocorrect
options could suppress this "correction" that Word makes. I've tried changing
a number of Autocorrect options that look vaguely like they could be related,
but no luck.

The problem is not a correction made "while I type". The text in the
document is not the address I want to link to. I have to mark the title of
the document (in the text) I want to link to as a hyperlink and then type in
the address I want to have stored, into the Insert Hyperlink window. As I
said, I don't type in the full address, since I want the link to be relative
to whichever web directory the eventual PDF document is stored in.

If I don't touch a hyperlink entered in Word 2000, the link address stays as
I originally typed it. If I have to edit the link address for any reason,
Word 2002 changes what I type so the link will no longer work in the PDF
document I create from Word. It insists on changing an address
"http:/pdflib/document.pdf" by adding a second "/" after the "http:".
Cindy Meister
INTER-Solutions, Switzerland
http://homepage.swissonline.ch/cindymeister (last update Jun 8 2004)
http://www.word.mvps.org

This reply is posted in the Newsgroup; please post any follow question or reply
in the newsgroup and not by e-mail :)
 
Ad

Advertisements

G

Guest

Cindy,
Thanks for your suggestion. However, I have already disabled that flag.

I have found what I consider a work-around, which works for my problem,
but does not change what I consider a problem that Microsoft introduced into
Word 2002 (and is still in Word 2003).

My documents are created in Word and are converted to PDF format using
the Word macro PDFmaker, provided by Adobe. This macro maintains the Word
hyperlinks when creating the PDF version. The PDF documents are first stored
on an internal web site for final testing, and then copied to the external
site. The two sites have the same directory structure and clicking on a
hyperlink in a document on one site should go to a document or html page on
the same site.

I have some text which is already a hyperlink created in Word 2000. The
link address is of the form:
http:/pdflib/document.pdf
"pdflib" is a folder (directory) on my web sites, and "document.pdf" is a
file in that folder. If I want to edit the link, for example to change the
file name, I right click my mouse on the hyperlinked text and get a pop-up
menu, where I select "Edit Hyperlink".
This brings up the Edit Hyperlink window. The bottom field on this window
says: "Address:". This address is shown as "http:/pdflib/document.pdf" (no
quotes), which is what I put there under Word 2000. If I change that address,
or even just close the window by clicking "OK", the address is changed by
Word 2002 to:
http://pdflib/document.pdf
That is a properly structured web address, but is not a valid address.
"pdflib" is just the name of my directory on my web sites - not a web site
address itself.
I can avoid having Word change my address if I remove the "http:". I find
that if I change the address to:
../pdflib/document.pdf
(note the two dots, or periods, before the first "/") then Word does not try
to force a properly structured web address (since there is no "http:" at the
beginning).
This work-around works for me because all the files I want to reference
are exactly one folder down from the root of both the web sites I want to
store the documents or web pages. I don't know how well this method would
work if I had cross-links within a more complex folder structure.
I still think there should be a way for me to stop Word 2002 from
changing an address that I enter in a hyperlink, even if it insists on
warning me that I have an invalid web address.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top