Print Spooler Errors/Problems-You Wont BELIEVE The Cause




Suddenly my printers stopped working, all of them, and the scanner, my
system started to bog down and I got SPOOLSV.EXE errors. I did CheckDisks, I
did Mem Checks, I scanned for Viruses and Trojans, cleaned up the Registry,
did a CHKDSK /R from the XP install CD... nothing! Then I did some more
research and came up with the cause and the solution which you WILL want to
know about.

I saw a blog entry about wiping out the contents of windows\system32\spooler
but thought that a bit drastic. However. I went into that folder and
started looking around.

In windows\system32\spool\printer I found two files that did NOT belong
there. How they got there is anyone's guess. They were: 0002.SPL and
0002.SHD, both of which are Shockwave Flash objects.

When I deleted these (and it took some doing) EVERYTHING returned to normal.

Apparently the Spooler does NOT know what to do with these file types in the
...\printer folder (understandable) so it kept chewing and chewing and chewing
and chewing on them to the point where I couldn't bring up my list of
printers, couldn't reinstall printer drivers, kept getting DeviceIO
Notification popups, constantly got SPOOLSV.EXE "could not read" memory error
instructions, and so forth during shutdown attempts.

So, the moral is, when you are having weird Spooler errors, check out your
windows\system32\spool\printer folder and look for "weird" stuff.

Hope this helps and I hope MS sees this and fixes their Spooler so it won't
chew away forever on "weird" objects.


Hey California4x4

Thanks for this !! - I think you have just saved my life.

I have had nothing but dramas over the last week with HP Printers, and my
Spooler !! - I have been on the phone to Microsoft & HP - & nothing !!

So when I saw your post, I followed the instructions, - and low & behold,
there in the PRINTER folder, were three Shockwave files !!!!

THese are now deleted, and I am hoping that everything should be back to
normal !!


Alan Morris [MSFT]

shd is the spooler scheduling file. It contains data about the job title,
the print driver, and the printer. It's partly text based and you can open
this file in notepad.

the slp file is the actually print data. It's been this way for over 15
years. I think that's older than Shock Wave.

Most likely there is a job scheduled to the MS Document Writer (whatever MS
Office installs for a printer) and a job was printed to this printer that
does not exist and was stuck in a loop until you deleted the job, the
spooler no longer did was it is coded to do with the data, send to GDI for
rendering to the print device.

Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:

This posting is provided "AS IS" with no warranties, and confers no rights.

Laura in Oregon


Thank you so much for your post. We just had the same problem. Your
solution worked.

Did you by any chance recently download something from Windows?


I've tried doing this several times and I still can't print to my printer and
the Shockwave files keep coming back. Anybody have any ideas?


California4x4 said:
In windows\system32\spool\printer I found two files that did NOT belong
there. How they got there is anyone's guess. They were: 0002.SPL and
0002.SHD, both of which are Shockwave Flash objects.

Just to add to Alan's cogent information, do not make the mistake of
thinking files *must* be a particular format just because Windows
"thinks" they are and assigns a particular icon to them.

Windows uses the three-letter file name extension to determine what
"kind" of a file it is dealing with. Not infrequently, the designers of
different application programs end up choosing the same three-letter
file extension to describe files that have nothing whatsoever to do with
each other. The icon that's displayed and the corresponding
description that appears in Windows Explorer just represent the last
application that has "told" Windows that it "owns" files with that

As Alan says, the SPL and SHD files in the \spool\printer directory
undoubtedly are print-related files and not flash files.

If you want to know what kind of file something is based on its file
extension, is a good place to start. It reveals, for
example, that an *.SPL file might be:

(a) a Compressed Archive File;
(b) a Digitrakker Sample file;
(c) an Adobe (or MacroMedia) Flash FutureSplash Document file;
(d) a Bioware Infinity Game Engine Spell file;
(e) a Microsoft printer spool file;
(f) a Sample File;
(g) a Shockwave Flash Object;
(h) a SoniqCast SoniqSync file;
(i) a Sound file;
(j) a Spell Checker file;
(k) an ABACOM Ingenieurbüro sPlan Circuit Diagram file;
(l) a Split Files Shell Extension file;
(m) a Sprint Customized Printer Driver file; or
(n) an Unknown Apple II File (found on Golden Orchard Apple II CD Rom).

For details, see
Lem -- MS-MVP

To the moon and back with 2K words of RAM and 36K words of ROM.


Last month I bought a new HP Printer, HP Deskjet F4280. Ever since I have
had nothing but problems with the printer spooler. I keep getting the
following error message when I try to print:

Spooler subsystem app has encountered a problem and needs to close.

I have tried to be resourceful and have followed nearly every recommendation
on the microsoft knowledge database and other sites to fix the problem. I
have deleted all printer drivers several times, and reinstalled the software
for the HP printer to no avail. I've followed Alan Morris' MFT advice and
his links to Bruce's aids and none of them have worked.

What's my next move? I can only get Word docs to print. No excel,
internet, etc.



Alan Morris [MSFT]

the next solution is to find the problem. If there is a DRwatsn.log file
(unsure on the name) in \windows you can search for FAULT and see what the
failing module is.

Or you can debug the spoolsv.exe process. Make sure the print spooler
service is started.

Launch task manager, go to Processes, add the PID column, note the PID
(Process ID) for spoolsv.exe.

Open a command window and type

ntsd -p [PID for spoolsv] -g -G

you will see a window open with a bunch of module load data. Now print
within the application where the spooler fails. You will not be informed
that the spooler failed but the process will be at a prompt where it failed.
Type k to dump the faulting stack and send it back. You can let the
spooler service terminate by entering q [ENTER] at the prompt. If you mess
this up the first time just restart the spooler in the command window "net
start spooler"

ModLoad: 77ba0000 77bfa000 E:\3576SRV\system32\msvcrt.dll
ModLoad: 77c00000 77c49000 E:\3576SRV\system32\GDI32.dll
ModLoad: 77380000 77412000 E:\3576SRV\system32\USER32.dll
ModLoad: 77da0000 77df2000 E:\3576SRV\system32\SHLWAPI.dll
ModLoad: 7c8d0000 7d0d4000 E:\3576SRV\system32\SHELL32.dll
ModLoad: 73070000 73097000 E:\3576SRV\system32\WINSPOOL.DRV
ModLoad: 76290000 762ad000 E:\3576SRV\system32\IMM32.DLL
ModLoad: 62d80000 62d89000 E:\3576SRV\system32\LPK.DLL
ModLoad: 75490000 754f1000 E:\3576SRV\system32\USP10.dll
ModLoad: 4b8d0000 4b921000 E:\3576SRV\system32\MSCTF.dll
ModLoad: 75e60000 75e87000 E:\3576SRV\system32\apphelp.dll
ModLoad: 4dc30000 4dc5e000 E:\3576SRV\system32\msctfime.ime
ModLoad: 77670000 777a4000 E:\3576SRV\system32\ole32.dll

(324.890): Break instruction exception - code 80000003 (second chance!!!)
eax=7ffd5000 ebx=00000001 ecx=00000002 edx=00000003 esi=00000004
eip=7c822583 esp=00a3ffcc ebp=00a3fff4 iopl=0 nv up ei pl zr na po
cs=001b ss=0023 ds=0023 es=0023 fs=0038 gs=0000
*** ERROR: Symbol file could not be found. Defaulted to export symbols for
576SRV\system32\ntdll.dll -
7c822583 cc int 3

Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:

This posting is provided "AS IS" with no warranties, and confers no rights.

Geoff Porter

My application fails to print with 'out of memory'

I tried ntsd -p [PID for spoolsv] -g -G and ended up with an error indication
that indicated:
The call to LoadLibrary(ext) failed with error 2.
The call to LoadLibrary(uext) failed with error 2.

Is this related to your help and can you help me?


Thanks. Tried several attempts at resolving this problem from the
microsoft world but they failed. Your suggestion to delete shock wave
files in the spool\printers directory did the trick. Unfortunately was
unable to determine how they got there.

BobBatIps's Profile:
View this thread:

I am having the same trouble now printing from google chrome (IE works fine) I dont beleive it is a "shockwave file" issue as these files are just incorrectly being identified as shockwae files when they are spool files?

In any case Ive deleted same to no effect

any other suggestions?? Google?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question