Mail System DLL is invalid


M

MR

I noticed that several weeks ago, the fax console stopped routing incoming
faxes. when i try to Mailto on the server, i get an error that says "Mail
System DLL is invalid". (if i try to Mailto from a workstation it works
fine)
i don't recall adding installing anything or modifying anything at that
time, except MS updates.
the server is W2K3 SP1 (not SBS!!!) the server also has exchange 2003 with
all the service packs and updates for both W2K3 and Exchange (also IIS and
SQL server 2005 - with CRM)


Below is a copy of the event log when a fax arrives:

Event Type: Error
Event Source: Microsoft Fax
Event Category: Inbound
Event ID: 32083
Date: 5/1/2006
Time: 1:19:24 PM
User: N/A
Computer: SERVER
Description:
Unable to route fax C:\Documents and Settings\All Users\Application
Data\Microsoft\Windows NT\MSFax\Queue\1C66D073B7A09.tif to the requested
e-mail address.

The following error occurred: 0x00000523
This error code indicates the cause of the error.


It appears that the error means: The name provided is not a properly formed
account name.

exactly which account is it referring to? i checked the SMTP configuration
tab and it looks correct. i certainly haven't changed it. is this even the
correct error code?

i would appreciate any information that would help me troubleshoot this
thanks
m
 
Ad

Advertisements

Ad

Advertisements

Joined
Mar 1, 2007
Messages
1
Reaction score
0
I had the same problem it was McAfee.
VirusScan Console
- Access Protection
- Prevent mass mailing worms from sending mail
- Port 25

Clear the checkbox - Apply -OK

Check this out:
According to your description, I understand you could not route your
incoming fax through email, and received 32089 & 32083 errors in the event
log. If I have misunderstood your concern, please don't hesitate to let me
know.

Based on my research, this issue could be mostly caused by that you have
installed some third-party Antivirus/Antispam software (MCAFee and so on)
and localhost TCP 25 is blocked to send email. To further isolate this
issue, I would suggest you run the following command on the SBS server.

Telnet localhost 25

A correct and expected output in the prompt window should be as following

220 Domain.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.211 ready at
Tue,
24 May 2005 20:16:20 -0700

- If the command fails to finish, you may need to configure your
Antivirus/Antispam software and unblock the localhost configuration.

- If the command finishes successfully,

1. Please use the following steps to confirm the Fax service has been
configured correctly.

1) Open Server Management
2) Right-click on Fax (Local) container
3) Select "Properties"
4) Select "Receipts" tab

Message Box - check the option "Enable Message Boxes as receipts"
SMTP E-mail
"Enable SMTP Receipts e-mail receipts delivery" is enabled
"From e-mail address" should be listed as
(e-mail address removed)
Authentication - should be Anonymous access
Check the option in "Use these SMTP Settings for the Route through
E-mail incoming routing method"

Restarted the Shared Fax Service if there are any changes.

2. Please verify the mailbox to receive the incoming faxes has a valid
e-mail address and the Exchange Sever can correctly send and receive
e-mail.

3. Please refer to the below steps to Re-register fxsroute.dll (regsvr32
fxsroute.dll):

A. Locate the fxsroute.dll from the CD3\SBS\CLIENTAPPS\FAXCLIENT folder.
B. Copy this file to the %systemroot%\system32 folder on the SBS Server.
C. Click Start, click Run, type cmd in the Open box, and then click OK.
D. At the MS-DOS prompt, type cd c:\windows\system32, and then press
ENTER.
E. At the next prompt, type regsvr32 /u fxsroute.dll, and then press
ENTER.
F. After you receive the following message, type exit at the prompt, and
then press ENTER:

Dll register server in fxsroute.dll succeeded.

G. Restart your computer.

4. Open Exchange System Manager, expand Servers\your
server\Protocols\SMTP, right-click Default SMTP Virtual Server and click
Properties. On the Access tab, click the Connection button under
"Connection control". If it is set to "Only the list below", select "All
except the list below" and list only the IP addresses of computers for
which you specifically want to deny connections. Stop and start the SMTP
virtual server, check if the issue still occurs.

Hope above information helps! I am happy to be of assistance to you and
look forward to your reply!

Have a nice day!

Sincerely,

Jenny Wu
Microsoft CSS Online Newsgroup Support
Get Secure! - www.microsoft.com/security

Source:
http://forums.techarena.in/showthread.php?t=465787
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top