Machine enters sleep then immediately restarts


J

John Burnie

I have Vista home premium, with SP1 Release Candidate 1 installed. My desktop
PC seems to enter sleep ok, but immediately wakes up again. The problem is
unchanged by the SP1 install.

I have changed various setting on the advice given in these newsgroups as
follows:-

I have a Logitech wireless mouse and keyboard and in each case I have
deselected "allow device to start up the computer" in Device Manager. The
problem persists if the network cable is disconnected. The computer power
light remains on and the Hard Drive light flashes but does not start to blink
regularly.

Other settings are:-
BIOS - S3
In Control Panel - Power Options - Advanced Settings:-
Sleep:-
Sleep after 120 minutes
Allow hybrid sleep "On"
Hibernate after 180 minutes.
Hard Disk:-
Turn off Hard Disk after 20 minutes.
Wireless adapter settings:-
Power Saving Mode "maximum performance".
Multimedia settings:-
When sharing media "Allow the computer to sleep".
In Control Panel - Device Manager - Network adapters:-
Advanced tab:-
WakeonLAN From PowerOff Value was "enable" - changed to "disable".
Allow the computer to turn off this device to save power - ticked.
Allow this device to wake the computer - not ticked.

Can anyone suggest another issue which might prevent the machine from
remaining asleep?
 
Ad

Advertisements

F

fcs25

If you have extra USB ports on your computer they will wake up the computer
also.
 
J

John Burnie

Many thanks fcs25.

I do have a D_Link DUB-H4 USB 2.0 Hub, so I tried disconnecting this before
putting the machine to sleep. It made no difference, in my case at least, but
you set me on the right lines. After disconnecting all USB cables (except the
keyboard and mouse), the ability of the machine to sleep was restored.
Reconnecting the cables showed that the culprit was my Belkin UPS (Regulator
Pro Gold).

The Belkin problem may not be typical because the UPS is an RS232 cable
connected model, but my Vista machine came without an RS232 socket and so I
connected it with a USB cable adaptor, only to find that the Belkin software
was not Vista compatible. I should have disconnected the cable...

Anyway, I am most grateful for your advice. My computer and I can now rest
easy. I'll reinstate some of the changed software settings mentioned in my
first post, and see if the problem stays away.

Sleep (or is it hybrid sleep) is a really neat feature of Vista. If only
Vista came with a Manual!
 
J

John Burnie

Hi,

With sleep restored, as per my previous post, I reinstated the Control Panel
- Power Options to default settings.

In Device Manager, in keyboard and in mouse Power Management tabs, ticked
"Allow this device to wake the computer".

In Control Panel - Device Manager - Network adapters:-
Advanced tab:-
WakeonLAN From PowerOff Value returned to "enable".
Allow the computer to turn off this device to save power - ticked.
Allow this device to wake the computer - ticked.

Can anyone advise on the security implications of the latter setting? I'm
happy if traffic on my home network wakes the computer, but not for incoming
internet traffic to do so. There is a further setting "Only allow management
stations to wake the computer" - can anyone comment on what that means?

The machine still sleeps fine (including after a reboot).

"Oh, sleep it is a gentle thing,
Beloved from pole to pole!"

I doubt the same can be said of Vista.
 
D

DarkSentinel

John Burnie said:
I have Vista home premium, with SP1 Release Candidate 1 installed. My
desktop
PC seems to enter sleep ok, but immediately wakes up again. The problem is
unchanged by the SP1 install.

I have changed various setting on the advice given in these newsgroups as
follows:-

I have a Logitech wireless mouse and keyboard and in each case I have
deselected "allow device to start up the computer" in Device Manager. The
problem persists if the network cable is disconnected. The computer power
light remains on and the Hard Drive light flashes but does not start to
blink
regularly.

Other settings are:-
BIOS - S3
In Control Panel - Power Options - Advanced Settings:-
Sleep:-
Sleep after 120 minutes
Allow hybrid sleep "On"
Hibernate after 180 minutes.
Hard Disk:-
Turn off Hard Disk after 20 minutes.
Wireless adapter settings:-
Power Saving Mode "maximum performance".
Multimedia settings:-
When sharing media "Allow the computer to sleep".
In Control Panel - Device Manager - Network adapters:-
Advanced tab:-
WakeonLAN From PowerOff Value was "enable" - changed to "disable".
Allow the computer to turn off this device to save power - ticked.
Allow this device to wake the computer - not ticked.

Can anyone suggest another issue which might prevent the machine from
remaining asleep?

For what it is worth, there are a lot of issues it seems with this on the
Logitech forums. My own theory is the way they address the hardware layer
with their drivers. I had an issue as I just got an MX3200 combo, and
SetPoint, and their driver install killed my audio subsystem. Wound up
having to re-install the drivers for Realtek HD because of it. What version
of SetPoint are you using btw? Seems that the problem is not as prevalent in
the older versions.

I don't have that particular problem myself. My sleep works perfectly even
with it set to let the kb/mouse bring it out.
 
J

John Burnie

Hi DarkSentinel,

I don't think that I have Logitec SetPoint loaded. The kb and mouse came
preinstalled, and Device Manager claims that the drivers are Microsoft ones.
The machine sleep problem has gone away since I disconnected the USB cable
from the Belkin UPS, even with both kb and mouse now set to "wake the
computer".

Sleep and Vista are now a joy to use (almost).
 
Ad

Advertisements

A

alexB

I had a shocking experience with a Logitech wireless mouse about 8 years
ago. Aside from the fact that it did not work it was designed in a totally
absurd, user unfriendly manner. That was enough. Now when offered their
product at Best Buy I just say: "NO."
 
D

DarkSentinel

John Burnie said:
Hi DarkSentinel,

I don't think that I have Logitec SetPoint loaded. The kb and mouse came
preinstalled, and Device Manager claims that the drivers are Microsoft
ones.
The machine sleep problem has gone away since I disconnected the USB cable
from the Belkin UPS, even with both kb and mouse now set to "wake the
computer".

Sleep and Vista are now a joy to use (almost).

THAT'S why. Basically, the UPS, and the Bulldog software if you are using
it, is polling and communicating with your system to make sure that there
has been no power failure, etc.
 
Ad

Advertisements

D

DarkSentinel

alexB said:
I had a shocking experience with a Logitech wireless mouse about 8 years
ago. Aside from the fact that it did not work it was designed in a totally
absurd, user unfriendly manner. That was enough. Now when offered their
product at Best Buy I just say: "NO."

Actually, aside from this problem I have exactly zero problems from any
Logitech product. Have been using them for years. I put the LX710 combo on
my fiancé's XP box, and she loves it. I absolutely love the MX3200.
Creative, on the other hand, couldn't find there ass with both hands and a
map. They can't even get their keyboards to work under Vista.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top