desktop machine won't stay in sleep mode


L

Leonard F Kiesling

using dell e521 desktop vista home premium. high speed cable modem always
on; linksys wireless/wired router; IE 7; windows mail; machine with problem
has hard wire to router.

machine always went into sleep mode with no problems.

after installing saturday's, 11-17-07's media center cumulative update
kb941229, offered by auto update, machine no longer stays in sleep mode
manually, & does not sleep automatically. if i put it in sleep manually, it
goes into sleep (click noise heard & light on cpu blinks) for less than a
minute, then comes back out of sleep mode.

as best as i can remember, the problem happened after that update.

before update, that saturday morning, i changed dlink router to a linksys
wired/wireless router, for use with new laptop.

to the best of my memory, i believe machine went into sleep mode after
router installation.

i called linksys regarding the computer not staying in sleep mode. they said
router would not cause problem.

my call to them was based on the fact if i disconnect from router, by
unplugging, the computer stays asleep. i had plugged the cable to router
back in, & machine stayed in sleep mode for about an hour; until i manually
woke it up to use. not sure if it will stay asleep longer until i test it.

i changed the multimedia setting in power options>advanced-changed to"allow
to sleep". problem still there.

my thoughts were to uninstall the kb941229 media update to see if that
solves problem.

i'm assuming i can obtain it back thru microssoft/windows update site if
needed.

thought i would present this to you folks before i do anything. my
work-around is to unplug the router cable at nite.

thank you, len kiesling
 
Ad

Advertisements

B

Bob H

Leonard F Kiesling said:
using dell e521 desktop vista home premium. high speed cable modem always
on; linksys wireless/wired router; IE 7; windows mail; machine with
problem has hard wire to router.

machine always went into sleep mode with no problems.

after installing saturday's, 11-17-07's media center cumulative update
kb941229, offered by auto update, machine no longer stays in sleep mode
manually, & does not sleep automatically. if i put it in sleep manually,
it goes into sleep (click noise heard & light on cpu blinks) for less than
a minute, then comes back out of sleep mode.

as best as i can remember, the problem happened after that update.

before update, that saturday morning, i changed dlink router to a linksys
wired/wireless router, for use with new laptop.

to the best of my memory, i believe machine went into sleep mode after
router installation.

i called linksys regarding the computer not staying in sleep mode. they
said router would not cause problem.

my call to them was based on the fact if i disconnect from router, by
unplugging, the computer stays asleep. i had plugged the cable to router
back in, & machine stayed in sleep mode for about an hour; until i
manually woke it up to use. not sure if it will stay asleep longer until i
test it.

i changed the multimedia setting in power options>advanced-changed
to"allow to sleep". problem still there.

my thoughts were to uninstall the kb941229 media update to see if that
solves problem.

i'm assuming i can obtain it back thru microssoft/windows update site if
needed.

thought i would present this to you folks before i do anything. my
work-around is to unplug the router cable at nite.

thank you, len kiesling
With Vista Ult. I had the same problem and cured it by installing an old pci
NIC, vs using the onboard NIC which I disabled in Device Manager.

Ubuntu Gutsy which I have installed also likes the onboard NIC and will not
sleep with the pci NIC. So I disabled the pci NIC through Ubuntu settings.

XP which I have installed will stay S3'd and hibernate with either NIC.

WRT54G v6 here.

Now all sleep happily ever after.
 
L

Leonard F Kiesling

thank you for reply!

don't know what a "pci NIC" is or where is located on machine, or how to
install it, or change it.

don't know what ubuntu is.

everything worked fine before update.

additional info: last nite, i unplugged cable to router. put into sleep
manually; machine went into sleep mode fine.

plugged cable back in this morning while still in sleep mode.

came back to machine 4 hours later; still in sleep mode with cable plugged
in.

also have wrt54g linksys router.

any other ideas before i remove that update?

thank you, len kiesling
 
R

Randy

This happened to me too. The only thing changed on my machine was the
update you noted in your post. My symptoms are: Click power button in the
start menu and computer screen goes black then comes right back on. It used
to go into sleep mode, power light blinking, fans and hard drive powered
down. Now if I click it several times I can get the monitor to stay off but
the power led stays on and the HD and fans keep running. Tried setting
suspend mode in BIOS to S1 from the default of Auto, but that didn't make
any difference. I changed the advanced power settings to shut down when the
power button is used (the one in the start menu) and the computer shuts down
like it's supposed to. I just can't get the sleep mode to work anymore.
Interesting problem, but really nothing more than a nuisance at this time.
I can shut down completely but I'd really like to get that sleep function
back and I really don't want to uninstall that update. Maybe Microsoft will
issue a patch for the patch.

Oh, by the way, a "pci NIC" is a separate PCI Network Interface Card that
you plug into a PCI slot on your motherboard to give you the Network
Interface that you already have, probably built on the motherboard. One way
to go I guess but this should not be necessary as this is apparently a
software issue and not a hardware issue.
 
M

Michael Walraven

Randy,

run elevated command prompt,

powercfg -lastwake
this will tell you why it was last woken

then
powercfg -devicequery wake_armed
this will tell you what devices can wake the machine

probable that the network connection is armed, you probably don't want that

go to Device Manager
expand Network Adapters
right click on the adapter, select properties, open the power management tab
exactly what is here depends on the network adapter.

In general you want any 'enable power to be turned off' to be set to accept
(checked)
you want any 'wake the computer if...' to be turned off (unchecked)

Michael
Vista Home premium
 
L

Leonard F Kiesling

SOLVED!!!

randy, thanks for explaining the pci card info!

mike, the settings on network adapter are set as you indicate. thank you.

it was the linksys wrt54g wireless router.

what i did: disconnected from router & connected direct to cable modem.
machine went into sleep mode & stayed.

bought & installed a netgear wgr614 wireless router.

machine enters sleep as set & stays in sleep; manually set to sleep, stayed
in sleep mode.

i'm glad i did the obvious-simple test first.

it wasn't that update.

thank you all! len kiesling
 
Ad

Advertisements

M

Michael Walraven

Randy,
Having two HID (Human Interface Device) devices seems strange. I have one
entry under 'Human Interface Device' in Device manager with not much
information as to what it is. It is actually my UPS power supply, which is
under Batteries as HID UPS Battery.

You might check for dual entries in the HID area and possibly delete the
duplicate. When you determine just what is the device (game controller comes
to mind) you might want to consider if you want to allow it to wake you
computer or not. The implication from being in the list or armed devices is
that associated with that device there is a power configuration button that
will allow you to turn the arming off. The HID is not in my armed list so I
am no help.

The count of 0 is what I get if I ask after a boot and before the first
'sleep' cycle. So your interpretation that it never makes it into sleep,
even for a short time, seems correct. But I have no ideas on why that could
be.

Do you have UAC turned off? You might turn it back on and see if it is
trying to tell you something.

If you hover over the 'power' button do you get message .....put your
computer in lower power state..... ?
Have you tried clicking on the little arrow to the right of the power button
area and selecting sleep from there?

The command 'powercfg -a' attempts to say why sleep is not available.

(powercfg /? shows all the stuff that powercfg can report on)

Michael
Vista Home premium
 
R

Randy

Thanks for all your ideas Michael...

I have tried going into sleep both ways, same result. UAC is not turned
off, and I unplugged my router from the computer, still does the same thing.
When I hover over the power button it says "saves session and puts the
computer in a low power state so you can quickly resume working." Both HID
devices need to wake the computer, one is the mouse and the other is an IR
receiver for my remote. Actually the mouse doesn't need to start the
computer but I can't turn it off via Windows I need to disable it in BIOS
but I don't want to do that. I've tried turning it off in Windows and it
still restarts the computer.

I ran scans for malware and came up clean on all of them, but that's the
first thing I thought of. For now I'll just continue to shut down instead
of sleep. If I can't live with that I'll try a restore point the day before
the problem started, 2 days ago. Thanks for your help. It seems that Len,
the guy who started this thread solved his problem, but the router isn't
causing my problem.
 
Ad

Advertisements

R

Randy

Multimedia settings in advanced power options changed to "allow to sleep,"
and computer returned to normal behavior. I'm pretty sure now that the
Microsoft update is what changed things for me. Sleep worked everytime
before that installation. I saw that Len originally tried that on his
computer and it didn't work for him, but his problem was obviously different
than mine with similar symptoms. Anyway, just in case this happens to
anybody else.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top