I can't sort desktop icons the way I want.



I have placed or software has created some desktop icons that I just can not
sort/arrange the way I want.

I wish them to be sorted by name.

That way some icons/Shortcuts would be in a location that's easiest to

But they do not work the way they did in XP

For instance.
Weatherlink, icon (shortcut to the program of the same name) places itself
after Paint Shop Pro and before a icon for a Folder containing my Financial
so I see (just an example, there are two 1/2 columns of icons.)

Kodak shortcut to program
Paint Shop Pro shortcut to program
Weatherlink shortcut to Weatherlink program
Financial (folder for Banks/Credit card shortcuts)
CNN (folder for news links)

Then there is a second column of shortcuts
And they are in aphabetical order, no matter whether shortcut of folder

So basically, both columns are in their own order by name, (sort of)

Why? and how can I fix this?

This was a xp machine, upgraded to vista, some of those icons were from XP
era, and some are from installed after Vista upgrade.

please and thank you.

Andrew Murray

Did you un-check "auto arrange" option (right click the desk top and uncheck
the option on the right-click menu). The type of icons (whether XP or Vista
style) shouldn't make a difference.




Three solutions above seem to relate to your problem (arranging desktop
icons and getting the settings to save), let us know what works for you.

Otherwise, Google "Save arrange desktop icon settings in Windows Vista"

This lists a few ideas, but these results seem to be for third-party
products that focus on arranging & saving the settings for your desktop icon


Yes I should have said that Auto Arrange was unchecked

It makes no difference Auto or not.
Arranging by name results in two and a half columns

the first (farthest to left) is sorted by name
The second and partial third are sorted by name.


The reason your icons appear that way is because there are two groups of
icons, the public group at the left which is available to every user on the
computer and the current user's group which appears to the right of the
public group. If you sort by name, both groups will be sorted but kept



That explains it.

Now while your on a roll, how do I combine them into just one 'group'.

Public is fine as I'm the only user of this computer.


This worked. I went to public>desktop, copied all the desktop items and
pasted them in User>Me>desktop
now they are all arranged alphabetically as I wanted.

Thank you and owe you a beer or wine, or if your not old enough...maybe a
juice box.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question