Font problem


A

Annie

Windows XP Home Edition.
SP3. IE6.


Hi,
I downloaded a few free fonts to a folder on my desktop. When I went to
install them I find they've changed from .TTF files to .JPEGS, so I can't
use them. They were .TTF files when I downloaded them.
I right clicked a font, went to *Open With*, but the utility I used to have
there is now missing, and I can't remember what it was called, so I can't
reinstall it. I don't even know when the fault happened, or I'd restore the
computer back to before then.
Please can you advise me,
Many thanks,
Anne
 
Ad

Advertisements

L

Leonard Grey

Files do not change from .ttf to .jpeg by themselves.

Many 'free' fonts that you download from the web are actually malware in
disguise.
 
A

Annie

hmm?

I thought you had to "install"
fonts and not just copy into
the font folder.

maybe there is more info
here for you:

http://search.microsoft.com/results.aspx?form=MSHOME&mkt=en-US&setlang=en-US&q=installing+fonts



--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~Hi,
I haven't got them in the fonts folder, they're in a folder on my desktop.
All Commercial fonts I've downloaded today have displayed as .jpegs too, and I have an image showing what I mean.
Thanks for the help.
Anne
 
A

Annie

Thank you for replying.
I have downloaded a few Commercial fonts and they're displaying on my Desktop in .jpeg format too.
If I take a font from the Font Folder and place it on my desktop then it too becomes a .jpeg, but obviously I haven't taken a font my OS needs, just a Commercial Calligraphy font - (now rendered useless.).
Anne
Files do not change from .ttf to .jpeg by themselves.

Many 'free' fonts that you download from the web are actually malware in
disguise.
 
D

db

maybe what you downloaded for free
are just images of fonts available
but not actually the fonts for
installation.

in any case, fonts like programs need
to go through an installation processes
to get them integrated with the system.



--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~
hmm?

I thought you had to "install"
fonts and not just copy into
the font folder.

maybe there is more info
here for you:

http://search.microsoft.com/results.aspx?form=MSHOME&mkt=en-US&setlang=en-US&q=installing+fonts



--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~Hi,
I haven't got them in the fonts folder, they're in a folder on my desktop.
All Commercial fonts I've downloaded today have displayed as .jpegs too, and I have an image showing what I mean.
Thanks for the help.
Anne
 
Ad

Advertisements

A

Annie

Hi DB,
Thanks for replying.
When I right click a Font in my Font Folder (any Font) and go to
Properties, it says **Open With** - *Irfanview*, so
I clicked on *Change* and * Windows Font Viewer* isn't listed there as I
know it should be. That's my problem, and I don't know how to put it right.
Anne


maybe what you downloaded for free
are just images of fonts available
but not actually the fonts for
installation.

in any case, fonts like programs need
to go through an installation processes
to get them integrated with the system.



--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~
hmm?

I thought you had to "install"
fonts and not just copy into
the font folder.

maybe there is more info
here for you:

http://search.microsoft.com/results.aspx?form=MSHOME&mkt=en-US&setlang=en-US&q=installing+fonts



--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~Hi,
I haven't got them in the fonts folder, they're in a folder on my desktop.
All Commercial fonts I've downloaded today have displayed as .jpegs too, and
I have an image showing what I mean.
Thanks for the help.
Anne
 
D

db

I think that instead of right
clicking on the font,

you need to go to the top
and in the file menu you
will find the "install" command.



--
db·´¯`·...¸><)))º>
DatabaseBen, Retired Professional
- Systems Analyst
- Database Developer
- Accountancy
- Veteran of the Armed Forces
- @Hotmail.com

"share the nirvana mann" - dbZen

~~~~~~~~~~~~~~~
 
B

Bob Lucas

Firstly, the file extension for a true type font should be TTF -
not JPEG. Try changing the extensions of the problem files from
JPEG to TTF.

The recommended program to view fonts in Win XP is Windows Font
Viewer. On my computer, the Windows Font Viewer file is located
at C:\WINDOWS\System32\fontview.exe. It might be different on
the OP's computer.

Click on "Start" (at the bottom left of the desktop screen),
followed by "Run". Type "fontview.exe fontname.ttf" (without the
quotation marks), followed by OK. (Substitute the name of the
actual font for fontname.ttf.)

If the file you have downloaded is not a valid font, you will see
an error message. Otherwise, Windows Font Viewer will open and
you should be able to view characters from the font.

The TTF file extension on your computer may not be associated to
the correct program.

To re-associate TTF files to Windows Font Viewer, open Control
Panel and Click on Folder Options. Then, select File Types and
scroll down to TTF.

Click on "Advanced". (If the "Advanced" Option is missing, click
on the "Restore" option instead, followed by "Advanced".) Check
the box labelled "Confirm open after download".

The "Advanced" menu should offer two command options - "open" and
"print".

Select "open", followed by Edit. The command line must read
C:\WINDOWS\System32\fontview.exe %1 (Note - the space between exe
and %1). Also, check the box marked Use DDE.

Select "print", followed by Edit. The command line must read
C:\WINDOWS\System32\fontview.exe /p %1 (Note - the spaces between
exe and /p and also between /p and %1). Also, check the box
marked Use DDE.

Click on OK and check that TTF files are associated correctly to
Windows Font Viewer. If not, click on "Change", to correct the
association. If Windows Font Viewer is not listed as a
recommended program, you may need to use the browse option (to
C:\WINDOWS\System32\fontview.exe).

Before you can use new fonts, you will need to install them.
Saving the TTF files is insufficient. You will find detailed
installation instructions at
http://support.microsoft.com/kb/314960
 
A

Annie

Hi,
Yes, there's a browse button, it opens my Program Files.
Anne

When you click on "Change" , is there a browse "button" ?
 
Ad

Advertisements

A

Annie

I don't have Windows Font Viewer installed, and that's the program I need so that I can associate my Fonts with it.
Thanjs for trying to help.
Anne


Go through Program Files and click on the program you wish to open
with .
 
B

Bob Lucas

Have you not read my previous replies ?

You should have Windows Font Viewer installed on your computer. The file name is "fontview.exe" and it is part of Windows XP.

I don't have Windows Font Viewer installed, and that's the program I need so that I can associate my Fonts with it.
Thanjs for trying to help.
Anne


Go through Program Files and click on the program you wish to open
with .
 
A

Annie

..I've done as you suggested, ran a search for the fontview.exe file, and
search reports ....*Search complete. There are no results to display*.

The fonts in the folder on my desktop were there for me to install at a
later date, and would have been properly installed into the fonts folder if
this problem hadn't arose. I don't just drag and drop fonts into the fonts
folder I install them properly.

I've installed the fonts ok, from your instructions, but I still have them
all presenting as .jpegs in the folder on my desktop.
Fontview.exe is not on the list, in the *Open With* box, so I can't
associate the fonts with it.

I've run several anti-spyware programs, and my AVG, they don't bring
anything untoward up, that was the first thing I did, thinking I had a bug
or two.
Anne


Sorry, but something doesn't quite add up, here.

Windows Font Viewer is a system file, which comes with every installation of
Windows XP.

You are saying that you don't have the file "fontview.exe " on your
computer. However, when you run "fontview.exe airstream.ttf", the font
viewer program opens and lets you view the font. It follows that you MUST
have the "fontview.exe" program on your computer. Otherwise, you would not
be able to run the program.

Also, I don't understand how a TTF file extension could change on its own to
JPEG. (I assume you are running active anti-virus protection - and the TTF
files are not infected).

Furthermore, if the file extensions have changed to JPEG, then I don't
understand how "fontview.exe" could allow you to view the content of the
files.

So let's try a few more steps.

Make sure you are signed into Windows as an "Administrator". Then, Open
Control Panel / Folder Options and click on the "View" tab. Remove the
check from the box labelled "Hide extensions for known file types".

Also, on a temporary basis, remove the check from the box labelled "Hide
protected operating system files". Save these changes

Next, click on "Start", followed by "Search" - and search for the
"fontview.exe" file. When you perform the search, make sure you search
against "All files and Folders". Under "Advanced Options", you should also
include system folders, hidden files and folders, and subfolders. The
search results should confirm the existence of the "fontview.exe" file - and
tell you where to find it.

You indicated that you have downloaded the custom font files to a folder on
your desktop. However, Windows font files should always reside in the
dedicated system folder at C:\WINDOWS\Fonts, because the system folder
provides special functions for managing fonts. Copy the downloaded font
files files to C:\WINDOWS\Fonts and if necessary, change the file extension
back to TTF.

In C:\WINDOWS\Fonts, select the name of each downloaded font in turn and try
to install it (follow the detailed instructions at
http://support.microsoft.com/kb/314960).

Now, you should be able to correct the file association for TTF files.
If the Folder options / File Types menu does not offer Windows Font Viewer
as one of the recommended programs for TTF files, you will need to click on
"Browse".

Perhaps I should clarify how to use the "Browse" function (in Folder Options
/ File Types). Clicking on "Browse" will display the complete folder list.
Scroll down the list until you reach the folder (or sub-folder) that
contains "fontview.exe". Click on the name of that program file. When you
select "fontview.exe" from the folder list, that should allocate the correct
file association.

Also, check the Advanced Options, as per my previous response.




Hello Bob,
I haven't got the XP Windows Font Viewer installed, otherwise it should
surely be in my Folder Options list? (No C:\WINDOWS\System32\fontview.exe
File available).

If I change the font from a .jpeg to a .ttf it stays in .jpeg. format.

If I run ...fontview.exe airstream.ttf . then the font opens as it should,
but the icon remains as a .jpeg on my desktop, and not as the actual font ..
(.ttf file).

As it shows here.
I can't install any font until this problem is resolved.
Anne

Firstly, the file extension for a true type font should be TTF -
not JPEG. Try changing the extensions of the problem files from
JPEG to TTF.

The recommended program to view fonts in Win XP is Windows Font
Viewer. On my computer, the Windows Font Viewer file is located
at C:\WINDOWS\System32\fontview.exe. It might be different on
the OP's computer.

Click on "Start" (at the bottom left of the desktop screen),
followed by "Run". Type "fontview.exe fontname.ttf" (without the
quotation marks), followed by OK. (Substitute the name of the
actual font for fontname.ttf.)

If the file you have downloaded is not a valid font, you will see
an error message. Otherwise, Windows Font Viewer will open and
you should be able to view characters from the font.

The TTF file extension on your computer may not be associated to
the correct program.

To re-associate TTF files to Windows Font Viewer, open Control
Panel and Click on Folder Options. Then, select File Types and
scroll down to TTF.

Click on "Advanced". (If the "Advanced" Option is missing, click
on the "Restore" option instead, followed by "Advanced".) Check
the box labelled "Confirm open after download".

The "Advanced" menu should offer two command options - "open" and
"print".

Select "open", followed by Edit. The command line must read
C:\WINDOWS\System32\fontview.exe %1 (Note - the space between exe
and %1). Also, check the box marked Use DDE.

Select "print", followed by Edit. The command line must read
C:\WINDOWS\System32\fontview.exe /p %1 (Note - the spaces between
exe and /p and also between /p and %1). Also, check the box
marked Use DDE.

Click on OK and check that TTF files are associated correctly to
Windows Font Viewer. If not, click on "Change", to correct the
association. If Windows Font Viewer is not listed as a
recommended program, you may need to use the browse option (to
C:\WINDOWS\System32\fontview.exe).

Before you can use new fonts, you will need to install them.
Saving the TTF files is insufficient. You will find detailed
installation instructions at
http://support.microsoft.com/kb/314960
 
A

Annie

Sorry Bob, yes I read your previous response, sorry, I can't find Windows Font Viewer anywhere on my machine.
Anne
Have you not read my previous replies ?

You should have Windows Font Viewer installed on your computer. The file name is "fontview.exe" and it is part of Windows XP.

I don't have Windows Font Viewer installed, and that's the program I need so that I can associate my Fonts with it.
Thanjs for trying to help.
Anne


Go through Program Files and click on the program you wish to open
with .
 
Ad

Advertisements

A

Annie

Hi Bob,
Thank you for the file, I followed the rest of your instructions so haven't used it as yet.

I ran sfc /scannow from the cmd prompt, and rebooted.

On the bright side I now have my fonts opening with Windows Font Viewer but they still remain as .. **Type of file : Irfanview TTF File**, which is a nuisance, but better than what I had, I'd like to put that right too, <g>.

When I navigate to my Fonts folder and double click on Arial.ttf I'm told
... **The requested file:C\Windows|fonts\ARIAL.ttf was not a valid font file.**.

How do I validate my Windows Fonts? Another mini problem!

I appreciate the help on this, thank you for your time.
Anne



In that case, I really am puzzled.

I simply don't understand how your computer responded to "Run
fontview.exe fontname.ttf", if you don't have "fontview.exe" on
your machine.

What happens if you navigate to the C:\Windows\Fonts folder - and
double click on one of the standard Windows fonts (such as
"arial.ttf")? Does the standard font open, using a Font Viewer
utility?

If "fontview.exe" really is missing from your computer, you could
use the Microsoft System File checker utility. To do so, go to a
command line prompt. Type "sfc /scannow" (without the quotation
marks). For further information, see the instructions at
http://support.microsoft.com/kb/310747.

If System File Checker doesn't restore the file, you could try to
copy it manually. This is at your own risk, and I'm not 100%
certain it will work. However, I have attached a required file
(renamed "fontview.copy"). Save the file to a temporary folder -
and rename it as "fontview.exe".

Then, upon the assumption that the Windows directory on your
computer is at C:\Windows, you should copy "fontview.exe" to the
"C:\Windows\system32" folder on your computer.

Use the procedure that I described previously to associate TTF
files to "fontview.exe". You will almost certainly need to use
the browse option in the File Types menu. Scroll down to
"C:\Windows\system32" and select the "fontview.exe" file.
 
A

Annie

HiBob,
I downloaded a 30 day trial offer of *Associate This*, and re-associated all my Irfanview.ttf files. All the fonts on my computer now open as they should, with the Windows Font Viewer.
Thank you so much for all the help.
Anne



Thank you for the file, I followed the rest of your instructions so haven't used it as yet.

I ran sfc /scannow from the cmd prompt, and rebooted.

On the bright side I now have my fonts opening with Windows Font Viewer but they still remain as .. **Type of file : Irfanview TTF File**, which is a nuisance, but better than what I had, I'd like to put that right too, <g>.

When I navigate to my Fonts folder and double click on Arial.ttf I'm told
... **The requested file:C\Windows|fonts\ARIAL.ttf was not a valid font file.**.

How do I validate my Windows Fonts? Another mini problem!

I appreciate the help on this, thank you for your time.
Anne



In that case, I really am puzzled.

I simply don't understand how your computer responded to "Run
fontview.exe fontname.ttf", if you don't have "fontview.exe" on
your machine.

What happens if you navigate to the C:\Windows\Fonts folder - and
double click on one of the standard Windows fonts (such as
"arial.ttf")? Does the standard font open, using a Font Viewer
utility?

If "fontview.exe" really is missing from your computer, you could
use the Microsoft System File checker utility. To do so, go to a
command line prompt. Type "sfc /scannow" (without the quotation
marks). For further information, see the instructions at
http://support.microsoft.com/kb/310747.

If System File Checker doesn't restore the file, you could try to
copy it manually. This is at your own risk, and I'm not 100%
certain it will work. However, I have attached a required file
(renamed "fontview.copy"). Save the file to a temporary folder -
and rename it as "fontview.exe".

Then, upon the assumption that the Windows directory on your
computer is at C:\Windows, you should copy "fontview.exe" to the
"C:\Windows\system32" folder on your computer.

Use the procedure that I described previously to associate TTF
files to "fontview.exe". You will almost certainly need to use
the browse option in the File Types menu. Scroll down to
"C:\Windows\system32" and select the "fontview.exe" file.
 
A

Annie

Thanks for trying to help, problem solved!
Anne

When you click on "Change" , is there a browse "button" ?
 
Ad

Advertisements

A

Annie

I've solved my font propblem, all is now well again.
Thank you for trying to help.
Anne
Files do not change from .ttf to .jpeg by themselves.

Many 'free' fonts that you download from the web are actually malware in
disguise.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Font problem 3
Help Installing Fonts 1
font viewer error 11
Need help with font size 1
Tahoma fonts etc. 6
OTF Font problems 4
TTF File 2
OTF Font problems - 2nd try 2

Top