Fax not showing up in printer list



I have a Motorola SM56 USB Data Fax Modem hooked up to my computer (a
MacBook Pro, running Windows XP as a second operating system).
I added the Fax services using the procedure detailed in Help.
In the Configure Fax... procedure, my modem shows up and I can set all the
settings for sending and receiving faxes.
However, I still cannot send faxes. I have tried rebooting since
installation of the Fax services, but when I try to fax or print and look for
fax as an option, the fax modem does not appear as an option, only the
regular printers show up, but not the fax modem.
How do I get printing to see the fax?
The system does detect the modem, as is indicated by the Configure Fax...
wizard showing it.

Hal Hostetler [MVP P/I]

The symptoms you list suggest the security database may be corrupt. Many
users who have updated an older version of Windows XP to SP2 before they try
to install the fax service or who attempt to reinstall fax on an SP2 system
appear to be encountering a problem installing it. In these cases there is
no error message during the installation (distinguishing this from the very
common problem where the installation routine states it cannot find the
necessary files). The installation appears to proceed without error, but
when it is over there is no fax printer listed in Printers & Faxes and any
attempt to send a fax results in the error message "Fax server information
cannot be retrieved. The Fax Wizard will now close." This problem appears to
occur because the security data base is corrupted as documented here:

You cannot add a Windows component in Windows XP

This article describes a hotfix users can obtain that might fix the problem
and states that Microsoft does NOT recommend simply running the Esentutl.exe
utility (also referred to in the article, it can repair/rebuild the corrupt
file) to recover from security database corruption.

You can either:

1. Get the hotfix mentioned in the KB article and install it. Microsoft
usually waives any charges for support calls to get supported hotfixes
listed in Knowledge Base articles.

2. Try this procedure using the Esentutl.exe utility mentioned in the KB
article to fix the bad database file:

HP and Compaq Notebook PCs: Unable to Install Windows XP Fax Software

I can report that the Esentutl utility has corrected the problem in a number
of cases, HOWEVER, note that Microsoft recommends against using the utility
and would prefer you try the hotfix.

Hal Hostetler, CPBE -- (e-mail address removed)
Senior Engineer/MIS -- MS MVP-Print/Imaging -- WA7BGX
http://www.kvoa.com -- "When News breaks, we fix it!"
KVOA Television, Tucson, AZ. NBC Channel 4
Live at Hot Licks - www.badnewsbluesband.com


Thanks for the info, I noticed another recent post where you have suggested
the same fix.
My system has indeed been updated to SP3. The disk from which it was
installed actually includes SP2. I didn't do the installation, but neither
the fax services nor the indexing services were installed by the shop that
did the installation for me. I have found that even though I tried to add the
indexing services, it seems that they are not working either. Do you think
that this fix might solve this problem too?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question