Error 0x80070643



I'm running vindows vista home premium edition and i'm trying to update
windows defender, but it keeps coming up with Error Found: Code 0x80070643. I
even tried to update via windows update, but it comes up with an error code
80240016. could anyone please help to solve this problem as it's driving me
round the bend.


I solved my (0x80070643) problem...

So after spending 80 minutes on a support call with Microsoft, where at the
end of the call the answer was "you need to back up your files and reinstall
Vista" I thought there must be a better (and less time consuming) answer.

So once again I started at the beginning (of all the suggested fixes) and
the first thing I tried was manually running the mpas-fe.exe program that
gets downloaded to the C:\Windows\SoftwareDistribution\Download\Install

This time, I happened to notice that during file extraction, it was
extracting the files to my "E" drive. I am running Vista Ultimate on my
MacBook Pro in the second partition on my hard drive created by Apple's
BootCamp utility. I use a utility in Windows Vista called MacDrive that
mounts my Macintosh partition (as drive "E") so that I can access my Mac
documents while I'm booted into Windows.

When I'm booted into the Windows Vista patition, my Vista drive is seen as
my "C" drive (as you would expect), and the Mac volume just looks like
another drive. For some reason (not sure whether it is Vista or MacDrive
that causes it), Windows Update (and Windows Defender) extract all of their
temp installation files to my "E" drive instead of my "C" drive. All of the
Windows Updates always install just fine, but for some reason Windows
Defender doesn't like it when the temp files get extracted to something other
than the "C' drive.

So I temporarily disabled MacDrive and forced Windows Defender (via the Help
menu) to update the definitions. Lo and behold it worked just great! Now
defender is up to date and I don't get the 0x80070643 error message any more.

So... In the end it was MacDrive for me--and the fact that I had a second
drive mounted as "E". For those of you also having this problem, check to
see if you have another drive mounted other than "C". That might be part of
your problem.

Also, there may be a way (but I couldn't figure it out) to manually extract
the files from mpas-fe.exe to your "C" drive using a command line switch so
that the files can run from there, perhaps that might also fix the issue.


I'm having this same issue too. I have Windows Vista Ultimate and I can't
get Windows Defender to install the latest definition update. I've tried the
different fixes such as disabling Windows Update and doing a manual update
scan. Downloading the definitions and installing, etc. and all to no avail.

When I try to update the definitions from within Windows Defender I get the
error code 0x80070643.

When I try to update them from within Windows Update, I get the error code

I'm completely stumped and I keep getting that red shield with the "X" in
the system tray telling me my definitions are not update to date.



Robin type the error code in Search for : in General Discussions and click
go, there might be some help there. Not Knowing if this is your problem there
seemed to be a fix by Dave M

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question