Cannot change "language scripts"


L

Link

Hi, IE6SP1, WinXP pro sp2 (rc1), I have "cyrilic"
language script selected, cannot be changed, as a result
IE and outlook are displaying wrong characters...ANY
idea ?
 
Ad

Advertisements

P

Paul Gorodyansky

Link said:
Hi, IE6SP1, WinXP pro sp2 (rc1), I have "cyrilic"
language script selected, cannot be changed, as a result
IE and outlook are displaying wrong characters...ANY
idea ?

Sure. You mean that in Internet Explorer you go to
Tools/Internet Options, click on "Fonts" button and see
the following ('Cyrillic' script as a currently selected one),
right?
http://ourworld.compuserve.com/homepages/PaulGor/IEscript.gif

Then don't worry - there is *no* functionality behind that.
It can NOT affect IE's and Outlook's work with characters:

it's just a menu with single-line window to show an item from that
menu. Which item is shown - does not matter, it does NOT mean
that say Cyrillic is now you Default setting, not at all.

Again, it's just an item shown in that single-line window,
not any kind of setting.

By the way, Internet Explorer does not have any setting in
any place of its options to specify a Default
Character Set Encoding (unlike Netscape/Mozilla), so don't worry.

Now what can be the real reason for your problems?

1) IE showing wrong characters, for example, you go to
say German Web page but see Russian letters.

a) It could happen if you have Encoding auto-detect enabled -
in View/Auto-select. It is know to be buggy in that area, so
just disable it, remove the checkmark next to that option

b) another possibility can be the following:
- you have visited a Russian site that did specify that it's
Russian, so IE had Cyrillic as a current encoding in
View/Encoding
- now you decided to visit a German site and it's the site
(rare nowadays) that does NOT specify its encoding.
So IE just uses the encoding used for the previous page -
Cyrillic - and you see Russian instead of German
In such case just change the encoding yourself - by
going to View/Encoding and choosing the right one for the
current page


2) Outlook (MS Outlook or Outlook Express?) is a different story -
you need to know how to work with character encodings there -
please see the tune-up instruction for each of them in the
"Russian in Browsers/Mail/News" section of my site. It explains
Russian settings, but it's the same for any other character
encoding


--
Regards,
Paul Gorodyansky
"Cyrillic (Russian): instructions for Windows and Internet":
http://ourworld.compuserve.com/homepages/PaulGor/

Russian On-screen Keyboard: http://kbd.da.ru
 
P

Pjotrp

I have the same problem and I now it doesn't change the functionality
of the browser. But the annoying thing is that I'm not able to choose
a different language script (i.e. Latin Based). After I changed the
language script, click on OK the APPLY button stays grey. Going back
to the FONTS tab shows still the cyrillic language script. There is no
possibility to change it.

I've searched the registry, policy settings etc. no result.
Re-installed IE, no result.

Does someone has an idea?
 
H

H Leboeuf

Repair IE see if it helps.

Add/Remove programs/MS/IE repair.
 
P

Paul Gorodyansky

I have the same problem and I now it doesn't change the functionality
of the browser. But the annoying thing is that I'm not able to choose
a different language script (i.e. Latin Based). After I changed the
language script, click on OK the APPLY button stays grey. Going back
to the FONTS tab shows still the cyrillic language script. There is no
possibility to change it.

I've searched the registry, policy settings etc. no result.
Re-installed IE, no result.

Does someone has an idea?
Please read one more time my previous message, but shortly:

- there is *no* such thing in IE as "choose language script". None.
- Fonts button is - as its name says - for *fonts* selections

That is, it does *not* matter which script is shown in that
single-line window. A user can:
- open that scripts menu and select "Latin based". There, one
could select *fonts* - for example, I selected "Arial" instead
of the default "Times New Roman". It means that in future, if I go
to a Web page of "Western European" encoding, for example, German
or English, the page will be shown in "Arial" (if page itself
does not specify its own fonts)

- when I am done (selected *fonts* for Western pages) I am out of
that Scripts drop-down menu - and, again, it does *not* matter which
item of that menu is shown - no functionality behind that.
- now I could go to that menu again and choose say "Greek". Then I am
able to specify my choice of *fonts* for the Greek pages if I even
visit one.

Again, no "language script selection" there, just fonts selection per
specific script.
 
Ad

Advertisements

P

Pjotrp

Ok.
You made clear to me that this is not a problem of IE.
What made me conclude that it had something to do with that setting
was that my colleagues could change make a change to the displayed
value (i.e. from cyrillic to latin based) and the new value was
displayed the next time. For me this was not the case: it always
displayed the cyrillic scipt.


Then I have to search in another place for the problems I have. It has
for sure something to do with the HTML format. All mail, webpages that
are displayed make a mess of special characters.I've checked all
settings and they are OK (as far as I know).
 
P

Paul Gorodyansky

...
All mail, webpages that
are displayed make a mess of special characters.I've checked all
settings and they are OK (as far as I know).
You may want to try 2 tnings:
1) Disable "encoding auto-detection" in Internet Explorer -
remove a check-mark next to View/Auto-select.

Auto-detection is known to be very buggy there...

2) Try to change the font for Latin-based - if currently
it's "Times new Roman" - choose "Arial".


--
Regards,
Paul Gorodyansky
"Cyrillic (Russian): instructions for Windows and Internet":
http://RusWin.net
Russian On-screen Keyboard: http://Kbd.RusWin.net
 
Ad

Advertisements

Joined
Apr 22, 2011
Messages
2
Reaction score
0
I HAVE AN ANSWER !!!!

My problem is the same. It is stuck in Thai. I can not change to latin based.

Start > Setting > Control Panel > Regional and Language Option

In Advanced Tab, change language of non-Unicode program to English (US) or English (Australia)

Click OK and Try to change Language script in Internet Option again.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top