Can't Change Default Language Setting



In Internet Explorer, pages with special characters, such as letters with
accents when I visit French pages, cannot load correctly. The proper
characters are replaced by Cyrillic ones.

When I go to IE's Tool menu, under Tools|Internet Options|Fonts, the
Language Script is set to "Cyrillic". Every time I change the setting to
"Latin based" and click OK and then OK once more to close Internet Options,
nothing ever happens. Pages still load with Cyrillic characters. Upon
returning to the Language Script setting, I find it is back to "Cyrillic"
rather than "Latin based" as though it never saved my change at all.

Recently I discovered that whatever is causing this problem is also
affecting special characters within MS Office applications. For instance,
when I wrote a Word doc while the language is set to French, spell check will
mark the words that have accents as wrong and the suggested spellings have
those strange Cyrillic characters in the place of the proper French

I have tried uninstalling and reinstalling IE. Upon contacting my computer
manufacturer, I was advised to try uninstalling all MS Office apps and then
try changing the IE settings, since MS Office language settings can override
IE language settings. This did not work. When the problem first presented
itself, I ran System Restores repeatedly to no avail.

I have run virtually all anti-virus programs in search of possible
infections, such as Norton, McAfee, Computer Associates, Panda Software,
TrendMicro, and others, and have come up PRISTINE clear every single time.

I've had this problem for months, and can not find a solution anywhere.
Please help me!

Myriam D.

I'm running:
Windows XP Pro SP2 (Embedded)
Internet Explorer 6
MS Office 2003
Microsoft AntiSpyware
McAfee Anti-Virus
Microsoft Office 2003 Desktop Language Settings (Add-In Tool which allows
one to change Language Settings for Windows and Office applications from one
convenient panel, which I installed a few hours ago)


Myriam - I had the same problem, probably caused by some trojan or
hijack. After much troubleshooting, I found the solution which is:
Control Panel - Regional Options - Advanced - Code Page Coinversion
Tables - Uncheck 21866 (Ukrainian - KOI8-U) - restart windows. The
KOI8-U seems to have been the problem with me. I hope this works for
you. If not uncheck others until problem disappears.
Best regards,


Other complications developed (unrelated to the previous problem), which led
me to start over and just format my hard drive. So far the problem has not
returned. But thanks for your help.
Oct 4, 2011
Reaction score
The solution to that and believe me the only solution is to run the command sfc/scannow from elevated command of cmd.
it works on win 7 too

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question