XP Blue screen crash from activesync


B

Brendan J Cuffe

Situation is as follows. Wndows XP machine, compaq 3970 and activesync 3.7.

I've recently had problems with my machine following an upgrade from NIS
2002 to NIS 2004. While NIS 2004 was on my machine activesync did not
appear to be affected and my pocket pc continued to sync with my decktop and
backups performed successfully. I uninstalled NIS 2004 and my machine
appeared to return to normal. Presently running a trial version of McAfee
AVS and all the items affected by NIS 2004 are working normally.

Last night tried to sync my pocket pc, everything was fine, all the info on
my pocket pc updated but when doing the backup my desktop hung and the
backup never completed.

Now at this stage, and I haven't done this for ages, I open activesync on
my desktop, clicked file and clicked on connection settings. As soon as I
clicked on connection settings I got a blue screen crash with the following
message: -

STOP 0x0000008E (0xC0000005, 0xF88DFB2E, OxF42B4720, 0x00000000)

ircomm.sys - address F88DFE2E base at F88DE000, Datestamp 3966160d

I then uninstalled activesync 3.7, installed 3.7.1 and updated the ROM
version on my 3970 from 2.0 to 2.10. I then re-establish my partnership,
everything synchronises perfectly and the backup to my pc is successful.
However if I click file - connection settings - I still get a blue screen
crash with the same error message. I've also tried it with the McAfee AVS
disabled but the same thing happened.

Personally I don't think my past difficulties with NIS 2004 are the cause of
my problems,but as it is months since I tried to open the connection
settings in the activesync file menu, I really don't know how long this
problem has been going on.

As the problem also seems to be with ircomm.sys, is there something I can
disable in services that might stop this re-occurring. I don't sync
anything to my desktop with infra-red.

Alternatively do I need to update ircomm.sys drivers, if I do where do I
obtain new ones and how do I find and remove the old ones?

Any thoughts much appreciated.
Brendan Cuffe
Please reply to group
 
Ad

Advertisements

C

Chris De Herrera

Hi,
The problem could be related to hardware. Do you have an IR port in your
desktop? The issue is that ActiveSync is attempting to identify what ports
are installed on your desktop and it thinks that there is a IR port. I
suggest trying to disable the IR hardware and reboot and see if that works.

Beyond that, try using the options in the Device Manager to update the
driver.
 
B

Brendan J Cuffe

Chris,

I shall look at it some more when I get home, but I'm 99.99% certain that my
desktop does not have an IR port. Presumably that might be my problem, it
looking for one and can't find it!

Brendan
 
Ad

Advertisements

B

Brendan Cuffe

Thanks Chris,

I disabled the virtual IR port in device manager and everything works fine.
Seeing as my desktop doesn't have IR, I then deleted the port.

Brendan
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top