Wireless adapter is making standy to restart

  • Thread starter Sudarshan Karkada
  • Start date

S

Sudarshan Karkada

Windows XP Home SP3
eMachines desktop PC
AMD Athlon XP

When I put my system in standby mode, the computer decides to restart
(reboot) immediately after the system goes to standby state. Hybernate
works fine, but takes too long and we don't like to use the function
if standby works. This problem only started to occur just a few weeks
ago. After a long research I have determined that USB Wireless Adapter
AirLink AWLL3026 is causing some problem.

If I exit from WLanUtil software, pull out the adapter from the USB,
and then put the system in standby mode, everything works as expected.

I searched for existing discussions on the Internet and found a lot of
talk on various forms of this issue. However, none of the solutions
suggested there are helping me. For example, Event Viewer has no error
even when I have setup to not automatically restart when system
failure occurs. I have also setup to write an event to the system log
when system failure occurs.

I have also disabled WakeOnLAN from PowerOff for the network
controller.

Is there anything else I should try? I'll appreciate any help.

Thank you.
 
Ad

Advertisements

S

SC Tom

Sudarshan Karkada said:
Windows XP Home SP3
eMachines desktop PC
AMD Athlon XP

When I put my system in standby mode, the computer decides to restart
(reboot) immediately after the system goes to standby state. Hybernate
works fine, but takes too long and we don't like to use the function
if standby works. This problem only started to occur just a few weeks
ago. After a long research I have determined that USB Wireless Adapter
AirLink AWLL3026 is causing some problem.

If I exit from WLanUtil software, pull out the adapter from the USB,
and then put the system in standby mode, everything works as expected.

I searched for existing discussions on the Internet and found a lot of
talk on various forms of this issue. However, none of the solutions
suggested there are helping me. For example, Event Viewer has no error
even when I have setup to not automatically restart when system
failure occurs. I have also setup to write an event to the system log
when system failure occurs.

I have also disabled WakeOnLAN from PowerOff for the network
controller.

Is there anything else I should try? I'll appreciate any help.

Thank you.

Check your BIOS settings also to see if there is a Wake On LAN or Wake On
Network Activity setting there.
Have you tried using Window's Wireless Zero Configuration instead of the
WLan utility? It may not be the best solution in your situation, but it may
help prove/disprove that the WLan utility is the culprit.

SC Tom
 
S

Sudarshan Karkada

SC Tom,

Thanks for your response. I couldn't find anything to the effect of
"Wake On" in BIOS setup. The BIOS is dated 2004.

Enabling Windows wireless configuration didn't help any. System
rebooted just the same.

What I noticed is that just exiting WLanUtil (or disabling Windows
wireless connection) doesn't help. I have to physically remove the USB
wirelss adapter. Is there a chance that the device is malfunctioning
and needs to be replaced? It works fine otherwise.

Thanks again.
 
S

SC Tom

Sudarshan Karkada said:
SC Tom,

Thanks for your response. I couldn't find anything to the effect of
"Wake On" in BIOS setup. The BIOS is dated 2004.

Enabling Windows wireless configuration didn't help any. System
rebooted just the same.

What I noticed is that just exiting WLanUtil (or disabling Windows
wireless connection) doesn't help. I have to physically remove the USB
wirelss adapter. Is there a chance that the device is malfunctioning
and needs to be replaced? It works fine otherwise.

Thanks again.

If you use a different USB socket, does that change the behavior? I believe
the Airlink adapter is USB2.0. Are the PC ports compatible? Do you have a
wired adapter installed, and if so, is it disabled?

SC Tom
 
S

Sudarshan Karkada

Using different USB port didn't help - exactly the same behavior. As
for the compatibility, this configuration worked flawlessly for more
than 3 years until a few weeks ago.

No, wired network card is not disabled. I will try that after posting
this message and update the posting only if something changes.

I have another wireless adapter (a different model AirLink that is
used on another computer) and it also rebooted! Another computer goes
into standby fine.

I am now beginning to suspect that something in Windows has changed.

Thanks.
 
S

Sudarshan Karkada

Disabling the network card didn't help. Restoring Windows to a
previous checkpoint didn't help either.
 
Ad

Advertisements

S

SC Tom

Sudarshan Karkada said:
Disabling the network card didn't help. Restoring Windows to a
previous checkpoint didn't help either.

Was anything new installed to this particular machine around the time you
started having this problem, even Window's updates? Have you tried totally
uninstalling the software that came with it? Something has definitely
changed from the time it was working until now; it's just a matter of
figuring out what it was, and that's the hard part. Do you have another
brand of adapter such as a Netgear or Belkin that you could try just to see
if they have a similar problem?

SC Tom
 
S

SC Tom

SC Tom said:
Was anything new installed to this particular machine around the time you
started having this problem, even Window's updates? Have you tried totally
uninstalling the software that came with it?

*** I meant the adapter, not the PC :) ***
 
S

SC Tom

Sudarshan Karkada said:
Disabling the network card didn't help. Restoring Windows to a
previous checkpoint didn't help either.

Another thought- what is wrong with using hibernation? You said in an
earlier post that it takes too long. My XP SP3 machine hibernates in about
30 seconds, and is back up and ready to use in less than 45 seconds. Plus I
can turn the power off while hibernating, saving a small amount of
electricity over stand by.

SC Tom
 
S

Sudarshan Karkada

Hibernation takes longer than 30 s on this computer. It's a 5-year old
PC and takes some time to write 1 GB memory to hard disk. Yes, it is
not such big a hassle to use hibernate function.

I am also interested in learning how to:

1) Replace Standby with Hibernate (without having to press Shift key)
2) Automatically eject the USB device before the system goes into
standby
 
S

SC Tom

Sudarshan Karkada said:
Hibernation takes longer than 30 s on this computer. It's a 5-year old
PC and takes some time to write 1 GB memory to hard disk. Yes, it is
not such big a hassle to use hibernate function.

I am also interested in learning how to:

1) Replace Standby with Hibernate (without having to press Shift key)
2) Automatically eject the USB device before the system goes into
standby

1- Create a shortcut on your desktop and put this in the blank space:
%windir%\system32\rundll32.exe PowrProf.dll, SetSuspendState

Double-clicking on it will put your PC in hibernation. I put mine in the top
of my Start menu (classic view).

2- Not sure how to do that, but you might find out here:
http://www.google.com/search?hl=en&...ect+usb+drive&aq=0&oq=script+to+eject+&aqi=g3

My PC is about 5 years old (if not older) with 4GB of RAM, and hibernation
says it requires 3.3GB. Most times when I hibernate, I only have 2 or 3
programs running at the time and still takes only about 30 seconds. Granted,
none of these are real memory intensive programs like CAD or video editing,
but I can't imagine it taking much longer than that anyhow.

SC Tom
 
Ad

Advertisements

S

Sudarshan Karkada

SC Tom,

Thank you very much for the hibernate shortcut. It worked just like
you described.

BTW, hibernation on my primary desktop takes 5 to 7 minutes! I have
tried 3 times. Couple of times without any applications running.
Looking at the defragmenter, it looks like the hibernate file (green
unmovable files) are fragmented into 4 parts. I don't think that
should make it take 5 minutes.

Thanks for all your help.

Regards,
__
Sudarshan.
 
S

SC Tom

Sorry we couldn't get the original problem fixed, but at least hibernate
works, albeit so slow.
How much RAM is in this PC? How large is your swap file? Do you have it set
manually, or are you letting Windows handle it? Do you have plenty of free
hard drive space?

SC Tom
 
K

Ken Blake, MVP

1 GB RAM, system managed virtual memory of 1535 MB, 8.4 GB (15%) free.



That's nice, but since you didn't quote anything, I have no idea what
you're referring to.

Please quote enough of the message you're responding to to put your
reply into context (as I did above). Many newsgroup participants (me,
for example) don't save already-read messages, and a message without a
quote is likely to be completely unintelligible to many people, as
yours was to me.
 
Ad

Advertisements

S

SC Tom

Good deal! Write caching is enabled on internal, non-removable hard drives
by default, I thought. I know mine have always been that way. Or maybe it's
because I've always used a UPS.
It does make sense that hibernation would be faster with WC enabled since
the info that hibernation is using going into hibernation is already written
to the drive and doesn't need to be saved again.
Another plus is that you may see a slight increase in overall performance
also.

SC Tom
 
Ad

Advertisements

K

Ken Blake, MVP

Sorry Ken, it was a long thread and even if I quoted something, it
wouldn't have made much sense.


The length of the thread is irrelevant. I certainly didn't suggest
that you quote the entire thread. As I said, you should quote "enough
of the message you're responding to to put your reply into context."
Otherwise, many of us here will be unable to make any sense of your
message.



Yes, I was certainly aware that if I was willing to make the extra
effort, I could find the thread in Google.

Thanks for your interest... I am still looking for a solution for the
original problem.


Then sorry to say that I can't help you. If I had to take the extra
time to do as you suggest for everybody who didn't quote, I would at
least double the time I spent here in the newsgroups. I'm not willing
to do that.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top