WINS server defualting to wrong NIC


J

James Buttle

I run W2K Advanced Server. It is a NAT gateway for the network. 1 NIC
is LAN, (Static IP) the other is WAN (DHCP IP).

I stuck WINS on it. The WINS snap in would not work (Said it was
attempting to connect to the IP address of WAN) not surprisingly it
failed. (I have removed NetBT on the WAN adapter and blocked most of
the ports on WAN).

I disabled the WAN adapter, restarted then WINS snap in and it
suceeded! (Now displaying the private IP address of LAN). I enabled
the WAN NIC and all is still well (I can still restart WINS snap in
with no trouble.

It looks like WINS automatically decides which NIC to to serve on. My
questions...

Is there a registry hack or similar that I can use to tell WINS not to
even think about the WAN NIC? (before or after installing WINS)

Is there anything else I should do / advice you can give?

NOTE: I have seen many people saying "DON'T PUT WINS ON A MULTIHOMED
MACHINE" - it is too late now.

Thank you all in advance for your help!

James Buttle
 
Ad

Advertisements

P

Phillip Windell

Set the LAN NIC as the top priority NIC (top of the list).

Properties of Network Places,...Advanced from the top menu,...Advanced
Settings...,...from the dropdown menu,....Adapters and Binding Tab,...in the
Upper Box (Connections), use the side arrows to move the proper NIC to the
top.
 
Ad

Advertisements

J

James Buttle

Thank you Phillip - I knew it before just forgot how to do it.

(_8(l) d'oh!

Phillip Windell said:
Set the LAN NIC as the top priority NIC (top of the list).

Properties of Network Places,...Advanced from the top menu,...Advanced
Settings...,...from the dropdown menu,....Adapters and Binding Tab,...in the
Upper Box (Connections), use the side arrows to move the proper NIC to the
top.

--

Phillip Windell [MCP, MVP, CCNA]
www.wandtv.com


James Buttle said:
I run W2K Advanced Server. It is a NAT gateway for the network. 1 NIC
is LAN, (Static IP) the other is WAN (DHCP IP).

I stuck WINS on it. The WINS snap in would not work (Said it was
attempting to connect to the IP address of WAN) not surprisingly it
failed. (I have removed NetBT on the WAN adapter and blocked most of
the ports on WAN).

I disabled the WAN adapter, restarted then WINS snap in and it
suceeded! (Now displaying the private IP address of LAN). I enabled
the WAN NIC and all is still well (I can still restart WINS snap in
with no trouble.

It looks like WINS automatically decides which NIC to to serve on. My
questions...

Is there a registry hack or similar that I can use to tell WINS not to
even think about the WAN NIC? (before or after installing WINS)

Is there anything else I should do / advice you can give?

NOTE: I have seen many people saying "DON'T PUT WINS ON A MULTIHOMED
MACHINE" - it is too late now.

Thank you all in advance for your help!

James Buttle
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Multiple NICs in Multiple Servers in Win 2003 1
Dual NICs and WINS 6
Server Nic speed 2
Server with TWO NICS 3
Defualt Directory 0
Two nic file Server 3
Backup W2k Server NIC 2
One Server, two NICs 0

Top