Win 98 and XP ICS


E

Ed M

Hello,
I have three computers on my network.
1. XP Home with dial up modem and ICS.
2. XP Pro that properly connects to ICS on XP Home.
3. Win 98 that will not connect to ICS on XP Home. File sharing works. The
XP disk was used to setup the proper files to receive ICS. Under Internet
Options, there was a connection setup that connects through a LAN. Should I
select the automatic proxy setting for this? I've tried both selecting the
auto proxy and leaving this selection blank. Anyways, I can get an Internet
Gateway window to display on the 98. This shows the connected modem on XP
Home. On this window, it shows modem activity on the XP Home, but is not
connecting to the Win 98 computer. How can I get the final connection so my
browser will work?
Thanks!
Ed M.
 
Ad

Advertisements

S

Steve Winograd [MVP]

"Ed M" said:
Hello,
I have three computers on my network.
1. XP Home with dial up modem and ICS.
2. XP Pro that properly connects to ICS on XP Home.
3. Win 98 that will not connect to ICS on XP Home. File sharing works. The
XP disk was used to setup the proper files to receive ICS. Under Internet
Options, there was a connection setup that connects through a LAN. Should I
select the automatic proxy setting for this? I've tried both selecting the
auto proxy and leaving this selection blank. Anyways, I can get an Internet
Gateway window to display on the 98. This shows the connected modem on XP
Home. On this window, it shows modem activity on the XP Home, but is not
connecting to the Win 98 computer. How can I get the final connection so my
browser will work?
Thanks!
Ed M.

ICS isn't a proxy server, so don't select the automatic proxy setting.
Clear all of the boxes on that screen.

These tests should help you get Win 98 working as an ICS client:

1. On the host computer, right click the local area network connection
and click Status | Support | Details. It should show:

IP Address: 192.168.0.1
Subnet Mask: 255.255.255.0
Default Gateway: none
DNS Server = none

2. On the Win 98 computer, go to Start | Run | Winipcfg, select the
LAN adapter, and click More Info. It should show:

IP Address: 192.168.0.x (1<x<255)
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1
DNS Server = 192.168.0.1

3. If #1 and #2 are right, open a command prompt window on Win 98 and
enter these lines. Each one should get four replies:

ping 192.168.0.1
ping 216.239.39.99
ping google.com

4. If #1-#3 are right, enter these addresses in Internet Explorer.
They should both take you to the Google web page:

http://216.239.39.99
http://google.com
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional Program
http://mvp.support.microsoft.com
 
G

Guest

Thanks,
From your information I found that the problem is that on the 98 computer
the Default Gateway is set to 192.168.0.2 and not 192.168.0.1. I went to
Control Panel > Network > TCP/IP for the Ethernet Adapter > Properties >
Gateway > and added 192.168.0.1. This is the only installed Gateway. Then
I selected DNS Configuration > Enabled DNS > Filled the Host in > Left
Domain blank > added 192.168.0.1. > OK > OK and rebooted when requested.
The Default Gateway is still 192.168.0.2. How can I change the default
Gateway?
TIA,
Ed M.
 
Ad

Advertisements

G

Guest

Hello,
I am replying to my own email below. As a shot in the dark, I unplugged my
router, reset it, turned off my XP home computer, plugged the router back
in, and turned the XP home computer back on. Then I rebooted my 98 computer
and everything works fine.
Again, thanks for your help.
Ed M.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top