Vista print problem with shared XP printer


Ken Varn

I have had an annoying problem with my home PCs that is driving me nuts. I
cannot solve an issue with trying to access a Windows XP shared printer from
a Vista Ultimate PC. I have read several articles on this on the web and
tried a lot of the suggestions, but I am still not getting anywhere with
this. My User accounts cannot print from Vista to the shared XP printer.
The printer status shows Error - Printing. I have opened up the security
permissions on the printer share to include Everyone, Guests, Users,
Anonymous Users with full access, and I still get this error. My
Administrator account does not have any problems printing from Vista.

Both computers are on the same workgroup. Both computers have identical
user accounts with identical passwords and permission sets. The printer is
an HP C4100. I checked with HP and I have the latest print driver.

I have tried adding the shared printer using both local and shared printer
settings, but still no luck.

Both computers have all of the latest service packs and updates.

I am at my wits end trying to fix this. Please can someone give me some
advice on how to get this working.

Mr. Arnold

Ken Varn said:
I am at my wits end trying to fix this. Please can someone give me some
advice on how to get this working.

What you should do if you have a router in play here is go get a print
server that works with Vista and XP, plug the print server into a LAN port
on the router, and plug the printer into the print server. That way, the
printer is on the network and no computer hosts the printer with each one
being able to print to the printer connected to the print server

Print servers are cheap. I got one a couple of years ago, and the Linux and
Windows machines on the network sent the printout to the print server and to
the printer to be printed

Mick Murphy

Ok, you say you have your Network set up; I'll skip that!
Run XP's File and printer sharing; info below.

Then, in vista's Network and Sharing>Add Network device>Browse to XP's
Printer>Add it.
You say you have the printer's Vista Driver already installed in Vista
computer for it.

Have a read of the above link re Vista File and Printer Sharing.

Permissions/Share info is there as well.

If using Norton, McAfee, Trend Micro I.S., make sure file and printer
sharing is enabled in THEIR firewall (or LAN allowed, depending on how their
Exceptions are worded in their Firewall)

Also, run the XP’s Home or Small Office Network File and Printer Sharing
Wizard to include Vista in your “New†Network, even if you had an XP Network
set up prior to adding a Vista computer to it(redoing the Wizard seems to
work for XP machines!).

In “My Network Placesâ€: “Set up a Home or Small Office Networkâ€
OR under Accessories > Communications > Network Setup Wizard > Allow File
and Printer Sharing.


I have done everthing you have said several timess.

My admin and Power User accounts work fine. My regular User accounts do not
work. I have openned up the printer access to everyone, users, guests, you
name it. I
don't want to have to make my user accounts into Power Users, but I may have
no choice.

Here is an Event Viewer log entry for one of the attempts:

The document,
owned by Jody, failed to print on printer HP Photosmart C4100 series on
Varnhome1 Port. Try to print the document again, or restart the print

Data type: NT EMF 1.008. Size of the spool file in bytes: 327680. Number of
bytes printed: 0. Total number of pages in the document: 2. Number of pages
printed: 0. Client computer: \\VARNHOME2. Win32 error code returned by the
print processor: 1327. Logon failure: user account restriction. Possible
reasons are blank passwords not allowed, logon hour restrictions, or a
policy restriction has been enforced.

Note that I do use logon time restrictions for the user accounts, but the
time period when the print job was submitted is within the allowed period.

Patrick C

I had a similar problem and after checking Google I found the following
procedure and it worked do it on the Vista machine;

"I had the same problem. I found a solution. Logically it makes no sense to
me, but it worked so...

Go to Control Panel. Choose printer. Then choose Add Printer.

ChooseAdd a local printer. Click on Create a new port. The default in the
drop down box is Local Port. Do not change that. Click Next.

A dialogue box will appear asking for you to enter a port name. Type in the
\\computer name\printer name ie. My computer's name is basement and the
printer name is EpsonSty so I typed in \\basement\epsonsty."

Hope it works for you.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question