USB to Serial Port Adapter Cable/USB to Parallel Printer Cable



I have an Averatec Model AV3715-EH1 running Windows XP Home Edition. This
computer does not have a parallel or serial port but does have three USB

Some time ago I purchased an IOGear USB to Serial Port Adapter cable (Model
GUC232A) to use with ham radio applications (to key the transceiver on ham
radio programs) and a USB to Parallel Printer Cable (Model GUC1284B) to
interface an old HP DeskJet 400 printer I use when on consulting assignments.
Both these adapter cable applications installed plug & play with XP some
time ago and had worked beautifully up until late July. When these were
plugged into the USB ports I think I can remember seeing virtual COM ports
assigned under the folder PORTS-(COM&LPT) in Device Manager.

In late July, both failed and PORTS-(COM&LPT) completely disappeared under
Device Manager whether these USB applications were plugged in or not. For
the printer adapter cable, I tried deleting and re-installing the printer
several times which installs but the printer head now simply comes to the
center of the printer, stops and does not print. The serial port adapter
cable has been deleted several times and the driver will not plug and play
install at all saying a Code 28 whatever that is.

After attempting to resolve this problem myself and calling Averatec and
IOGear I came to the conclusion the problem must be in the XP software. I
paid Microsoft $35 problem for Technical Support in early August to help
solve the problem. I have used phone calls, emails and lastly online support
using their EasyAssist program for computer access so their tech support
people can look into your computer. I am now on my fifth person with them in
India trying to resolve this problem and they don’t appear to have a clue
what is causing this. They tried first pointing the finger at HP and IOGear
as the problem but after some effort saw they were not the issue. After the
last of three EasyAssist sessions re-installing printer drivers, disabling
startup programs and running virus and adware detection software (programs
which I have had on computer since day one) to no avail, they assigned a new
tech support person (the fifth) who will not answer my emails.

Before I write Microsoft about their wonderful Tech Support I wonder if
anyone else on this board and has had this cable problem? Both had worked
perfectly for me up until late August. Secondly I wonder how I might get
subject matter expects at Microsoft on this problem? HELP! Thanks in


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question