USB issues while playing games


A

Adam Bowers

I'm having issue with my USB devices when playing games (Lord of the Rings
Online, Team Fortress 2, etc), and only when playing games. I constantly get
the 'USB device disconnect' sound and then a 'usb device reconnect' sound.
Occasionally I will get a dialog box saying I should use the device in a USB
2.0 slot. All of my USB slots are 2.0 and powered. I have tried using
different slots and different devices, but the behavior remains the same.
Here is my hardware. All drivers are up-to-date.

Vista Home Premium w/ SP1 32-bit
ASUS P5E3 [email protected] (X48 Chipset)
eVGA Geforce 8800 GTS 512
Seagate 2700.11 (RAID 0)
Sound Blaster X-Fi Fatal1ty
Logitech G5 Mouse
Logitech G15 V2 Keyboard
Multimedia card reader
 
Ad

Advertisements

Q

Quaoar

Adam said:
I'm having issue with my USB devices when playing games (Lord of the Rings
Online, Team Fortress 2, etc), and only when playing games. I constantly get
the 'USB device disconnect' sound and then a 'usb device reconnect' sound.
Occasionally I will get a dialog box saying I should use the device in a USB
2.0 slot. All of my USB slots are 2.0 and powered. I have tried using
different slots and different devices, but the behavior remains the same.
Here is my hardware. All drivers are up-to-date.

Vista Home Premium w/ SP1 32-bit
ASUS P5E3 [email protected] (X48 Chipset)
eVGA Geforce 8800 GTS 512
Seagate 2700.11 (RAID 0)
Sound Blaster X-Fi Fatal1ty
Logitech G5 Mouse
Logitech G15 V2 Keyboard
Multimedia card reader

IMO, in the old world, the BIOS controlled the power to USB. With
Vista, it appears to me that USB devices *must* have the ability to
withstand major power deficiencies. Most pre-vista USB devices do not
have the ability to operate under the wide range of power availability
that Vista wants.

You might gain a "cure" for this problem by turning off the eye-candy
that is standard with Vista. Make Vista operate more like XP.

Q
 
A

Adam Bowers

I just wanted to let everyone know that the problem was with my media card
reader. I don't know why it is having problems when I play games. I suspect
it has something to do with the way Vista handles power to USB devices.
 
Ad

Advertisements

B

Blade

Hi,

I have the same problem when I'm using a browser, IE or Firefox, when I
click on a tab, my mouse act like it's disconnected and, like you, I heared
the disconnect/connect usb sound, sometime just by scrolling on a page the
led of the mouse and keyboard are flashing.

I have the same problem on any port and sometimes even the keyboad stop
working at the same time.

I only have my keyboard and mouse connect on my usb port and it's acting
this way, it only started like 4 days ago.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top