usb device not recognized




My external usb hard disk, all of a sudden, can not be recognized by my
Windows XP machine. Nothing seems to have changed. The device appears as
unrecognizable in the device manager. I have tried the followings and
still can not fix the problem.

1. power down the computer, removed all usb devices and restart the
computer. Attached the usb hard disk and the problem persist.
2. tried different usb ports and none of them could recognize the drive.
Tried the usb drive on another laptop and it was recognized by the system.
3. followed some online documents and removed all the Vid entries that
was associated with the usb hard disk in
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB, restarted the
computer and let the OS to redetected the usb device. Still, no luck
with that.
4. Looked at the hard disk vendor website (Buffalo Tech) and it doesn't
has any driver for the drive. Driver installation is not required.
5. Looked at the motherboard vendor website (Asus) and it appeared that
I have the latest version of the driver installed.

The system is running Windows XP SP2. When I looked at the properties of
the device in the device manager, it said that the driver is not loaded
for the particular device. However, I was unable to update/install the
driver for it.

Any help would be appreciated.



Similar thing for me. After the update Wednesday, none of my usb devices are
recognized. I get some error now with my Asus P5b motherboard.


There is not driver for the hard drive. Again, it just works when I
plugged it in to another computer.


I cant believe this trash... I entered a 45-line possible solution here
as I had a very similar problem, and when I clicked Post it told me
page is not available... I am POed right now...


This is a registry problem, thats for sure.
I had a very similar problem, and let me tell you what I did to fix it.

I put both computers next to each other, I had that luxury as I have two.
The device was being recognized on one, but not the other.

The one that the device was recognized, let me call it COMPGOOD
while the one that was NOT being recognized, let me call COMPBAD
just for reference, OK?

Edit the registry of both computers and look under

and its subkeys, the problem is in there.

If you have lots of time(I did this last Sunday),
you can look each individual subkey and compare it on both
computers to see the differences.

Now, select COMPGOOD select HKLM\System\CurrentControlSet\Enum\USB
pull down the Edit Menu and choose Find and search for the
name of your device, some string that identifies your device.

You can do the same on COMPBAD and see the differences under
these subkeys and their associated values.

Once you rind the string of your device in there,
select the whole subkey, say:


and do a right-click and choose export.

Save the generated registry- file somewhere, perhaps a flash disk or
and transfer this file onto COMPBAD
Alternatively save it on My Documents and email it to the other computer,
whatever it takes to transfer that little-registry-file to COMPBAD

You can leave the registry editor open on COMPBAD, its OK,
you can even delete that correspongind subkey completely,
as you are about to replace it.

Double-click that file on COMPBAD and answer Yes to have its info
enter onto its registry.

Close the registry, restart the computer, plug your device, and pray...
For whatever reason, this first time it took a little longer for me,
but as long as it works, who cares if it takes a little longer.

I said "pray" because even if it doesnt work, you need to still persist
with the registries and their differences. Go bad on COMPGOOD and make
sure that it was ONLY that specific subkey that had anything to do with
your device, ie that there are no other references anywhere else.
If there are, you know what to do now, you need to export these too,
and put them on COMPBAD as well.

It wasnt so easy for me, because I .... well, I am so smart sometimes
and instead of exporting the info into a file, I was editing the registry
of COMPBAD manually, and I was entering keys, and values, and strings and
doublewords and all that, totally manually... Then I thought, oh, man,
come on now, export, man, export!!! :-(

Anyway, I hope it helps, read all above once or twice to understand
the concept before you attack, registry entries tend to be a bit picky,
if you know what I mean. I dont check this thing here often,
so if you need more help feel free to email me at
(e-mail address removed) I check that once a day.

Tim Slattery

bp said:
I cant believe this trash... I entered a 45-line possible solution here
as I had a very similar problem, and when I clicked Post it told me
page is not available... I am POed right now...

As we've told others: don't use the web interface! Set up Outlook
Express, or get Mozilla Thunderbird ( or
Forte Agent ( or another such product. Point it


I was hoping to leave this entry for the USB problem only.
Evidently, I disagree with outlook, mozilla and all others.
See, people have so many things to do at work,
I want to believe they try to keep things simple,
or as least complicated as possible. What I hear is,
I cannot go from WashingtonDC to NY via the train,
because the rail is broken, and I have to go to chicago first.
No, no, fix the WashDC-NY rail instead! Its really easy for me
to click on and read and
reply etc. Anyway, I may be overreacting a bit, but thanks
for the reply.

Bob I

Actually you have it backwards, newsreaders ARE the WashingtonDC to NY
rail, and it works. You on the otherhand are driving a car to chicago
and then loading your car on the train there for the ride to NY, and
THAT is why there are things that don't work so graet.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question