USB 2.0 PCMCIA Card


E

Edwards, Martin

All,

I am experiencing a strange problem with an NEC USB 2.0 PCMCIA card that I
have recently purchased. When the card is inserted, it is supposed to
install:

1. NEC PCI to USB Enhanced Host Controller
2. NEC USB Open Host Controller (x2)
3. USB 2.0 Root Hub Device
4. USB Root Hub (x2)

1, 2, and 4 are installing without fault, except the USB 2.0 Root Hub
Device, which is reported within Device Manager as an Unknown Device. The
device status of the "Unknown Device" reports that no drivers are installed.
I think I am correct in assuming that this unknown device should be the USB
2.0 Root Hub Device, but it doesn't want to install the correct drivers.
There is no ? or ! indicating problems with the unknown device.

The card itself works fine with an external USB thumb drive and other USB
devices but whenever the PCMCIA card is removed from the laptop and inserted
again a balloon notification pops up on the screen and tells me 'USB Device
Not Recognized".

I have the same symptoms on Windows XP SP1 and SP2, and have installed all
the latest updates from Windows Update.

Unfortunately it would appear that the manufacturer does not have any
website offering technical support.

Any ideas?

Thanks in advance.
 
Ad

Advertisements

E

Edwards, Martin

It turns out the manufacturer does have a website, albeit not documented on
the packaging.

http://www.necel.com

I'm starting to think that drivers provided with the card are fine, but
maybe a problem with Windows XP:

On the Details tab 'Hardware Ids' shows the device as USB\UNKNOWN.

How can I manually install the USB 2.0 Root Hub Device drivers?
 
E

Edwards, Martin

If I disable one of the USB Root Hub drivers, the Unknown Device disappears.

If I enable the above but then disable the last USB Root Hub (remember,
there are 4 in total listed in Device Manager) driver but enable the above,
two Unknown Device drivers appear.

I'm confused, very confused. What's going on?
 
J

jorge

Edwards said:
All,

I am experiencing a strange problem with an NEC USB 2.0 PCMCIA card that I
have recently purchased. When the card is inserted, it is supposed to
install:

1. NEC PCI to USB Enhanced Host Controller
2. NEC USB Open Host Controller (x2)
3. USB 2.0 Root Hub Device
4. USB Root Hub (x2)

1, 2, and 4 are installing without fault, except the USB 2.0 Root Hub
Device, which is reported within Device Manager as an Unknown Device. The
device status of the "Unknown Device" reports that no drivers are
installed.
I think I am correct in assuming that this unknown device should be the
USB
2.0 Root Hub Device, but it doesn't want to install the correct drivers.
There is no ? or ! indicating problems with the unknown device.

The card itself works fine with an external USB thumb drive and other USB
devices but whenever the PCMCIA card is removed from the laptop and
inserted
again a balloon notification pops up on the screen and tells me 'USB
Device
Not Recognized".

I have the same symptoms on Windows XP SP1 and SP2, and have installed all
the latest updates from Windows Update.

Unfortunately it would appear that the manufacturer does not have any
website offering technical support.

Any ideas?

Thanks in advance.
Are you sure your PCMCIA card is not manufactured by somebody else using
NEC's USB chipset?
 
E

Edwards, Martin

Jorge,

Thanks for the reply. How would I find out? The card nor packaging states
the manufacturer. It is using an NEC chipset, so is probably manufactured
from someone else.

I'm inclined to send the card back, request refund, and go for a Belkin or
something. It doesn't look like a hardware fault with the card, as we
requested a replacement under warranty but have the same symptoms.
 
S

Sharon F

All,

I am experiencing a strange problem with an NEC USB 2.0 PCMCIA card that I
have recently purchased. When the card is inserted, it is supposed to
install:

1. NEC PCI to USB Enhanced Host Controller
2. NEC USB Open Host Controller (x2)
3. USB 2.0 Root Hub Device
4. USB Root Hub (x2)

1, 2, and 4 are installing without fault, except the USB 2.0 Root Hub
Device, which is reported within Device Manager as an Unknown Device. The
device status of the "Unknown Device" reports that no drivers are installed.
I think I am correct in assuming that this unknown device should be the USB
2.0 Root Hub Device, but it doesn't want to install the correct drivers.
There is no ? or ! indicating problems with the unknown device.

The card itself works fine with an external USB thumb drive and other USB
devices but whenever the PCMCIA card is removed from the laptop and inserted
again a balloon notification pops up on the screen and tells me 'USB Device
Not Recognized".

I have the same symptoms on Windows XP SP1 and SP2, and have installed all
the latest updates from Windows Update.

Unfortunately it would appear that the manufacturer does not have any
website offering technical support.

Any ideas?

Thanks in advance.

Other than a notice about a USB Device Not Recognized, the card works? If
it was my system, I would stop there. The loose end would annoy me too but
the goal - having working hardware - has been accomplished.

A few thoughts:

What is the brand of the card? NEC is the manufacturer for the USB
controller chip on the card but most likely they provided the chip to
whoever manufactured the card. Suggest checking that hardware vendor's
website for drivers.

Hardware related services have not been altered from default settings (Plug
and Play, Shell Hardware Detection and so on)?
 
Ad

Advertisements

J

jorge

Edwards said:
Jorge,

Thanks for the reply. How would I find out? The card nor packaging states
the manufacturer. It is using an NEC chipset, so is probably manufactured
from someone else.

I'm inclined to send the card back, request refund, and go for a Belkin or
something. It doesn't look like a hardware fault with the card, as we
requested a replacement under warranty but have the same symptoms.
Where and how are you ordering replacemets? Does this place have the part
number for your card?
 
Ad

Advertisements

D

Daniel Ganek

All,

I am experiencing a strange problem with an NEC USB 2.0 PCMCIA card that I
have recently purchased. When the card is inserted, it is supposed to
install:

1. NEC PCI to USB Enhanced Host Controller
2. NEC USB Open Host Controller (x2)
3. USB 2.0 Root Hub Device
4. USB Root Hub (x2)

1, 2, and 4 are installing without fault, except the USB 2.0 Root Hub
Device, which is reported within Device Manager as an Unknown Device. The
device status of the "Unknown Device" reports that no drivers are installed.
I think I am correct in assuming that this unknown device should be the USB
2.0 Root Hub Device, but it doesn't want to install the correct drivers.
There is no ? or ! indicating problems with the unknown device.

The card itself works fine with an external USB thumb drive and other USB
devices but whenever the PCMCIA card is removed from the laptop and inserted
again a balloon notification pops up on the screen and tells me 'USB Device
Not Recognized".

Are you sure it's working at full speed? The first USB 2.0 PCMCIA card I got
wouldn't run at 2.0 speeds it ran at 1.0 speeds. I switched to a different brand
it was fine.

/dan
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top