USB 2.0 Conflicts



I have Windows XP Professional SP2. I have built-in USB that requires
drivers to be installed to make them USB 2.0. I have done this,
further, you DO see "VIA USB Enhanced Host Controller" in the Device

But XP insists that I don't have USB 2.0, and performs like it too.

To wit: when I inserted my card reader, it kept saying in a popup how
this device would perform better if connected through a high-speed USB
connection, and the ensuing summary list suggests that there are NO
USB 2.0 hosts installed. And when I tried & copy the files, it
definitely performs like USB 1.1; it takes 7 minutes to download 355
megabytes worth of photos.

It is worth noting that when I try & install the drivers, they don't
seem to install normally. But, BEFORE installation, the "Enhanced Host
Controller" is not there; afterwards, it is.

I set a system restore point to before I installed it, and have tried
doing it repeatedly. Nothing works.




Sorry for the bother, I did find the fix. I will document it here in
case anyone else needs the help.

Maybe I should post this under the newsgroup for PC Chips
motherboards, because it appears that is where the issue lies.

The motherboard is a PC Chips M811LU. I downloaded the USB 2.0 driver
(a ZIP file) and extracted the contents.

The readme file (.doc, Wordpad opened it) said to double-click the
setup.exe (which makes sense), but the setup.exe that resides in the
folder with the readme file didn't do the trick.

I tried using the setup.exe located under the "patch" folder, and that
did cause the "VIA Enhanced Controller" to show up, but not at USB

The trick was changing the driver of the VIA Enhanced Controller to
the INF file located within the MSUSB_XP zip file (a file that results
from extracting the original downloaded ZIP file). So the steps were

(1) Download the ZIP file for USB 2.0
(2) Extract it to a folder
(3) Find the MSUSB_XP zip file and extract it to a like-named folder
within this structure
(4) Double-click the setup.exe within the PATCH folder, reboot
(5) Browse to the VIA Enhanced Controller in Device Manager, change
(6) Don't download driver, and get to the option where it lets you
choose the "Have Disk" route (forget exactly how to get there, I
assume reader of this material knows how to get there)
(7) Use the .INF file located within the MSUSB_XP folder

Again, I think this belongs in the newsgroup for this motherboard, and
I will post there. But since I had already posted here (thinking maybe
it was an XP issue), I figured I'd follow up with my fix.

Thanks anyway.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question