USB 2.0 Not working since Vista Upgrade



Since installing vista (upgrade from XP) I no longer seem to have any USB 2.0
ports. When I insert a 2.0 device I get the "device could preform faster
bubble". All my USB ports are USB 2 capable and worked with XP (MSI K9NGM2
motherboard using Nforce 430 chipset).

Looking at my USB controllers I have
1) Standard Enhanced PCI to USB Host Controller (the USB 2.0 controller I
2) Standard OpenHCD USB Host Controller (USB 1.1 support)
Any device I plug in ends up on the OpenHCD controller and I get windows
telling me to put it in a different port (I have tried every port on my MB
and they should all be 2.0 enabled).

I am usually quite good fixing computer problems and have flashed the Bios,
installed the latest Nforce chipset drivers and tried unstalling the USB
drivers (with all USB devices removed) and restarting. All to no avail -
Vista seems intent on putting my USB devices on the wrong controller. I have
also installed the USB fix rollup KB941600.
The next step will be to uninstall this next gen/step backwards OS and go
back to XP. Any suggestions would be really helpfull. Thanks


Hi Idnlgeah ,

When installing an operating system, I recommend that wherever possible you
do a clean install. This enables the new OS to start off on a clean slate
with no detritus from a previous installation and it can also prevent driver
conflicts in certain setups. If you follow the instructions in my post 'Clean
Install Windows Vista Using Upgrade Media', in the newsgroup 'Windows Vista
Installation and Setup' (dated 9/21/2007), you should be able to solve your
problem. If necessary, you can print these out so that you can refer to them.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question