"The object could not be found." error when creating new custom fo


D

DavidT543

I develop a lot of custom forms and COM Add-ins mainly using Outlook 2003 for
compatibility reasons.

I've just been starting a custom contact form in OL2007. I made the smallest
of changes on the general page of the contact form (added one additional
caption ) and published the form to a new Public Folder. I then set my new
form as the default item.

If I try to create a new item by clicking 'New' on my new folder, I get an
error message "The object could no be found". If I use the same folder in
favorites - it works fine. I can create a new item and save it. I can then go
back to the original public folder (not in Favorites) and open my newly saved
item perfectly. But if I try to create a new item I get the same error
message again "The object can not be found".

It reminds me of Outlook 2003 before SP1 was released to allow custom forms
to work in offline folders. My favorite folders are set to work offline if
that makes a difference. I thought it might be something to do with the
Outlook View Control (has caused me similar problems in the past) but I tried
the same test with a new custom task item and get the same error.

I see a few other references to this in various forums, but no real
solutions. Any suggestions anyone?
 
Ad

Advertisements

D

DavidT543

I just noticed that in the 'normal' public folders when I open an item, it
always shows the 'Installing the form on your machine' message when I open an
existing item. Every time - even if I open three items in the same folder in
a row.

I works fine as expected in Offline favorites! Curiouser and Curiouser.
 
D

DavidT543

Thanks Sue - but Yes I have cleared the forms cache - both from within
Outlook and by closing Outlook and physically deleting the forms cache file.
No change!
 
D

DavidT543

OK - its fixed, and having tried a number of solutions, I'm not quite sure
which resolved it. For future reference here is what I did.

I switched off 'Cached Exchange Mode' in the Exchange Settings (in Outlook).
That fixed the bug - but I want to use cached mode so a fix but not a
solution.

I archived a bunch of large emails from public folders to get my .ost file
size down from 1.8Gb to 1.2 Gb. Not sure that this had any impact but speeded
up the process of creating a new ost in the next stage.

I swiched off 'Download Public Folder Favorites' in the advanced tab of the
Exchange Settings (in Outlook) and deleted my .ost file.

I deleted frmscache.dat AND all subfolders (as suggested by Sue) which I
suspect is what actually provided the solution. The path to this folder on my
pc is 'C:\Documents and Settings\Administrator\Local Settings\Application
Data\Microsoft\FORMS'

I then set Outlook to use Cached mode, and set Outlook to download public
folder favorites. Strangely I didn't need tell Outlook which Public Folders
to download. It OL2007 seems to just download them all anyway (as opposed to
OL2003 where you can tick which ones you want to take offline) Is this a
feature or another bug in my system?

I closed and restarted Outlook between all of the above changes just in case
it needed to catch up with itself in settings etc.

Thaks Sue for pointing me in the right direction.
 
Ad

Advertisements

S

Sue Mosher [MVP-Outlook]

Best practice is to use a non-cached mode profile when publishing forms. That
might prevent similar problems in the future.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top