Stop Message 0x7E



I just upgraded my motherboard, and processor to an AMD 64 3200+ with an
ECS EliteGroup 755 A2 mobo. I reused my hard drive Maxtor 160gb, Ram Pc3200
512mb, Nvidia GeForce 5200 Ultra 128mb video card. I have Xp home edition
with SP2. When I started it up after installing the new hard ware, it booted
normally until reaching the windows xp startup screen with the scrolling blue
thing. Then got the blue screen of death and 0x7E stop message. The exact
message looked like this

Stop Message 0x0000007E: (0xC0000005, 0xF8F31750, 0xF9200430, 0xF920012C)
It didnt list a driver or sys file associated with it. I was able to
start in safe mode, and after checking the Dr Watson log file, showed an
Access Violation from rstrui.exe. I dont know if the 2 errors are linked, im
not a software guru by any means. I dont have an XP cd to reinstall with, so
Formatting the hard drive is pretty much out of the question. Please reply
if you can help... i miss my computer already!

AMD 64 3200+
ECS Elitegroup 755 A2 mobo
512 mb PC3200
Nvidia GeForce 5200 Ultra 128mb
Maxtor 160Gb HD
XP Home Edition SP2



Mark L. Ferguson

You are not going to both replace a motherboard, and save the install, while not owning the setup media to do a Repair setup.

David Candy


The SYSTEM_THREAD_EXCEPTION_NOT_HANDLED bug check has a value of 0x0000007E. This indicates that a system thread generated an exception which the error handler did not catch.

The following parameters are displayed on the blue screen.

Parameter Description
1 The exception code that was not handled
2 The address at which the exception occurred
3 The address of the exception record
4 The address of the context record

This is a very common bug check. To interpret it, you must identify which exception was generated.

Common exception codes include:

An unaligned data reference was encountered.

b.. 0x80000003: STATUS_BREAKPOINT
A breakpoint or ASSERT was encountered when no kernel debugger was attached to the system. • 0xC0000005: STATUS_ACCESS_VIOLATION

A memory access violation occurred.

For a complete list of exception codes, see the ntstatus.h file located in the inc directory of the Windows DDK.

Resolving the Problem
If you are not equipped to debug this problem, you should use some basic troubleshooting techniques. Make sure you have enough disk space. If a driver is identified in the bug check message, disable the driver or check with the manufacturer for driver updates. Try changing video adapters. Check with your hardware vendor for any BIOS updates. Disable BIOS memory options such as caching or shadowing.

If you plan to debug this problem, you may find it difficult to obtain a stack trace. Parameter 2 (the exception address) should pinpoint the driver or function that caused this problem.

If exception code 0x80000003 occurs, this indicates that a hard-coded breakpoint or assertion was hit, but the system was started with the /NODEBUG switch. This problem should rarely occur. If it occurs repeatedly, make sure a kernel debugger is connected and the system is started with the /DEBUG switch.

If exception code 0x80000002 occurs, the trap frame will supply additional information.

If the specific cause of the exception is unknown, the following should be considered:

Hardware incompatibility. First, make sure that any new hardware installed is listed on the Microsoft Windows Hardware Compatibility List (HCL).

Faulty device driver or system service. In addition, a faulty device driver or system service might be responsible for this error. Hardware issues, such as BIOS incompatibilities, memory conflicts, and IRQ conflicts can also generate this error.

If a driver is listed by name within the bug check message, disable or remove that driver. Disable or remove any drivers or services that were recently added. If the error occurs during the startup sequence and the system partition is formatted with NTFS file system, you might be able to use Safe Mode to rename or delete the faulty driver. If the driver is used as part of the system startup process in Safe Mode, you need to start the computer by using the Recovery Console to access the file.

If the problem is associated with Win32k.sys, the source of the error might be a third-party remote control program. If such software is installed, the service can be removed by starting the system using the Recovery Console and deleting the offending system service file.

Check the System Log in Event Viewer for additional error messages that might help pinpoint the device or driver that is causing bug check 0x1E. Disabling memory caching of the BIOS might also resolve the error. You should also run hardware diagnostics, especially the memory scanner, supplied by the system manufacturer. For details on these procedures, see the owner’s manual for your computer.

The error that generates this message can occur after the first restart during Windows Setup, or after Setup is finished. A possible cause of the error is lack of disk space for installation and system BIOS incompatibilities. For problems during Windows installation that are associated with lack of disk space, reduce the number of files on the target hard disk. Check for and delete any unneeded temporary files, Internet cache files, application backup files, and .chk files containing saved file fragments from disk scans. You can also use another hard disk with more free space for the installation. BIOS problems can be resolved by upgrading the system BIOS version.


I have not been able to locate where the memory gets dumped to. I have
changed the option under the Advanced tab for system info to perform a full
memory dump, and specified it to be placed in C:\memory.dmp But it's no where
to be found. Once I get this issue resolved, how will I trace the address
back the driver or device that the error is associated with?

To answer a couple things listed in your reply... I have approx 110 gig's
of space in my hard drive. I have the most up-to-date BIOS my mobo
manufacturer has. And I have installed as many of the drivers for the mobo
as I can find to see if that was the problem. Another issue is the Windows
Installer program wont let me use the auto install feature on the cd.

Also, I think this my be part of the problem, when I try to use the System
Restore on the start menu under System Tools, I get an error... When I check
the Dr Watson log, It shows a 0xc0000005 Access Violation Error...

I hate messing with software, please help me before I smash my computer into
little pieces!!!!

David Candy

Don't do a full dump. Noone will want that file from you. It's just too big.

Understand I don't get blue screens. But you should get a dialog on restart which has a details link. That will show you the file names. I think it gets deleted after you choose send/don't send.

If the problem is known the dialog will say there is more info after sending and do you want to read it. This will have the fix.

You can type in Help while online

0x7e or 0x0000007e (you might need both) - you should get around 10 hits.

and it will tell you known problems that you can look at. EG

When you disconnect a CardBus Compact Flash (CF) adapter, your computer may stop unexpectedly and you may receive the following stop error in Pci.sys on a blue screen:

So if you aren't disconnecting a CF adaptor then this isn't your cause.

You can also request support from MS via

Read around on the site.

You can also get a memory tester from here

Type in a command prompt

cacls C:\WINDOWS\system32\Restore\rstrui.exe

and check you have permissions.


Ok, so I can change it back to mini dump in the Advanced tab of the System
Properties, but where does the dump go? As in, which file does it go into?
I do not receive a windows error message once booted up in safe mode in
regards to the "blue screen" error. The only time I receive a windows error
message is when I try to open the System Restore Program, or click on the
System Restore tab of the System Properties window. I can view the details
of that error in the window provided, or in Dr Watson's log file... But I do
not believe the 2 faults are directly linked, as I can remember there being
intermittent problems with the System Restore tab in the past.



David Candy

It goes to your temp directory in a wierd named sub folder containg two files (this is the part sent to MS). Minidumps also go into c:\windows\minidumps. You do have error reporting turned on don't you? Dr Watson is the debugger if it's not on. Don't boot into safe mode after a crash (after all what do you actually do in safe mode? Reboot back to normal?).

Your stop message is an Access Violation (I looked up parameter1 of your error and pasted the meaning at the top of my first post). System Restore (that other error - what was it in full exactly?) also generating Access Violations seems worthy of investagation. System Restore is a type of app that could cause a Stop Error (most apps can't cause them - it's hardware or drivers).


Ok, found the minidump folder, but there arent any new files since august
2004. Also when I open one, it's just garbage. Is there a specific font it
should be in??

I have error reporting on, however there are no Windows Error message pop
up's to view the technical details of 0x7E. I also have to boot it safe mode
to get to windows, if started in normal mode, I get the blue screen of death
just before windows would normally load everytime, and cant competely boot up.

I do however get a pop up error window for the System Restore problem...
How do I go about fixing this problem? It lists 30 modules... Dont really
know what that means.

I checked the Event viewer, and saw several errors... 4 services unable to
function due to "a hardware device not functioning." These services are AFD
Networking Support Environment Service, TCP/IP Protocol Driver, NETBT Service
and IPSEC Driver Service. These services not being able to start, also
caused other services to have errors, which is what is reported in the Event
Viewer. So the errors were reported like this.... "Xxxx service was not able
to start due to NETBT Service not functioning properly. Reason for this
error is: A hardware device not functioning."

Any ideas??

Joshua Smith [MSFT]

Hi JDizzle995,

You can try the following to get a better minidump when your system
bugchecks. This will help to determine what driver is causing the problem. I
need you to enable driver verifier.
1) Windows Key + R
2) Type in 'verifier' and hit enter
3) Make sure 'Create Standard Setting' is selected and hit next
4) Click on 'Select all drivers installed on this computer' and hit Finish
5) Reboot

There is a possibility that your computer will crash on reboot. If this
occurs hit F8 when rebooting just before the windows logo screen and select
the safe mode boot option. Follow the same steps above but on step 4 choose
'Select driver names from a list'; hit next; check the box next to any
driver where the provider is not Microsoft; hit Finish; reboot.

This will slow the performance of you computer a little while enabled but
will hopefully catch the driver causing corruption. Next time you crash
the blue screen will hopefully say something like
"DRIVER_VERIFIER_DETECTED_VIOLATION". If this occurs please send the
corresponding minidump (by default it is at c:\windows\Minidump ) my way.
If you have any questions or I didn't explain something well enough don't
hesitate to e-mail me back. Good Luck,

Joshua Smith
OpenGL Test Lab


Ok, ran the verifier. The first time I ran it, windows crashed and gave me a
completely different error, and referenced IOMDISK.SYS below an error message
of 0xD6.

So I re-ran the verifier and selected only the drivers that werent signed by
microsoft. I got the same 0x7e stop message with a different address...
0xFBF37750... It didnt show the driver verifier detected violation error
either, and didnt list any specific drivers. Also there was no new file in
the minidump folder. I verified the directory where it's setup to dump to...
"%systemroot%\minidump".... which would be the equivalent of

Any more ideas??

Joshua Smith [MSFT]

Hi JDizzle995,

Try going to Iomega and getting the most recent drivers for your Zip
Drive. That is what uses the iomdisk.sys driver. The "%systemroot%\minidump"
location is the same as c:\windows\minidump, providing everything was
installed default . You can try opening a cmd window and search to see if
you can search for it.

1. Start -> Run
2. Type cmd in the Run dialog.
3. In the cmd window type cd\ and hit Enter
4. When the prompt indicates your current directory is c:\ type "dir *.dmp
/s" without quotes.

This should show you all the files on the system that have the .dmp file

Joshua Smith
OpenGL Test Lab

Get Secure!

This posting is provided "AS IS" with no warranties, and confers no rights




Im at work at the moment, I'll download the new driver, and install it when I
get home.

About the minidump folder, if i cant see it in the folder while in windows,
would I be able to find it in dos?? It's got to be sending the dumps
somewhere right?

Also, I emailed you this morning but it got sent back. Do you have a more
current one besides the one in your profile in the newsgroups? My work email
address is (e-mail address removed)

Thanks for the help,


Ok, well I didnt think I could do it, but I screwed my computer up more! I
checked the IOMDISK.SYS after installing a new version of IomegaWare. And it
didnt install a newer version of the driver, which was being called out when
I ran the Driver Verifier on all drivers on my computer. So I checked for
new drivers on the Iomega Site.

It seems they dont have the driver for my specific Zip Drive, which is a 250
USB. So I uninstalled the software, disabled driver and moved it from the
windows system 32 folder to the desktop and rebooted.... Got a new Stop
Message, and now the computer will not boot in normal OR safe mode! Ooopsy!
tee hee... So I dont have a recovery disk to run Recovery Console to move
IOMDISK.SYS back in to the Windows System32 folder... so now im at stand
still until I can get that file back in to the folder.




Also, the only .dmp file that has been created or edited in 2005, was one in
the Dr Watson file, named "user" It seemed to contain a dump from the last
time I tried to access the System Restore program, the same information was
the most recent entry into the Dr Watson Log, the time on the "user" file and
the time of the entry to the Dr Watson log were the same... So still not
able to find a .dmp file that has any info about the 0x7E...

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question