SOLVED: ERROR >> "Access Denied" with Maxtor OneTouch 4 backupsoftware


F

FUBARinSFO

ROBLEM

When backing up a Windows XP data drive to a Maxtor OneTouch 4 Plus
drive, 19,452 files were not backed up ("Unable to backup 19452") On
inspection, the error messages were of the below form

Examples:
--------------------------------------------------
ERROR >>> D:\G\Scans\<folder>\<filename>.pdf Access
denied
ERROR >>> D:\G\AZ Commercial\<filename>.exe Access
denied
ERROR >>> D:\G\AZ Commercial\<filename>.hlp Access
denied
ERROR >>> D:\G\Scans\<folder>\<filename>.xls Access denied
--------------------------------------------------

There was no particular pattern to the problem other than they all
seemed to be on one drive (G:) -- all kinds of files were denied, yet
others of the same type were backed up. Access was denied to some
files with a folder, while others within the same folder were backed
up.


SOLUTION

Add 'Everyone' to the permissions on the root (if it is not already
there), and propagate the permissions to all child folders and files.
This will allow the software to access the files,


DISCUSSION

Because all the problems appeared to be associated with one drive
(G:), and because this drive letter was in fact a local drive mapping
off the physical partition D: (D:\G), at first glance it appeared that
it might be associated with local drive mapping, as had been the case
with some other application software that was not able to distinguish
between local and remote drives, or would not install or load properly
from a mapped drive. The problem at this stage was posted to Maxtor/
Seagate tech support. This has confused them, and at this point it is
clear that they have not run into this problem before.

But on further inspection of the security status of the individual
source files themselves, I eventually noticed that some files had
multiple permissions -- Administrator, Everyone, SYSTEM, etc. -- and
some had only Administrator as the security permission. On further
testing with a sample subset, I found that the files with only
Administrator as its security privilege level would not be backed up,
whereas the files with multiple permissions would be backed up
successfully.

It also turned out that the files that were backed up successfully
had all their permissions merged into Everyone, but with "full
control" instead of just "Modify'. The actual specific permission
status of the files had been lost, but the effective permission level
had been attached to Everyone as a union of the source set of
permissions.

So it appears from this that Maxtor OneTouch 4 Plus backup software
runs only at the Everyone level, and cannot access higher-level
permission files, even though the logged-on user is in fact
Administrator and the process itself has Administrator privileges.
Either that, or the files themselves have to have "Full control"
security level.

I didn't make an exhaustive check of this situation, so there may be
some simpler way to get the same result. At this point, since the
target backed-up file has only "Everyone" as its security group, with
merged attributes that include "Full Control", Full Control may be
necessary also (though I doubt it). I'm assuming here that just addind
"Everyone" to the root and propagating the root to the subfolders and
files will solve the "access denied" problem.

-- Roy Zider


--------------------------------------------------
System:

750 GB OneTouch 4 Plus
Model STM3075040TY3E5-RK
Software version 4.02.0303 (latest as of 8/30/2009 17:34)
Maxtor Manager 4.7.0.7 (per GUI screen)

OS Name Microsoft Windows XP Professional
Version 5.1.2600 Service Pack 3 Build 2600
--------------------------------------------------
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top