RPC server unavailable


G

Guest

We are experiencing a problem in several different Terminal Server
environments. All environments are 2003 AD domains with one or more Win 2003
Terminal Servers. At the largest site, with about 75 users spread over 3
terminal servers, the error occurs within every 48 period on each of the
terminal servers unless the servers are rebooted. The 3 servers do not get
the error at the same time, but all within that 48 hour period from the
reboot. At the less busy sites the error comes, but it usually takes 4-6
days to reach the error condition.
The problem is first manifested when some user attempting to make an RDP
connection to the terminal server receives an error "unable to log in: the
RPC server is unavailable". At this point no new RDP connections can be made
to that server (others in the farm still work until they meet the error
condition), but the existing RDP connections are not affected. Also, no
other services that use RPC work either. Errors related to RPC server
failures begin to pile up in the event log of that server from all the
services that use it(RPC). The existing RDP sessions continue to operate
fine except for functions that require RPC, but no new sessions can be made.
When sessions log off or disconnect, they can't reconnect. A reboot is
required.
The error continues to occur (at this location and other sites) no matter
what SP is on the servers. We've tried clean OS installs, adding just hotfix
832521 (which someone recommended), and clean OS installs with SP1.
Still the same symptoms continue on each server at each site. The
frequency of the error condition does seem to directly correlate with the
amount of terminal services connection activity it gets. Once the RPC server
resources are spent, they don't become available again until the server is
rebooted.
I've seen a few (very few) other threads online that do describe this
problem almost exactly, but no resolutions. Those threads claim that the
problem only shows up in very specific network configurations (Win2000 AD
domains with 2003 servers and/or networks NOT running NETBIOS. Our networks
do all have NETBOS left OFF. One thread claims it is a MS bug dealing with
RPC server using all of a system resource (kernel mem). DNS misconfiguration
has also been suggested, but DNS appears to be running perfectly at each of
the sites.
thanks -baulrich
 
Ad

Advertisements

Z

zaknafeinr1

Well, I went through this "RPC Server Too Busy" problem and also a
related Secure Channel issue. Windows 2003 AD domains with Windows 2000
Terminal Servers (about 100). There were apparently a myriad of factors
involved, but it revolved around: The original MS05-19 patch, a Domain
wide GPO setting for SMB timeouts (ours was mysteriously set to 0
instead of 15). We fixed this problem by installing the re-released
MS05-19 patch (v2), installing a non-ppublic RPC hotfix from MS, and
re-imaging most of our machines. Use NLTest.exe from the reskit to
check if the secure channels between the terminal serves and the domain
controllers are experiencing errors (ours were, but this might have
been a separate problem). I think this is caused by a bug in the
Windows code that overloads the RPC process over time. Good luck. This
was one of the most painful issues I have ever encountered. I have a
whole lot more background on the problem, but it is too much to write.
Feel free to post a reply and I will try to answer any specific
questions you may have.
 
Ad

Advertisements

G

Guest

What was the hotifx # of the non-public hotfix from MS that you installed.
We also received one from them (it was 832521)?? So the hotfix you mentioned
in conjunction with v2 of the MS05-19 patch fixed the problem?? Were you
also running SP1?? or Does SP1 for 2003 server include one or both of those
patches??

thanks -baulrich
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top