Resolved problem with PXE-E55 by removing additional IP addresses assigned to RIS server

  • Thread starter Matthew X. Economou
  • Start date

M

Matthew X. Economou

I fixed a problem with a RIS server not responding to ProxyDHCP requests by only
assigning a single IP address to the server's network interface. I am
documenting it here for posterity's sake. I did not find any documentation that
suggested checking the IP configuration as part of troubleshooting PXE-E55
errors.

If someone from Microsoft is in the house, would you be so kind as to document
this in a Knowledge Base article or (even better) consider this a bug report and
fix it in some future hotfix or service pack?

(By the way, one more request, this time of the audience. Would you people
please follow up your problem reports with solutions, or at least some kind of
status? I kept finding lots of problem reports and even a few suggestions on
how to troubleshoot this particular problem, but not one person followed up with
"it worked" or "it didn't work, but I fixed it like so".)

The situation:

- The RIS server is running an up-to-date version of Windows Server 2003.

- The RIS server worked at one time in the past, and no RIS configuration
changes had been made.

- The RIS server is also being used as a web server, and the administrator
assigned multiple IP addresses to the server's network interface (NIC) in order
to use IP-based virtual hosts in IIS.

- Several months after this change was made (RIS is used infrequently at the
client's site), systems attempting to boot via PXE reported the following error:

"PXE-E55 ProxyDHCP: No reply to request on port 4011"

- The client searched the web, checked the event logs, and verified that the RIS
services were running properly.

The resolution:

I was going to run an Ethereal packet capture on the RIS server when I noticed
that it had multiple IP addresses assigned to the NIC. On a whim, my client and
I reconfigured the NIC to have only one IP address and PXE-booted a VMware
virtual machine. Instead of reporting the ProxyDHCP error, it requested and
received an IP address and continued with the PXE boot process (TFTP transfer,
execution of the OS chooser, etc.).

Best wishes,
Matthew
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top