Remote Desktop Issue: Black Screen, Can connect to other computers



I am currently at work. In the past, I am able to remote desktop to my home
computer. Over the weekend, I formatted my computer and reinstalled stuff and
I reconfigured Remote Desktop in my Win XP SP2 computer (all the updates are
installed except for SP3, since I have software that does not work on SP3).

So today I went into work (Win XP SP3 computer) trying to remote desktop
connect to my computer, All I get is a black screen. I also tried a different
computer at work on the same server and have the same outcome (the black
screen after I type in my username and password).

The weird part is, when I do VPN into a different server (a non-work server)
I can connect to my home computer at my work computer. So i figure they
blocked my ip address or remote desktop.

So I first tried telnet my ip address with the port remote desktop is on
(3389). And it works, my work computer without VPN can telnet to my home

So next I tried remote desktoping to my mom's computer (different ip address
from my home computer, Win XP SP3 computer). I was able to connect to my
mom's computer. Then I decided to connect to my computer through my mom's
computer (so in this case I remote desktop to my mom's computer and use my
mom's computer to remote desktop to my home computer) and that WORKS.

Can anyone provide any suggestions and solutions on why I cannot connect to
my home computer with my work computer? I would rather not use VPN (since I
can't access my work share drive) or connect to my mom's computer to connect
to my computer.

Is it possible that my workplace block my home ip address, but I am still
able to connect to the black screen, ping (80) and telnet (3389) to my

Sooner Al [MVP]

I would make sure you have the latest video drivers installed on the
home PC as a start.


Al Jarvi (MS-MVP Windows – Desktop User Experience)

Please post *ALL* questions and replies to the news group for the
mutual benefit of all of us...
The MS-MVP Program -
This posting is provided "AS IS" with no warranties, and confers no
How to ask a question


yes i have the latest drivers based on the Sony drivers website. I checked
to see if Nvidia's website have any drivers (nVIDIA® GeForce® Go 7400) and it
does not.


I also tried decreasing my MTU packet size as an optmal size (so it doesn't
need to be defraged) and still no luck...

If anyone have any suggestions, that would be great.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question