redirect printer does not work

  • Thread starter Raimond Kempees
  • Start date

Raimond Kempees

I have a couple of printers client side that will not
redirect to my W2KAS machine in Application Mode. However,
on my DC they do get redirected in the every proper way.

They printer drivers I need are not native drivers, but
after installing those drivers (HP dj 990c) on my DC, the
printer got redirected fine, but this did'nt work on my TS.

I tried everything listed on the MS knowledge base: custom
inf, looking at possible access rights settings in the
group policy, moving the machine to another group policy,
etc etc.

The funny thing is: the port (TS00x) is being
created/mapped. Only the printer queue isn't been created.

How can I solve this problem?

Matthew Harris [MVP]

What type/version of printer driver is your DC using? Are
those the same drivers as your other server?


Raimond Kempees

We are using the exact same drivers. I installed
everything fresh from the same driver directory.

Drivers are version 3 drivers, for both the 990c and the

But I don't think its the drivers, because I installed
them on my DC as well, where the printer got mapped just

That's the problem, because I also do not see the 1100-
series events in my event log. Somehow I suspect that my
TS thinks the queue is already there while it is not. Do
you think access rights might be the problem? If so,
which? Or maybe previously installed printers?

Anyway, thanks for your reply. :)

Raimond Kempees

Raimond Kempees

Ok, I am pretty sure it's not a driver problem, because I
installed an old printer, for which windows 2000 has
native drivers. In this case the printers also did not got

Then I removed SP 4 from the server, put it back into its
old state, but no printer was redirected.

I verified all the client settings again and the RDP-
connection settings. Everything is allowed to redirect.

The last option is to reinstall de machine. But I hope
that someone here can give the golden tip first. ;)

Matthew Harris [MVP]

You typically don't see those eventlog errors unless the
system can't find a driver, but occasionally the system
will find a driver, but that driver doesn't produce any
reasonable output when something hits the queue.

I'm a little stumped...I assume you have rebooted your
machine a few times, right?

Have you tried hooking the printer up to another machine
to see if the terminal server will map it then? Have you
tried logging in with a different user who has a different


Raimond Kempees

Well, to tell you the truth, I'm stumped too. ;)

I have rebooted my machine 4 times now. Also I have tried the printer, and
other printers on

3 different computers. Also I have tried logging in with a couple of
different user names on

the client machine as well as on the terminal server.

What I havent tried yet is edit the ntprint.inf file itself. I am

going to try that right now and let know here what's happening.

Again, thanks for your time reading this.


Raimond Kempees

Editing printupg.inf didn't work too. I didn't dare touching ntprint.inf, as
it is signed and you need a specific driver(?) or registry string. Or should
I dare do that? ;)

Raimond Kempees

Well I managed to solve the problem...
By installing the server all over again.

I used exactly the same configuration settings and drivers for my printers,
and now the getting redirected very good.

I'm pretty happy with it, although I am slightly annoyed for having found no
reason why the TS didnt map printerqueues before. I hop to find out one day

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question