Printer spooler not working - *** HELP ****



I'm having trouble adding my printer ( Canon all in one Photo Printer
- PIXMA MP480) to my Notebook ( HP Pavilion dv6775us Notebook PC,
Windows Vista Home Premium, 32bit). I keep getting a message that
reads: "windows can't open add printer.
The local print spooler service is not runnig please restart the
spooler or restart the machine".. Needless to say i have resarted the
machine and I still get the same message. Prior to trying to add this
printer I had no printer and a friend of mine gave me his old printer
( LEXMARK Z645) i tired to add this printer while i waited on my
printer to come to me. When i ran the install cd for the LEXMARK i
didn't notice it was only XP compatible. After running the software i
was prompted by a message that stated this software was not
with my operating current Operating system. My friend who says he
know more about PC than I had me download the Vista drivers for the
LEXMARK printer from the Mfg website. When I ran the download the
print queue seemed to recognized the printer but then later displayed
message that the installation had failed. after unistalling and
reinstalling the software and the file downloaded from LEXMARK i
had the same problem. I was so frustrated that I didn't now what to
do. The print queue seemed to be stuck with a test job that the
printer had ask me to do and i could not stop it or resume it. Some
how my friend got it to delete the job but then my print queue
dissappeared. So i figured It was a error due to the LEXMARK printer
being so old. I left it alone, now i have my new Canon printer which
is Vista compatible and I tired running the software. I got message
window that read installation no complete and then i got the window
that read: windows can't open add printer.The local print spooler
service is not runnig please restart the spooler or restart the
machine. I tried restarting it and i went through the Services
to try and restart the spooler but it then gave this error message:
Error 1068 the dependency service or group failed to start.

I don't have any Printer listed in my printers folder and the spooler
is nowhere to be found. I don't know what to do. I tried searching
through the windows message boards and well i'm frustrated because no
one seems to have the right answer for me. Most of the message i
were for a similar problem with XP but none for Vista. I can now
officially say I hate VISTA!! and well i really hope someone can help
me cuz i'm out of ideas.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question