printer spooler issue in windows vista



Hello all

I have this exactly same problem as Eddie, Pimp Daddy Addy, irondog,
Mr. raspy, and many many more users in (and outside) this forum

It is clear that there is an (yet) unidentified issue with the Windows Vista
Spooler with regards to different printers (mainly HP and Lexmark but also
Canon, Epson....)

the "symptom" is always the same

1) all the printers have disappeared from the control panel printer folder
(including virtual printers such as MS XPS or Acrobat printer)

2) when trying to install (add) a new printer : an error message appears,
telling that the spooler is not running (or similar messages

3) when checking in the services.msc console,
we do see that the spooler has stopped

4) when starting the spooler, it seems to stark ok,
but as soon as we try to (again) "add" a printing (using the
appropriate button)
-> the spooler immediately crashes (stops)
and the same error message occurs
- spooler not started and/or
- windows can't open add printer and/or
- Operation could not be completed and/or
- error 0x000006be
- etc...

So the situation is "delicate"
- OS is Windows Vista (no mater the version)
- The printers are various (HP; Canon, Lexmark, Epson)
- The "control panel printers folder" is empty
- It is impossible to add a printer (using the appropriate "add" button)
- The spooler seems unstable and stops itself when attempting to add a printer

Does someone know the solution?

thank you very much in advance



LAB Enterprises

I had this problem trying to install a network printer on a different
computer, so I plugged the printer directly into my vista computer,
installed it, did a test print and all okay. Then I connected the printer
back to its normal network location and reran install from my vista machine
and it has worked perfectly ever since.



Thank you for your help Lori

but my problem has no link with any network (or network share printer)

my printers (3 of them) are local, different types and different brands

the problem clearly does not come from the printers (nor the drivers) but
from the spooling subsystem itself !!!

starting the spooler looks all right
but in the windows vista control panel printer folder,
1) no printer are presents
2) simply pressing the "add printer" button instantly turn the spooler of
(or crashes it ?)

so... nothing to do with networking matters...



LAB Enterprises

Hmm. I had a problem with the spooler dying all the time too, but cannot
remember what it was that I did to fix it. Sorry.



I have a problem with the spooler as well.
One PC has Vista Ultimate 32 bit with an HP AIO laser printer connected to
it and shared on the network, and the other is a laptop running XP pro and
the laptop gets spooler errors all the time. The only thing that will fix
it is a reboot.



I don't think this issue has any relation with the network system
and, definitely, a simple reboot does not solve the problem at all

any other ideas ?


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question