Print Spooler service problem


N

Nick Thompson

Running XP Pro SP2 as a sever in a home network (problem began under SP1).

When trying to add a printer under "Printers and Faxes", I get this error:
"Operation could not be completed. The print spooler service is not
running."
I also get an error when trying to access the server properties:
"Server properties cannot be viewed. The print spooler service is not
running."
Went to the Print spooler service and restarted it and the RPC dependent
service with no luck. The service stops as soon as I try to add the printer.
Any suggestions? Thanks.
 
Ad

Advertisements

G

Guest

How do you find if a services is corrupt, is there a tool to use for a
verification?

And yes I have the same problem on brand new WinXP Sp2 load, and am
currently on hold with TechSupport at this time ;)

- Jeff
 
G

Guest

Thank you Cari, I have made note of this website and will try that. I am also
going to try and uninstall all the printers, and then install 1 by 1 and see
if maybe a driver from 1 of the printers is over writing spool service
driver, or maybe even rename the spoolsv.exe and copy from another working
machine!

Thanks!

PS: Will be having a Support Specialist call me back monday from Msft to
help resolve issue aswell, and will update what my turnout might be.
 
Q

qjchen

I have a similar problem but not sure of the same cause:

I have my notebook (setup as WORKGROUP and is NOT a machine in the
domain.)

I CAN add a network printer, with proper user id and password, But
after I print several times, my "printout" goes nowhere, check the
printer's property, it says, "Printer properties can not be displayed,
The print spooler is not running", I have to delete the printer and add
it back to print again.
 
Ad

Advertisements

G

Guest

Resolved Issue :

After working with Msft for 3 1/2 Days on this issue, and having them
dialed into the laptop in question via Msft Live Meeting, and spending about
36hrs on this problem with many WinXP dump files sent to Msft, and event logs
and so fourth. We finally ended up getting this issue resolved on Tuesday
late in the after noon.

After being on the call with the Tech Support agent for 4hrs, we tried
various registry hacks and settings, and print clearing out with
{cleanspl.exe} from the Win2003 Resoure Kit which helped clear some items out
of the registry and also ran a program called {ListDlls.exe} which shows what
other resources are being run against a certain service when they are
running, like what files are independant upon what service and what there
resources are being used.

The end result ended up being a program called REMCON/PCDuo/NetSupport
(Similar to PC Anywhere) was being executed from the start of the machine and
then was taking priority over the service before the actual loading of the
desktop was completed, so the spoolsv.exe would be failing right at the
loading of the desktop since it was having a tuggle war over the service and
would fail everytime...

This was discovered using MsConfig and disabling all msft services on the
startup tab, and then ruling out certain files 1 by 1, and then it came down
to being the REMCON file being used, and then we were able to re-enable the
services besides that one, and then uninstalled the application and
reinstalled my printers with no problems what so ever.

It took a while to finally figure this one out, so from now on that program
is no longer part of our PC Load Images! Thank you to our holding company in
Germany!

And a big thanks goes out to the fellas at Microsoft for assisting me in
this mind boggling issue free of charge for the on going support I received!

these guys rocked !~

PS: I believe I spoke with every single Msft office that is in existance,
except for the NC based office, which is like 2-3hrs from me*L*
 
Ad

Advertisements

G

Guest

You could have solved the problem far easier by disabling the print capture
feature of that remote control software within the client configuration. ;o)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top