Outlook 2003 free/busy no information


G

Guest

I have read others posts and found that you are also seeing issues with
Outlook 2003 Calendering Free/Busy searching. We have a sporadic issue when
people try to schedule meetings and find that there is "No Information"
available when doing a Free/Busy search from Outlook 2003. But on most of
our clients they work just fine. Here's our environment

Windows XP SP2
Microsoft Office 2000
Microsoft Outlook 2003
Exchange Server SP1
AD Group Policy to globally set the Free/Busy options to the following
-Publish "6" month(s) of Calendar free/busy information on the server
-Update free/busy information on the server every "5" minutes

Is this a known bug in Outlook? Exchange?
Is there a fix for the issue?

Any help would be greatly appreciated. Thank you
 
Ad

Advertisements

S

sally.mcphillips

I am experiencing the same thing. The frustrating part is that it is
not all users, as you state, it's sporadic. Our environment is close
to yours, except for the 6 months, we are 3. I have tried to start
Outlook with the /cleanfreebusy switch, but it doesn't do anything.

If someone is aware of a fix, please let us know!
 
G

Guest

I'm not sure if this is the issue, but maybe. There is a k article that
describes this issue a bit when using delegates.

http://support.microsoft.com/?kbid=309185

I don't think this is it because not all of the troubled users have
delegates setup. This also appears to be happening on some of our mac
machines using Entorage. This leads me to believe it's a server thing. I
have tried running the /cleanfreebusy switch which worked for a couple of
users for a day or so an then reverted back to the slashes (///////) "No
Information", very strange

Our environment is also running Exchange 2003 SP2 not SP1. I was incorrect
in my last post.

So.......right now the 20 or so users having the issue the slashes appear
from June 1st on. This will change to July 1st once March is over. I have
verified that the GPO is set on those machines, both GUI and registry. I'm
still very stumped. Anyone have any thoughts? Ideas? or even a fix?

Thanks
 
S

sally.mcphillips

Here were our issues:

1) the user who could not see anyones f/b had moved to a different
Exchange server. The x400 address was still pointing to the previous
server. We realigned this to the new server and f/b came back for the
user.

2) the other users that had moved - their previous server had its
services stopped before uninstalling it. The Schedule+ Free Busy
public folder for that site was still pointing to the server with its
services stopped. Repointed it to the server that the users moved to
and f/b regenerated. Whew!
 
G

Guest

It may NOT be server side. We are having this issue with Free/Busy and we
don't use Exchange Server. We all have Outlook 2003 SP2 and publish
Free/Busy to our FTP server. 90% of the users work with no problems. 10%
have their .vfb file either not being written properly, saved or closed
properly. If you look at the file's icon it looks different than the others,
and it cannot be openned with notepad like the others can. It is always the
same people. We'ved also tried the /cleanfreebusy switch on their Outlook.
Any other clues would be helpful.
 
Ad

Advertisements

D

DougS

I have been looking into this issue at work and found a posting that
stated that if a user has a virgin calendar (they have never scheduled
an appointment...even with themselves) then other users will see "No
infromation" when scheduling a meeting with that person.

This worked for me:
I found a user who was showing no infomation. It so happened that the
user had no appointments (ever) in their calendar. I had the user
schedule a meeting with himself for a future date/time (save and close)
and waited the 15 minute default time to update free/busy. Then I tried
to schedule a meeting with that person and I was able to see free/busy.

I had also tried to schedule a meeting with the person and have them
Accept, but this did not appear to resolve the problem.

Hope this helps...
 
G

Guest

The calendars already had several events, and just to be sure, we scheduled
test meetings too.

We did find the culprit and solve the problem. The issue is in Outlook.
When you click on -> Tools - Options - Calendar Options - Free/Busy Options -
Check Publish - and fill in the location boxes, you must not have a space at
the end! Each user had copied and pasted the URL and it had a space at the
end of it. The URL format they used for both boxes was:
ftp://userid:p[email protected]/OutlookFreeBusyService/%name%.vfb

But they had a space at the end, and that is why the ftp log files had .vfb+
on the problem files. The ftp server thought there was an extra strange
character on the file extension. But if you tried to open, read, rename, or
update the file, it could not access it. This needs to go in a Microsoft KB
article and get addressed in an Outlook code fix. Outlook should ignore or
strip out starting or ending (trailing) spaces. Obviously it stumped us all!
It took us 8 weeks to figure this out.

Thanks for your support, and hopefully getting the word out and a code fix.
Jim
 
G

Guest

James ...good work!

Were any of your users able to post .vfb files successfully, but no read
them? This is the problem I have!

For us, everyone can post perfectly fine but on of the PC's cannot read
anyone's VFB files (even though the same PC can post them).

I even reformatted the hard drive and installed a fresh copy of XP and
Office 2003. But the PC STILL does not read VFB files but can post them. I'm
thinking it must have something to do with the .pst file since XP and Office
were fresh installs.

What makes things worse is that this is my fiance's machine and all I do is
work on this problem day and night ...I am getting tired! KB has no info on
this and
I've been here many many times. Sigh.

-Tony
 
G

Guest

Yes, we had those problems too, until we had really good instructions. You
can email me at Jim_Miller @ CSSus .com for the pretty word doc with
screen shots. But here is the text:

Outlook Calendar – Free/Busy Setup
------------------------------------------
When setting up a work schedule for yourself and team members, you need to
know when each team member is available. After all, to schedule a meeting,
you need to know when everyone is available.
What free/busy status looks like in Outlook 2003
In Microsoft Office Outlook 2003, free/busy status information refers to the
status of a block of time in someone's schedule. Different color coding and
shading indicate Busy, Tentative, Open, or Out of Office. When you click on
File – New – Meeting, there is a legend at the bottom of the Meeting dialog
box, showing the color coding.

Setup Outlook 2003 to publish and retrieve free/busy information
----------------------
We use a special folder on our internet web server, to store free/busy
information. Only free/busy status is stored there. No personal information
about your appointments is stored here. (These are simple small text files
that you can open with notepad and see that only blocks of time are stored
there.) Follow these steps:
1. In Outlook click Tools, E-mail Accounts, View/Change, Next, select your
business email account, click Change. Ensure that your E-mail Address box
has your first and last name capitalized. Ex. (e-mail address removed)
(This is the only text box that Free/Busy uses for file naming.)
2. Click Tools, Options, Preferences tab, Calendar Options, Free/Busy Options:
3. Set to Publish at least 6 months and at most every 15 minutes.
4. Click Publish at my location, and in the box, copy (or type) this exact
FTP URL: ftp://userid:p[email protected]/OutlookFreeBusyService/%name%.vfb
** Ensure that you do not have any spaces at the beginning or end of these
URL’s. The %name% variable permits Outlook 2003 to use the first part of the
e-mail address as the file name. For example, for (e-mail address removed), the
file name would be Fred_Flinstone.vfb.
5. In the Search location box, copy (or type) this same FTP URL. This is
how Outlook 2003 knows where to look for other users' free/busy information.
If the free/busy information is stored elsewhere for specific contacts, you
can designate the location for those contacts. (See more information below.)
6. Click OK in the three dialog boxes.

To test the connection between Outlook 2003 and your server
---------------------
On the Tools menu, point to Send/Receive and click Free/Busy Information.
Outlook 2003 informs you whether the free/busy information was published
successfully. If you an error message appears, check the URL and test the
connection again. Use your browser to see your .vfb file by going to:
ftp://userid:p[email protected]/OutlookFreeBusyService Ensure that it has capital
letters in the format of Fred_Flinstone.vfb If not, right click it and
deleted it and start over at the beginning.

To specify a free/busy location for specific contacts
---------------------------
1. For contacts with an ABC email address, you do not need to do this. Open
the Contacts folder, and open the contact. Click the Details tab to specify
(or “overrideâ€) the free/busy search folder for this contact.

2. In the Internet Free/Busy area, in the Address box, type the URL for the
contact's free/busy information. Do not use the wildcard %name%.vfb. Click
Save and Close. For example:
ftp://ftp.XYZclientInc.com/schedules/Barney_Rubble.vfb

Using free/busy in Outlook 2003 to schedule group meetings
---------------------------------------------------------------------
Now you are ready to start using Outlook 2003 to schedule meetings. Click
on File – New – Meeting, then the Scheduling tab to begin. Add attendees by
typing in their first and last name. Click on Tools – Check Names, to see
everyone’s free/busy timeslots. Note the AutoPick Next button at the bottom.
 
G

Guest

James, thank you for the document ...so many people would benefit from that
well-written doc.

Unfortunately, my situation is that everything was working fine on this one
PC but now suddenly it's not. My settings have been working for a year now
and they reflect what your document says, it's just that on PC stopped
READING .VFB files (it posts OK. The settings are a no-brainer for us; we've
been round and round on the settings - it's just that one PC simply will not
read VFB files and the others do (with identical settings).

I formatted the hard drive of the one PC and reloaded XP AND Office 2003 and
it STILL doesn't read them so it must have somethign to do with the .pst file
itself since that's the only thing in common with the previous install that
also didn't read VFB files. Funny thing, it did in the past, it just stopped
recently.

-Tony
 
Ad

Advertisements

G

Guest

I guess I'd try three things. Enable and examine the FTP server's log files
to see if this user's Outlook ever actually reads the vfb files. Rename your
pst file to originaloutlook.pst and letting outlook create a new one for
testing, since you find it suspect. Verify the vfb files have text in them
viewable with notepad and work with a new pst file.
 
G

Guest

Jim,

Yes, 3 of the 4 PC's are posting/reading VFB files ...so the VFB files are
there (with text).

Also, I did rename the .pst file and when Outlook recreated the .pst file,
it DID NOT read any .vfb files. I'm wondering if there's something in the
registry that's preventing it from working and that registry setting was
transferred somehow into the fresh install of XP and Office via the .pst
file? I say that because when the new .pst files was created, the URL for
posting .vfb files was magically already filled in!

I am close to giving up: I must have spent over 40 hours researching and
testing for this 1 PC.

Thanks for your suggestions, I do appreciate it.

-Tony
 
Ad

Advertisements

G

Guest

Here's a shot in the dark for you all to try... I had similar problems..

My issue was that I did not have an Internet MIME type set up to handle .vfb
files.

Here's how my setup goes:

Users publish their IFB info to a web site in Outlook to:
http://mydomain.com/freebusy/FirstLast.vfb

In the contact card on the "Details" tab that same URL is referenced in the
Internet free-busy address field.

I had to launch IIS admin for the server that hosted the
http://mydomian.com/freebusy virtual server, went to HTTP Headers tab and
added a mime type for extension ".vfb" and content type "text/calendar"

Voila! Free/Busy info populated on a remote system for that user.

Before going through the hassle of setting this up, you can test if this is
your problem by doing this:

throw the url to your users .vfb file into an internet browser, if you get a
404 then you need to add the MIME type, if you are prompted to download an
iCalendar file then your MIME type is configured properly and you've got
anothe problem. (more than likely a permissions problem on the ACL for the
file system location where your IFB info is stored or no anonymous access
allowed on the IIS VS)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top