Outlook 2003: Can't create Data File

Discussion in 'Microsoft Outlook Discussion' started by Thomas Adams, Jan 14, 2008.

  1. Thomas Adams

    Thomas Adams Guest

    Hi

    How do you debug/fix the problem that Outlook 2003 can't create a Data File?

    Control Panel/Mail/Data Files/Add gives you the New Outlook Data File dialog
    box with an empty Types of storage area. I seem to remember that I should be
    able to select PST here.

    This is Windows XP MCE 2005 + Outlook 2003. Both have all the latest patches
    applied. Reinstalling or Repairing Outlook did not help. New Mail profile
    and/or new mail accounts did not help neither.

    I'm grateful for any advice apart from "reinstall Windows".

    Thanks!
     
    Thomas Adams, Jan 14, 2008
    #1
    1. Advertisements

  2. Thomas Adams

    K. Orland Guest

    Did you browse to the location of your PST? I don't know what O/S you're
    using but for Windows 2000 & Windows XP look in:

    C:\Documents and Settings\yourWindowsusernamegoeshere\Local
    Settings\Application Data\Microsoft\Outlook

    Note that you may have to unhide hidden files & folders using Windows
    Explorer. At the same time, make sure you're not hiding file extensions for
    known file types.

    Once you have located the PST and verified it, open Outlook and use File >
    Open, browse to your PST, and have Outlook open it.

    Good luck. Let me know how you make out.
     
    K. Orland, Jan 14, 2008
    #2
    1. Advertisements

  3. Thomas Adams

    phammo1

    Joined:
    Jan 23, 2008
    Likes Received:
    0
    I had exactly the same problem (except I'm using Windows XP Pro SP2). Tried uninstalling/reinstalling Office, but it seems that even after uninstall some traces of Outlook remain. So I uninstalled again, went into the registry and deleted the entire HKLM Outlook section. Then I reinstalled Office.

    Outlook still gave an error when started, but now I could manually create a .PST file in the Control Panel, i.e. the "Types of Storage" box was no longer empty. After that, Outlook worked normally.

    I don't know if it's relevant, but this PC previously had Office 2007 on it, which I had uninstalled before installing Office 2003..

     
    phammo1, Jan 23, 2008
    #3
  4. Thomas Adams

    srini.ms

    Joined:
    Feb 26, 2008
    Likes Received:
    0
    Finally the Solution

    Orginal Solution is here------------------------------------***********************-------------------------------

    In order to fix this error you have to rename ‘mapisvc.inf’ one in

    C:\Windows\System32,
    and one in
    C:\Program Files\Common Files\System\MSMAPI\1033
    Once you rename these files start outlook again and it will reinstall the correct versions of the file

    Then you can able to acces the Types of storage list for creating pst









    ------------------------------------***********************-------------------------------
     
    srini.ms, Feb 26, 2008
    #4
  5. Thomas Adams

    BigKidSerious

    Joined:
    Dec 17, 2008
    Likes Received:
    0
    Types of Storage FIXED thanks

    Great info thanks srini.ms.

    Fixed it.

    My situation was:

    I had also removed the trial version of Office 2007, loaded Office 2003 professional. When I opened Outlook 2003 it recognised my Outlook.pst file automatically but there was no Archive Folders in the folder list. Then tried to add the data file but going to the default folder location I was prompted to select the "type of storage" but it was blank.

    Perhaps worth noting is that when I installed Office 2003 I had option to leave or remove some temporary installation information on the hard drive. By leaving this I think it means that I did not need to have the disk at hand.

    BKS
     
    BigKidSerious, Dec 17, 2008
    #5
  6. Thomas Adams

    BMS

    Joined:
    Jan 11, 2009
    Likes Received:
    0
    Still no luck creating data file..

    Hi srini.ms and BKS

    I've spent half my weekend trying to restore my archive.pst, same problem (Type of storage empty) in Add Data file.. So I tried your -apparently proven- solution. Renamed the mapisvc.inf to mapisvc.inf.OLD in both locations.
    Reopening Outlook doesn't seem to create new files, and doesn't fix the problem. Instead I get an error 0x80070002 when hitting 'Add' in Outlook Data Files. Clicking OK takes me to an empty Type of Storage - as before.

    I was thinking to reinstall Office 2003 tomorrow, but seems like others were not successfull in doing that.

    So if you have any further suggestions..

    Thanks, BMS

    UPDATE: after some reboots Outlook suddenly asked for the installation CD.. that did the trick so my archives are back . Thanks all for the coop.
     
    Last edited: Jan 12, 2009
    BMS, Jan 11, 2009
    #6
  7. Thomas Adams

    amclean

    Joined:
    Jan 12, 2009
    Likes Received:
    0
    I have recently had the same issue following the installation of a email archiving system that has an option to prevent the use of PST files. A registry key (DisablePST = 1) was added and set to prevent the creation of PST files and hence no data types appeared in the list. As soon as I modified the value of the registry key back to 0, I was able to add PST files again. You need to make the change to all versions of the key.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Outlook
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\10.0\Outlook
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\11.0\Outlook
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0\Outlook
     
    amclean, Jan 12, 2009
    #7
  8. Thomas Adams

    thunderhawk

    Joined:
    May 14, 2009
    Likes Received:
    0
    Location:
    Singapore
    I'm also faced the same problem and solved by srini.ms's solution.

    Thanks You Srini.ms.

     
    thunderhawk, May 14, 2009
    #8
  9. Thomas Adams

    MarvinJ

    Joined:
    Dec 3, 2009
    Likes Received:
    0
    Thanks amclean. Your solution worked for my Citrix servers.
     
    MarvinJ, Dec 3, 2009
    #9
  10. Thomas Adams

    juliei

    Joined:
    Jun 4, 2010
    Likes Received:
    0
    worked!!

    Thanks very much because this worked quickly and perfectly! This issue also happened to me when I uninstalled office 2007 before installing office 2003.
    Regards.

     
    juliei, Jun 4, 2010
    #10
  11. Thomas Adams

    dirk99pitt

    Joined:
    Jan 23, 2011
    Likes Received:
    0
    Fixed my problem on a new pc running Windows 7. Had a trail 2007 Office that I removed so I could install 2003 Office. Couldn't add my pst file from my old computer. Renamed the files as suggestted below, went to Control Panel > Mail and was able to setup data file from there.

    Thanks

     
    dirk99pitt, Jan 23, 2011
    #11
  12. Thomas Adams

    GreaterD

    Joined:
    Mar 1, 2011
    Likes Received:
    0
    How I fixed the Outlook not opening
    Background info:
    Outlook would not allow me to open the program by simply clicking on the icon.
    It gave me a message of not being able to fix the data file.

    So I renamed the files to add .old at the end of the file name just as this explains
    ===============================================================
    Orginal Solution is here------------------------------------***********************-------------------------------

    In order to fix this error you have to rename ‘mapisvc.inf’ one in

    C:\Windows\System32,
    and one in
    C:\Program Files\Common Files\System\MSMAPI\1033
    Once you rename these files start outlook again and it will reinstall the correct versions of the file
    ===============================================================

    Then you can able to acces the Types of storage list for creating pst

    Then, I went to the mail app in control panel and added the personal files(1).pst liked it walked me through. Then I could get in. if I were creating a brand new .PST file and didn’t need to pull items from another .PST file from another computer or user, I could have stopped here. But because I had already copied the Outlook.pst file from the other computer, I needed to use that. So, through Outlook, I opened the other Outlook.pst file that I moved from the other computer so that I had both PST files open at once in Outlook. I then transferred the few e-mails that I received during the course of time. Then went back into Control PanelMailData Files and changed the default to the already existing .PST folder, and then removed the .PST just made. Opened Outlook and adjusted settings for mail retrieval and such.
     
    GreaterD, Mar 1, 2011
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.