No Printers Installed Error; Print Spooler Problem?


J

JuliusPIV

We've seen an increase in the number of calls from our users stating that
when they try to print from Outlook 2007 (Windows XP SP3 + all Updates) they
receive an error stating that there are no printers installed. However, they
not only have multiple printers installed, but they also have a default
printer defined. Restarting the print spooler fixes this problem but its not
clear what caused it to begin with. When we stop and eventually restart the
spooler, we notice it hangs for a while when stopping and the following
appears in the Event Viewer:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7011
Date: 10/20/2009
Time: 9:38:48 AM
User: N/A
Computer: XX-YYY-123456
Description: Timeout (30000 milliseconds) waiting for a transaction response
from the Spooler service.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7011
Date: 10/20/2009
Time: 9:39:18 AM
User: N/A
Computer: XX-YYY-123456
Description: Timeout (30000 milliseconds) waiting for a transaction response
from the service.

Related to this, last week we received a number of calls from users telling
us that their machines hung during the login process once entering their
credentials. Waiting even 20 minutes didn't fix the problem, and rebooting
the machine took care of it. We have a lengthy login script so I added lines
surrounding, and within, the various functions, calls, WMI queries etc within
to figure out what might be causing the problem. Turns out, when the script
got to the point where it enumerated the printer list, it hung the machine.
(Code below at the bottom.) Once commented out this code, users were logging
in fine, and the same timeout error above appeared in the login script. What
gives!?

Sounds to me like we have a possible spooler problem, but aside from
removing & readding printers and their drivers, I'm not quite sure where else
to look, or why this only affects a small percentage of our population, and
more importantly, all of a sudden. I'm open to suggestions.

//*Login Script Snippet
login_printer_list= ""
Set colSettings = objWMIService.ExecQuery ("Select * from Win32_Printer")
' I previously had a 'debug' function that would write to a log file
' just before the For Each statment listing. While the log
' contained the line stating it was starting the process...
For Each objWMI_Item in colSettings
' It didn't process anything beyond the above code as. Where this
' comment is, I had another line where it would output
' objWMI_Item.name in the debug log.
login_printer_list= login_printer_list & "--" & objWMI_Item.name
If objWMI_Item.Default = True Then login_default_printer=objWMI_Item.name
Next
---EOF

Any help is greatly appreciated.
 
Ad

Advertisements

K

Kathleen Orland

Have you tried stopping and restarting the Spooler service on the PC's in
question?

Have you tried to delete some old spool jobs in the folder:
C:\WINNT\System32\Spool\PRINTERS\*.SHD and *.SPL?
 
J

JuliusPIV

Hi Kathleen - thanks for taking a moment to read and respond!

Quickly to answer your qestions:
Yes - restarting the spooler seems to 'fix' the problem. (I don't know if
we've had repeat callers...)
No - I didn't think to check for those file types, but thanks for reminding
me! I'll let our Help Desk know to check next time they get calls.

RE: Spooler -
When we stop the spooler, that's when we see the 'Timeout (30000
miliseconds)' entry in the Event Viewer. In fact, it never actually finishes
stopping. We let it sit for a few minutes then click close. The service at
that point is indeed in the 'stopped' state so from there, we start it up,
and now printing works.

In some instances, once its evident a PC in question is experiencing this
problem, the system doesn't seem to behave normally. For instance, we cannot
open the 'Printers & Faxes' window and Explorer.exe appears or seems to
crash/hang. (partial responsiveness to clicks, Start Menu frozen etc) In
the latter cases, we were able to restart the print spooler remotely at which
point the machine immediately resumed normal operation. (Pritners & Faxes
window pops up, Start Menu opens & closes a few times depending on how many
clicks we issued etc)

We recently upgraded to a Lexmark T644 XL driver from the [older(?)] Lexmark
T644 driver. We're investigating whether or not it may be related, and
devising ways of testing, since we cannot reproduce the problem at will.
 
K

Kathleen Orland

In addition, You might want to consider opening the printers folder,
deleting all the drivers (File > Server Properties), and then restarting the
PC.
 
Ad

Advertisements

J

JuliusPIV

Thanks for sort of following this thread.

I'm going to repost this in a more appropriate area as its not specific to
Outlook.

Unfortunately, there are never any *.SHD or *.SPL files in
%WINDIR%\System32\Spool\PRINTERS, and wiping out that location, along with
all the printers, and readding them doesn't seem to fix the problem.

Further more, as I may have previously mentioned, stopping & starting the
spooler service on the PC's in question fixes the problem but only after it
happens. If it happens again, the machine is hung, and we need to restart
the spooler service again. Wash, Rinse, Repeat.

This spooler hang-up happens multiple times a day to a number of users, and
without being able to repeat the problem at will for testing, it makes it
difficult to solve.

Again, thanks for the comments. If you come up with something, let me know.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top